Bug 964595 - [vdsm] add dependency on the new iscsiadm package
[vdsm] add dependency on the new iscsiadm package
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: vdsm (Show other bugs)
3.2.0
x86_64 Linux
unspecified Severity high
: ---
: 3.3.0
Assigned To: Saggi Mizrahi
Jiri Belka
infra
: Triaged
Depends On: 983553
Blocks: 3.3snap4
  Show dependency treegraph
 
Reported: 2013-05-19 04:18 EDT by Liron Aravot
Modified: 2016-02-10 14:23 EST (History)
11 users (show)

See Also:
Fixed In Version: is26
Doc Type: Bug Fix
Doc Text:
After deleting the iscsi storage, ISCSIADM operations got stuck and wouldn't end.This caused connectStoragePool/GetDeviceList to fail on timeout. This has been fixed by removing forceIscsiScan() as iscsiadm already does that when refreshing sessions, and rewriting the logic with a simpler implementation.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 11:07:13 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Logs for the host that turned to unassigned after removing storage (5.93 MB, application/zip)
2013-05-19 04:45 EDT, GenadiC
no flags Details
Logs for the host that stayed in the up state after removing storage (2.31 MB, application/zip)
2013-05-19 04:46 EDT, GenadiC
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 19254 None None None Never
oVirt gerrit 19256 None None None Never
oVirt gerrit 21135 None None None Never
oVirt gerrit 21136 None None None Never

  None (edit)
Description Liron Aravot 2013-05-19 04:18:48 EDT
Description of problem:
After deletion of iscsi storage (not from engine) - ISCSIADM operation got stuck and won't end.
this causes that connectStoragePool/GetDeviceList fail on timeout

Version-Release number of selected component (if applicable):
si17
vdsm-xmlrpc-4.10.2-19.0.el6ev.noarch
vdsm-cli-4.10.2-19.0.el6ev.noarch
vdsm-4.10.2-19.0.el6ev.x86_64
vdsm-python-4.10.2-19.0.el6ev.x86_64
rhevm-3.2.0-10.26.rc.el6ev.noarch

Steps to Reproduce:
1. iscsi pool - two hosts, one domain, pool is up
2. delete the iscsi storage
  
Actual results:
1. connectStoragePool always fail on timeout
2. getDeviceList doesn't work
3. lock queue on vdsm grows indefinitely.
Comment 1 GenadiC 2013-05-19 04:45:20 EDT
Created attachment 749983 [details]
Logs for the host that turned to unassigned after removing storage
Comment 2 GenadiC 2013-05-19 04:46:18 EDT
Created attachment 749988 [details]
Logs for the host that stayed in the up state after removing storage
Comment 3 Barak 2013-07-29 09:45:44 EDT
Saggi,

It looks like the patch for iscsiadm will get into 6.5,
So we need to send a patch for VDSM to sdjust.
Comment 5 Jiri Belka 2013-12-10 05:39:40 EST
ok, is26.

# rpm -q vdsm ; rpm -qR vdsm | grep ^i
vdsm-4.13.2-0.1.rc.el6ev.x86_64
initscripts >= 9.03.31-2.el6_3.1
iproute  
iscsi-initiator-utils >= 6.2.0.873-3
Comment 6 errata-xmlrpc 2014-01-21 11:07:13 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0040.html

Note You need to log in before you can comment on or make changes to this bug.