Bug 983553 - iscsiadm gets stuck on D state when refreshing targets if target is unavailable [NEEDINFO]
iscsiadm gets stuck on D state when refreshing targets if target is unavailable
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: iscsi-initiator-utils (Show other bugs)
6.5
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Chris Leech
Bruno Goncalves
:
Depends On:
Blocks: 964595
  Show dependency treegraph
 
Reported: 2013-07-11 09:10 EDT by Saggi Mizrahi
Modified: 2013-11-21 18:10 EST (History)
7 users (show)

See Also:
Fixed In Version: iscsi-initiator-utils-6.2.0.873-3.el6
Doc Type: Enhancement
Doc Text:
Feature: Target rescans run asynchronously. Reason: A single unreachable target could previously block rescans of others. Now functioning sessions will rescan properly without long delays. Result (if any):
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-21 18:10:05 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
cleech: needinfo? (smizrahi)


Attachments (Terms of Use)

  None (edit)
Description Saggi Mizrahi 2013-07-11 09:10:38 EDT
Description of problem:
In order to refresh targets iscsiadm pokes all the devices and targets for updates sequentially. If one is not responding iscsiadm will block forever and not refresh the rest of the targets.

Version-Release number of selected component (if applicable):


How reproducible:
101%

Steps to Reproduce:
1. Connect to a couple of targets
2. Set the firewall to drop packets going to a specific target
3. run: iscsiadm -m session -R
4. profit

Actual results:
iscsiadm gets stuck in D state and the rest of the targets remain unscanned.

Expected results:
iscsiadm should be killable and the all targets should be updated.

Additional info:
Comment 1 Saggi Mizrahi 2013-07-11 09:12:07 EDT
Patches have been sent upstream to: http://comments.gmane.org/gmane.linux.iscsi.open-iscsi/8410
Comment 6 Saggi Mizrahi 2013-09-16 04:37:26 EDT
http://gerrit.ovirt.org/#/c/19256/
Comment 10 Bruno Goncalves 2013-10-25 03:29:38 EDT
Passed on regression test using

kernel 2.6.32-424.el6

rpm -q iscsi-initiator-utils
iscsi-initiator-utils-6.2.0.873-10.el6.x86_64
Comment 11 errata-xmlrpc 2013-11-21 18:10:05 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1700.html

Note You need to log in before you can comment on or make changes to this bug.