Bug 964638 - Since some days, alert boxes are presented with black and white icons only
Since some days, alert boxes are presented with black and white icons only
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gnome-icon-theme (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Dan Mashal
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks: F19Beta-accepted/F19BetaFreezeException
  Show dependency treegraph
 
Reported: 2013-05-19 06:15 EDT by Joachim Backes
Modified: 2013-05-20 22:50 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-20 22:50:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
layout of the altert box (11.63 KB, image/png)
2013-05-19 06:15 EDT, Joachim Backes
no flags Details

  None (edit)
Description Joachim Backes 2013-05-19 06:15:23 EDT
Created attachment 750020 [details]
layout of the altert box

Description of problem:
Since some F19 days, alerts boxes appear with b/w icons, but no more with
colored icons (for example red for the stop sign or yellow for a warning sign).

Version-Release number of selected component (if applicable):
gnome-icon-theme-3.8.2-1.fc19.noarch

How reproducible:

Example: ssh to some some site (whith gnome-terminal) requesting a password, and try to kill the window during the password is requested. Then an altert box appears with a b/w icon.

Steps to Reproduce:
1.see description
2.
3.
  
Actual results:
see description

Expected results:


Additional info:
Comment 1 Dan Mashal 2013-05-20 13:10:04 EDT
If you do yum downgrade gnome-icon-theme and reboot does that solve the issue?
Comment 2 Joachim Backes 2013-05-20 13:38:35 EDT
I did downgrade and reboot, but

same effect with gnome-icon-theme-3.7.91-1.fc19.noarch and gnome-icon-theme-legacy-3.7.91-1.fc19.noarch.

Who the hell could be the culprint?
Comment 3 Dan Mashal 2013-05-20 14:31:08 EDT
Gnome/anaconda devs. gnome-icon-theme was updated recently. I will look into it further.
Comment 4 Dan Mashal 2013-05-20 14:40:08 EDT
This seems to also be affecting live CD composes as well (running anaconda has blank icons).
Comment 5 Adam Williamson 2013-05-20 15:11:44 EDT
So the bug Dan is actually concerned about here for FE status is http://i.imgur.com/epaGfX8.png - generic/incorrect icons being used in anaconda when running from the MATE live image - and I'm not sure that actually has much or anything to do with changes in gnome-icon-theme . We may want to open a separate bug for that.

I think this particular "bug" may not be a bug at all, AIUI the icon in the OP's screenshot and others were intentionally changed to grey in recent gnome-icon-theme.
Comment 6 Matthias Clasen 2013-05-20 15:19:28 EDT
Indeed: not a bug, its an intentional change.
Comment 7 Adam Williamson 2013-05-20 22:48:43 EDT
For the record, I filed https://bugzilla.redhat.com/show_bug.cgi?id=965358 for the MATE thing.

Note You need to log in before you can comment on or make changes to this bug.