Bug 964763 - SELinux is preventing /usr/libexec/postfix/cleanup from read, write access on the file /var/spool/postfix/pid/unix.cleanup.
SELinux is preventing /usr/libexec/postfix/cleanup from read, write access on...
Status: CLOSED DUPLICATE of bug 964679
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:c4778184ef63297b97f3c9180db...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-19 12:48 EDT by Juan Orti
Modified: 2013-05-20 05:18 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-20 05:18:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Juan Orti 2013-05-19 12:48:26 EDT
Description of problem:
SELinux is preventing /usr/libexec/postfix/cleanup from read, write access on the file /var/spool/postfix/pid/unix.cleanup.

*****  Plugin catchall (100. confidence) suggests  ***************************

If cree que de manera predeterminada, cleanup debería permitir acceso read write sobre  unix.cleanup file.     
Then debería reportar esto como un error.
Puede generar un módulo de política local para permitir este acceso.
Do
permita el acceso momentáneamente executando:
# grep cleanup /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:postfix_cleanup_t:s0
Target Context                system_u:object_r:postfix_var_run_t:s0
Target Objects                /var/spool/postfix/pid/unix.cleanup [ file ]
Source                        cleanup
Source Path                   /usr/libexec/postfix/cleanup
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           postfix-2.9.6-4.fc18.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.11.1-95.fc18.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 3.9.2-200.fc18.x86_64 #1 SMP Mon
                              May 13 13:59:47 UTC 2013 x86_64 x86_64
Alert Count                   47
First Seen                    2013-05-19 18:00:19 CEST
Last Seen                     2013-05-19 18:47:06 CEST
Local ID                      63a8799a-4358-4cbf-9d01-7e80a96873a8

Raw Audit Messages
type=AVC msg=audit(1368982026.378:1727): avc:  denied  { read write } for  pid=20637 comm="cleanup" name="unix.cleanup" dev="dm-2" ino=6162974 scontext=system_u:system_r:postfix_cleanup_t:s0 tcontext=system_u:object_r:postfix_var_run_t:s0 tclass=file


type=SYSCALL msg=audit(1368982026.378:1727): arch=x86_64 syscall=open success=no exit=EACCES a0=7fde2b458b20 a1=2 a2=0 a3=11 items=0 ppid=9938 pid=20637 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 ses=4294967295 tty=(none) comm=cleanup exe=/usr/libexec/postfix/cleanup subj=system_u:system_r:postfix_cleanup_t:s0 key=(null)

Hash: cleanup,postfix_cleanup_t,postfix_var_run_t,file,read,write

audit2allow

#============= postfix_cleanup_t ==============
allow postfix_cleanup_t postfix_var_run_t:file { read write };

audit2allow -R
require {
	type postfix_cleanup_t;
	type postfix_var_run_t;
	class file { read write };
}

#============= postfix_cleanup_t ==============
allow postfix_cleanup_t postfix_var_run_t:file { read write };


Additional info:
hashmarkername: setroubleshoot
kernel:         3.9.2-200.fc18.x86_64
type:           libreport

Potential duplicate: bug 960894
Comment 1 Miroslav Grepl 2013-05-20 05:18:43 EDT

*** This bug has been marked as a duplicate of bug 964679 ***

Note You need to log in before you can comment on or make changes to this bug.