Bug 964947 - GUI spinner lets you increase the quantity of virtual to pool to 2 ,when total available quantity is only 1
GUI spinner lets you increase the quantity of virtual to pool to 2 ,when tota...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager (Show other bugs)
5.10
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Devan Goodwin
IDM QE LIST
:
Depends On:
Blocks: rhsm-rhel510
  Show dependency treegraph
 
Reported: 2013-05-20 03:44 EDT by Shwetha Kallesh
Modified: 2013-09-30 19:09 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
No description necessary
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-30 19:09:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
GUI spinner let you increase the quantity of Virtual pool to 2 (113.42 KB, image/png)
2013-05-20 03:44 EDT, Shwetha Kallesh
no flags Details
Error when you try to subscribe to 2 quantities of sub-pool (94.49 KB, image/png)
2013-05-20 03:47 EDT, Shwetha Kallesh
no flags Details
GUI-Spinner Instance Based (116.24 KB, image/png)
2013-07-19 13:57 EDT, Sharath Dwaral
no flags Details

  None (edit)
Description Shwetha Kallesh 2013-05-20 03:44:03 EDT
Created attachment 750433 [details]
GUI spinner let you increase the quantity of Virtual pool to 2

Description of problem:
GUI spinner lets you increase the quantity of virtual to pool to 2 ,when total available quantity is only 1,when you try to attach GUI throws an error

Version-Release number of selected component (if applicable):
[root@localhost ~]# subscription-manager version
server type: Red Hat Subscription Management
subscription management server: 0.8.7-1
subscription-manager: 1.8.7-1.git.45.1094dd0.el5
python-rhsm: 1.8.11-1.git.1.7236cc2.el5


How reproducible:


Steps to Reproduce:
1.subscription-manager-gui
2.In available subscription tab,select Instance based subscription and increase the quantity of sub-pool in contract selection dialogue
3.

Actual results:
Lets to you increase the quantity to 2

Expected results:
Should not let you increase the quantity as available quantity is 1

Additional info:
Screen shots in the attachment
Comment 1 Shwetha Kallesh 2013-05-20 03:47:11 EDT
Created attachment 750437 [details]
Error when you try to subscribe to 2 quantities of sub-pool
Comment 2 RHEL Product and Program Management 2013-05-20 12:42:07 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 3 Devan Goodwin 2013-06-05 11:44:52 EDT
I think this has been fixed by the same fix as for bug #963535. I can no longer get it to happen. The contract selector defaults to 1 if only 1 is available and will not let me increase the value for the subscription that only has one left.
Comment 5 Sharath Dwaral 2013-07-19 13:57:52 EDT
Created attachment 775906 [details]
GUI-Spinner Instance Based

Version :

# rpm -qa | egrep "subscription-manager|python-rhsm"
subscription-manager-debuginfo-1.8.13-1.el5
subscription-manager-gui-1.8.13-1.el5
subscription-manager-firstboot-1.8.13-1.el5
python-rhsm-1.8.13-1.el5
subscription-manager-migration-1.8.13-1.el5
subscription-manager-1.8.13-1.el5
python-rhsm-debuginfo-1.8.13-1.el5

Verifcation:

See Attachment. This bug is fixed and no longer reproducible. Comment 3

Marking Verified
Comment 7 errata-xmlrpc 2013-09-30 19:09:32 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1332.html

Note You need to log in before you can comment on or make changes to this bug.