Bug 965268 - buglist.cgi doesn't show params anymore
buglist.cgi doesn't show params anymore
Status: CLOSED CURRENTRELEASE
Product: Bugzilla
Classification: Community
Component: Query/Bug List (Show other bugs)
4.4
Unspecified Unspecified
unspecified Severity unspecified (vote)
: ---
: ---
Assigned To: Simon Green
tools-bugs
: Reopened
: 966012 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-20 15:41 EDT by Scott Haines
Modified: 2015-01-22 10:29 EST (History)
9 users (show)

See Also:
Fixed In Version: 4.4-3.2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-24 02:23:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Mozilla Foundation 875217 None None None Never

  None (edit)
Description Scott Haines 2013-05-20 15:41:07 EDT
When doing any type of query / bug list, the default URL always results in "https://bugzilla.redhat.com/buglist.cgi".
Comment 1 Scott Haines 2013-05-20 16:36:05 EDT
I see that I have workarounds available to me, so certainly not a blocker:

1) Click on "Edit Search" at the bottom and share that URL
2) Do the same thing, but change the URL part that says "query.cgi" to "buglist.cgi"
3) Give the search a name and click on [ Remember Search ]
Comment 2 Simon Green 2013-05-20 19:29:27 EDT
From what I can see, it has been like this since 2008. Here is the upstream commit
http://bzr.mozilla.org/bugzilla/4.4/revision/6228.

However, Bugzilla does a redirect (see above) to show the complete URL in all its glory.

If you are still having a problem can you please let me know:

1) The version of the browser you are using (from the about: dialog)
2) The URL that you get at the end of step one.
3) Any extensions you are running in your browser.
Comment 3 Simon Green 2013-05-21 02:32:49 EDT
Changing the status of this after some more investigation (it happened to me to). The upstream I linked to above was replaced with http://bzr.mozilla.org/bugzilla/4.4/revision/7635

There are some cases where the POST isn't redirected. One of them is when you are not logged in.

  -- simon
Comment 4 Simon Green 2013-05-23 02:04:50 EDT
Re-opening. Turns out that it also happens on newer browsers too.

Upstream bug: https://bugzilla.mozilla.org/show_bug.cgi?id=730670

Workaround: Look at the source HTML and look for the history.replaceState statement.

  -- simon
Comment 5 wangjing 2013-05-23 02:59:56 EDT
(In reply to Scott Haines from comment #1)
> I see that I have workarounds available to me, so certainly not a blocker:
> 
> 1) Click on "Edit Search" at the bottom and share that URL
what are the steps to 'share that URL'?

> 2) Do the same thing, but change the URL part that says "query.cgi" to
> "buglist.cgi"
what is 'do the same thing'?

thanks!
Comment 6 Simon Green 2013-05-23 03:06:32 EDT
Patch submitted upstream. Hopefully the will commit it tonight, and we can pull it in tomorrow.
Comment 7 wangjing 2013-05-23 04:25:36 EDT
(In reply to wangjing from comment #5)
> (In reply to Scott Haines from comment #1)
> > I see that I have workarounds available to me, so certainly not a blocker:
> > 
> > 1) Click on "Edit Search" at the bottom and share that URL
> what are the steps to 'share that URL'?
> 
> > 2) Do the same thing, but change the URL part that says "query.cgi" to
> > "buglist.cgi"
> what is 'do the same thing'?
> 
> thanks!

IRC contact Simon, this issue happened on bz-stage/bzweb01-devel/partner/prod env on current version 4.4.rc2-3.1, except bzweb01-qe env.
Comment 8 Shirley Zhou 2013-05-23 05:40:22 EDT
Provide more information here:

This bug does not exist on old browser: firefox 3.6.24, and when I tried with google chrome Version 25.0.1364.172, it does exist.
Comment 9 Cui Chun 2013-05-23 05:57:23 EDT
(In reply to Shirley Zhou from comment #8)
> Provide more information here:
> 
> This bug does not exist on old browser: firefox 3.6.24, and when I tried
> with google chrome Version 25.0.1364.172, it does exist.

Meet the same issue on Firefox 19.0.2.
Comment 10 Simon Green 2013-05-23 06:36:44 EDT
(In reply to Shirley Zhou from comment #8)
> Provide more information here:
> 
> This bug does not exist on old browser

These are the minimum versions that support history.replaceState, which is what is causing problems.

"Up-to-date copies of Chrome (5+), Safari (5.0+), Firefox (4.0+), and Opera (11.50+) have support for the new History API. Even some mobile browsers work just fine, like Mobile Safari on iOS 4+. Unfortunately, IE 9 and below lack support, but it should work in IE 10 when it arrives." (source http://html5doctor.com/history-api/#browser-support ).

I have not independently verified this though.

(In reply to wangjing from comment #7)
> IRC contact Simon, this issue happened on
> bz-stage/bzweb01-devel/partner/prod env on current version 4.4.rc2-3.1,
> except bzweb01-qe env.

That's not what I said

16:28 <@simon> jingwang: But as I mentioned it doesn't affect 
               the QE server. It only affects partner-bugzilla and the  live 
               servers.
Comment 11 wangjing 2013-05-23 08:06:35 EDT
(In reply to Simon Green from comment #10)
> (In reply to wangjing from comment #7)
> > IRC contact Simon, this issue happened on
> > bz-stage/bzweb01-devel/partner/prod env on current version 4.4.rc2-3.1,
> > except bzweb01-qe env.
> 
> That's not what I said
> 
> 16:28 <@simon> jingwang: But as I mentioned it doesn't affect 
>                the QE server. It only affects partner-bugzilla and the  live 
>                servers.

why doesn't it affect the QE server?
Comment 12 Simon Green 2013-05-23 08:46:04 EDT
(In reply to wangjing from comment #11)
> why doesn't it affect the QE server?

It only occurs when the user accesses a secure server, but the server itself is not. This is the case with partner-bz and live servers where there is a proxy server between the user and the bugzilla webserver.

On the QE server (and all other internal servers), there is no proxy server between the server and the user.

  -- simon
Comment 14 Simon Green 2013-05-23 23:54:01 EDT
*** Bug 966012 has been marked as a duplicate of this bug. ***
Comment 15 wangjing 2013-05-24 01:48:18 EDT
Verified on partner env version 4.4-3.2(20130524.2) --> Pass

Verify steps:
1. login as redhat account.
2. open 'Advanced search' page, set the conditions 'Status: NEW, ASSIGNED'.
3. click search button, and check the URL of the buglist.

then expected results: the URL of the buglist should not be like this:'https://xxx-bugzilla.redhat.com/buglist.cgi', the params should also be shown in the URL, like: 'https://xxx/buglist.cgi?list_id=1148624&query_format=advanced&bug_status=NEW&bug_status=ASSIGNED'.

4. click 'my bugs' link at the bottom of the page.
5. click 'Edit Search' at the bottom of the buglist.
6. on the returned search page click button 'search'.
7. check the URL of the buglist.

then expected results: the URL of the buglist should not be like this:'https://xxx-bugzilla.redhat.com/buglist.cgi', the params should also be shown in the URL, like: 'https://xxx/buglist.cgi?bug_status=NEW&bug_status=VERIFIED&bug_status=ASSIGNED&bug_status=MODIFIED&bug_status=ON_DEV&bug_status=ON_QA&bug_status=RELEASE_PENDING&bug_status=POST&email1=jingwang%40redhat.com&emailtype1=exact&emailassigned_to1=1&emailreporter1=1&emailcc1=1&list_id=1220859'.

8. Preferences->Saved Searches->click 'edit' of one saved search.
9. click search button.
10. check the URL of the buglist.

then expected results: the URL of the buglist should not be like this:'https://xxx-bugzilla.redhat.com/buglist.cgi', the params should also be shown in the URL,

Actual results:
after step7: there is one extra param 'query_format=advanced' in URL.
other results are same with expected results.

Note You need to log in before you can comment on or make changes to this bug.