Bug 9655 - diff is giving incorrect output
Summary: diff is giving incorrect output
Status: CLOSED DUPLICATE of bug 9212
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel   
(Show other bugs)
Version: 6.2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Cristian Gafton
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-02-21 19:59 UTC by Graham Cole
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-24 02:12:56 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Graham Cole 2000-02-21 19:59:47 UTC
when doing a "diff -uNr" on 2 directories that should be the same, diff
will claim that 2 files are different, but when i tried to verify that with
cmp file1 file2, the files compare successfully.

I pulled an iso image from a cdrom using "dd if=/dev/cdrom of=image.iso"
then I mounted the image over loopback using "mount -t iso9660 -o
ro,loop=/dev/loop0 image.iso /mnt/image"  then mounted the cdrom, and then
did a "diff -uNr /mnt/image /mnt/cdrom"

in fact, when I mount the same image twice over loopback under seperate
directories, I still get errors with diff, so I believe it is a problem
with diff itself.

Comment 1 Graham Cole 2000-02-22 01:33:59 UTC
I don't think this is a diff problem anymore.  I copied the directory twice to
an ext2 filesystem (cp -dpr) from the directories where the images were mounted,
and some of the files were not copied (certian files were missed on each run).
I imagine it may be something wrong with mounting files over loopback or
possibly something with the iso9660 filesystem support.

I'm going to burn a second copy of the cd, mount one in a cd drive and the other
in my cdrw and then diff it and see what happens.

Comment 2 Graham Cole 2000-02-22 02:16:59 UTC
Still getting similar results with 2 mounted cd's.
so it's independant of loopback.  Probably something with the iso9660 fs module.
I only have CD that this happens on, so it may be that there is something wrong
with that CD as well.

Comment 3 Graham Cole 2000-02-22 02:20:59 UTC
did some reseach.  This bug looks VERY similar to Bug #9212

Comment 4 Preston Brown 2000-02-23 15:14:59 UTC
gafton, either figure this out or pass to dledford.

Comment 5 Cristian Gafton 2000-02-24 02:12:59 UTC
*** This bug has been marked as a duplicate of 9212 ***


Note You need to log in before you can comment on or make changes to this bug.