Bug 965805 - factories should check container changes sanity before trying to apply device changes
factories should check container changes sanity before trying to apply device...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: python-blivet (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David Lehman
Fedora Extras Quality Assurance
abrt_hash:3232f557d8a8e0c84a950677da8...
:
: 959714 965865 966286 (view as bug list)
Depends On:
Blocks: F19Blocker/F19FinalBlocker fedora19rtt F19PPCFinal/F19PPCFinalBlocker/PPCFinalBlocker
  Show dependency treegraph
 
Reported: 2013-05-21 15:02 EDT by Pavel Holica
Modified: 2013-06-13 02:40 EDT (History)
17 users (show)

See Also:
Fixed In Version: python-blivet-0.15-1.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-13 02:40:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda.log (52.04 KB, text/plain)
2013-05-21 15:02 EDT, Pavel Holica
no flags Details
File: backtrace (960 bytes, text/plain)
2013-05-21 15:02 EDT, Pavel Holica
no flags Details
File: environ (760 bytes, text/plain)
2013-05-21 15:03 EDT, Pavel Holica
no flags Details
File: ifcfg.log (567 bytes, text/plain)
2013-05-21 15:03 EDT, Pavel Holica
no flags Details
File: lsblk_output (1.98 KB, text/plain)
2013-05-21 15:03 EDT, Pavel Holica
no flags Details
File: nmcli_dev_list (3.38 KB, text/plain)
2013-05-21 15:04 EDT, Pavel Holica
no flags Details
File: packaging.log (313.71 KB, text/plain)
2013-05-21 15:04 EDT, Pavel Holica
no flags Details
File: program.log (28.50 KB, text/plain)
2013-05-21 15:04 EDT, Pavel Holica
no flags Details
File: storage.log (550.83 KB, text/plain)
2013-05-21 15:04 EDT, Pavel Holica
no flags Details
File: syslog (72.62 KB, text/plain)
2013-05-21 15:04 EDT, Pavel Holica
no flags Details
File: anaconda-tb (1.14 MB, application/octet-stream)
2013-05-21 15:04 EDT, Pavel Holica
no flags Details

  None (edit)
Description Pavel Holica 2013-05-21 15:02:28 EDT
Description of problem:
The following was filed automatically by anaconda:
anaconda 19.28-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.7/site-packages/blivet/size.py", line 80, in _parseSpec
    raise ValueError("invalid size specification", spec)
  File "/usr/lib/python2.7/site-packages/blivet/size.py", line 138, in __new__
    self = Decimal.__new__(cls, value=_parseSpec(spec))
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/lib/accordion.py", line 61, in selectorFromDevice
    size = Size(spec="%f MB" % device.size)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 1033, in _replace_device
    selector=selector)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 1314, in _save_right_side
    selector=selector)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 2746, in on_apply_clicked
    self._save_right_side(self._current_selector)
ValueError: ('invalid size specification', '-1744.000000 MB')

Version-Release number of selected component:
anaconda-19.28-1

Additional info:
reporter:       libreport-2.1.4
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2019-Beta\x20x86_64 quiet BOOT_IMAGE=vmlinuz 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.9.2-301.fc19.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        19-Beta

Truncated backtrace:
Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 2746, in on_apply_clicked
    self._save_right_side(self._current_selector)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 1314, in _save_right_side
    selector=selector)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 1033, in _replace_device
    selector=selector)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/lib/accordion.py", line 61, in selectorFromDevice
    size = Size(spec="%f MB" % device.size)
  File "/usr/lib/python2.7/site-packages/blivet/size.py", line 138, in __new__
    self = Decimal.__new__(cls, value=_parseSpec(spec))
  File "/usr/lib/python2.7/site-packages/blivet/size.py", line 80, in _parseSpec
    raise ValueError("invalid size specification", spec)
ValueError: ('invalid size specification', '-1744.000000 MB')
Comment 1 Pavel Holica 2013-05-21 15:02:33 EDT
Created attachment 751347 [details]
File: anaconda.log
Comment 2 Pavel Holica 2013-05-21 15:02:56 EDT
Created attachment 751348 [details]
File: backtrace
Comment 3 Pavel Holica 2013-05-21 15:03:00 EDT
Created attachment 751349 [details]
File: environ
Comment 4 Pavel Holica 2013-05-21 15:03:05 EDT
Created attachment 751350 [details]
File: ifcfg.log
Comment 5 Pavel Holica 2013-05-21 15:03:55 EDT
Created attachment 751351 [details]
File: lsblk_output
Comment 6 Pavel Holica 2013-05-21 15:04:00 EDT
Created attachment 751352 [details]
File: nmcli_dev_list
Comment 7 Pavel Holica 2013-05-21 15:04:06 EDT
Created attachment 751353 [details]
File: packaging.log
Comment 8 Pavel Holica 2013-05-21 15:04:12 EDT
Created attachment 751354 [details]
File: program.log
Comment 9 Pavel Holica 2013-05-21 15:04:20 EDT
Created attachment 751355 [details]
File: storage.log
Comment 10 Pavel Holica 2013-05-21 15:04:25 EDT
Created attachment 751356 [details]
File: syslog
Comment 11 Pavel Holica 2013-05-21 15:04:38 EDT
Created attachment 751357 [details]
File: anaconda-tb
Comment 12 David Lehman 2013-05-23 12:12:59 EDT
*** Bug 966286 has been marked as a duplicate of this bug. ***
Comment 13 Adam Williamson 2013-06-03 12:58:50 EDT
*** Bug 965865 has been marked as a duplicate of this bug. ***
Comment 14 Adam Williamson 2013-06-03 12:59:46 EDT
*** Bug 959714 has been marked as a duplicate of this bug. ***
Comment 15 Adam Williamson 2013-06-03 13:02:11 EDT
Discussed at 2013-06-03 blocker review meeting: http://meetbot.fedoraproject.org/fedora-blocker-review/2013-06-03/f19final-blocker-review-2.2013-06-03-16.00.log.txt (under the identity of 965865). Accepted as a blocker per https://fedoraproject.org/wiki/Fedora_19_Beta_Release_Criteria#Custom_partitioning : "When using the custom partitioning flow, the installer must be able to: ... Reject or disallow invalid disk and volume configurations without crashing."
Comment 16 Fedora Update System 2013-06-03 19:55:07 EDT
python-blivet-0.15-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/python-blivet-0.15-1.fc19
Comment 17 Fedora Update System 2013-06-04 22:27:29 EDT
Package python-blivet-0.15-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing python-blivet-0.15-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-9977/python-blivet-0.15-1.fc19
then log in and leave karma (feedback).
Comment 18 Ladislav Jozsa 2013-06-05 15:01:45 EDT
Description of problem:
Error occured when trying to change LVM's underlying layer to RAID5 on / partition and clicked Update settings. Desired capacity value wasn't touched.

Version-Release number of selected component:
anaconda-19.30-1

Additional info:
reporter:       libreport-2.1.4
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2019-Beta\x20x86_64 rd.live.check quiet BOOT_IMAGE=vmlinuz 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.9.2-301.fc19.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        19-Beta

Truncated backtrace:
Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 2746, in on_apply_clicked
    self._save_right_side(self._current_selector)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 1314, in _save_right_side
    selector=selector)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 1033, in _replace_device
    selector=selector)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/lib/accordion.py", line 61, in selectorFromDevice
    size = Size(spec="%f MB" % device.size)
  File "/usr/lib/python2.7/site-packages/blivet/size.py", line 138, in __new__
    self = Decimal.__new__(cls, value=_parseSpec(spec))
  File "/usr/lib/python2.7/site-packages/blivet/size.py", line 80, in _parseSpec
    raise ValueError("invalid size specification", spec)
ValueError: ('invalid size specification', '-663996.000000 MB')
Comment 19 Wendell Baker 2013-06-09 13:10:41 EDT
Description of problem:
An HP ProLiant N57L server with 4x 2TB disks.
The disks were extracted from another Linux and thus had filesystem remnants on them.
In anaconda, cleared those out.
Asked for the default filesystem layout.  This laid out the usual on 8TB of space.
But I wanted a RAID.  So I modified the Volume Group to be RAID5.
This should give ~5.5TB of space on 4x 2TB HDD.
It seems like that happened was that the internal business logic of anaconda was not prepared for a change from an LVM set up across 4x disks to a RAID5 set up on those 4 disks.   

Version-Release number of selected component:
anaconda-19.30-1

Additional info:
reporter:       libreport-2.1.4
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=F19/x86_64/isolinux/initrd.img vnc headless shell sshd ks.device=link lang=en_US keymap=us repo=nfs:vers=3:pickerel.sanguine.emerson.baker.org:/lake/fedora/mirrors/19/replica/development/19/x86_64/os BOOT_IMAGE=F19/x86_64/isolinux/vmlinuz 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.9.4-300.fc19.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        19

Truncated backtrace:
Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/lib/accordion.py", line 218, in _onSelectorClicked
    cb(selector)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 2364, in on_selector_clicked
    self._save_current_selector()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 2353, in _save_current_selector
    self._save_right_side(self._current_selector)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 1314, in _save_right_side
    selector=selector)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 1033, in _replace_device
    selector=selector)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/lib/accordion.py", line 61, in selectorFromDevice
    size = Size(spec="%f MB" % device.size)
  File "/usr/lib/python2.7/site-packages/blivet/size.py", line 138, in __new__
    self = Decimal.__new__(cls, value=_parseSpec(spec))
  File "/usr/lib/python2.7/site-packages/blivet/size.py", line 80, in _parseSpec
    raise ValueError("invalid size specification", spec)
ValueError: ('invalid size specification', '-1857900.000000 MB')
Comment 20 Juan Orti 2013-06-11 11:10:05 EDT
Description of problem:
Creating a new home partition

Version-Release number of selected component:
anaconda-19.30-1

Additional info:
reporter:       libreport-2.1.4
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2019-Beta\x20x86_64 quiet BOOT_IMAGE=vmlinuz 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.9.2-301.fc19.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        19-Beta

Truncated backtrace:
Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/lib/accordion.py", line 218, in _onSelectorClicked
    cb(selector)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 2364, in on_selector_clicked
    self._save_current_selector()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 2353, in _save_current_selector
    self._save_right_side(self._current_selector)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 1314, in _save_right_side
    selector=selector)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 1033, in _replace_device
    selector=selector)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/lib/accordion.py", line 61, in selectorFromDevice
    size = Size(spec="%f MB" % device.size)
  File "/usr/lib/python2.7/site-packages/blivet/size.py", line 138, in __new__
    self = Decimal.__new__(cls, value=_parseSpec(spec))
  File "/usr/lib/python2.7/site-packages/blivet/size.py", line 80, in _parseSpec
    raise ValueError("invalid size specification", spec)
ValueError: ('invalid size specification', '-2.000000 MB')
Comment 21 Brian Lane 2013-06-11 20:25:29 EDT
Please retest with TC2, which has newer versions of anaconda and blivet.
Comment 22 Fedora Update System 2013-06-13 02:40:17 EDT
python-blivet-0.15-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.