Bug 966286 - ValueError: ('invalid size specification', '-30708.000000 MB')
ValueError: ('invalid size specification', '-30708.000000 MB')
Status: CLOSED DUPLICATE of bug 965805
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
19
x86_64 Linux
high Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
abrt_hash:3232f557d8a8e0c84a950677da8...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-22 19:20 EDT by Jeff Bastian
Modified: 2013-05-23 12:12 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-23 12:12:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda.log (19.92 KB, text/plain)
2013-05-22 19:20 EDT, Jeff Bastian
no flags Details
File: backtrace (961 bytes, text/plain)
2013-05-22 19:20 EDT, Jeff Bastian
no flags Details
File: environ (779 bytes, text/plain)
2013-05-22 19:20 EDT, Jeff Bastian
no flags Details
File: ifcfg.log (567 bytes, text/plain)
2013-05-22 19:20 EDT, Jeff Bastian
no flags Details
File: lsblk_output (1.69 KB, text/plain)
2013-05-22 19:20 EDT, Jeff Bastian
no flags Details
File: nmcli_dev_list (3.38 KB, text/plain)
2013-05-22 19:20 EDT, Jeff Bastian
no flags Details
File: packaging.log (592.65 KB, text/plain)
2013-05-22 19:20 EDT, Jeff Bastian
no flags Details
File: program.log (20.09 KB, text/plain)
2013-05-22 19:20 EDT, Jeff Bastian
no flags Details
File: storage.log (201.68 KB, text/plain)
2013-05-22 19:20 EDT, Jeff Bastian
no flags Details
File: syslog (69.47 KB, text/plain)
2013-05-22 19:20 EDT, Jeff Bastian
no flags Details
File: anaconda-tb (1.03 MB, application/octet-stream)
2013-05-22 19:20 EDT, Jeff Bastian
no flags Details

  None (edit)
Description Jeff Bastian 2013-05-22 19:20:17 EDT
Description of problem:
I tried to switch my Volume Group to use RAID1 on just the first two disks and Anaconda crashed.
The following was filed automatically by anaconda:
anaconda 19.28-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.7/site-packages/blivet/size.py", line 80, in _parseSpec
    raise ValueError("invalid size specification", spec)
  File "/usr/lib/python2.7/site-packages/blivet/size.py", line 138, in __new__
    self = Decimal.__new__(cls, value=_parseSpec(spec))
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/lib/accordion.py", line 61, in selectorFromDevice
    size = Size(spec="%f MB" % device.size)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 1033, in _replace_device
    selector=selector)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 1314, in _save_right_side
    selector=selector)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 2746, in on_apply_clicked
    self._save_right_side(self._current_selector)
ValueError: ('invalid size specification', '-30708.000000 MB')

Version-Release number of selected component:
anaconda-19.28-1

Additional info:
reporter:       libreport-2.1.4
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2019-Beta\x20x86_64 quiet BOOT_IMAGE=vmlinuz 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.9.2-301.fc19.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        19-Beta

Truncated backtrace:
Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 2746, in on_apply_clicked
    self._save_right_side(self._current_selector)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 1314, in _save_right_side
    selector=selector)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 1033, in _replace_device
    selector=selector)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/lib/accordion.py", line 61, in selectorFromDevice
    size = Size(spec="%f MB" % device.size)
  File "/usr/lib/python2.7/site-packages/blivet/size.py", line 138, in __new__
    self = Decimal.__new__(cls, value=_parseSpec(spec))
  File "/usr/lib/python2.7/site-packages/blivet/size.py", line 80, in _parseSpec
    raise ValueError("invalid size specification", spec)
ValueError: ('invalid size specification', '-30708.000000 MB')
Comment 1 Jeff Bastian 2013-05-22 19:20:21 EDT
Created attachment 751937 [details]
File: anaconda.log
Comment 2 Jeff Bastian 2013-05-22 19:20:24 EDT
Created attachment 751938 [details]
File: backtrace
Comment 3 Jeff Bastian 2013-05-22 19:20:28 EDT
Created attachment 751939 [details]
File: environ
Comment 4 Jeff Bastian 2013-05-22 19:20:31 EDT
Created attachment 751940 [details]
File: ifcfg.log
Comment 5 Jeff Bastian 2013-05-22 19:20:34 EDT
Created attachment 751941 [details]
File: lsblk_output
Comment 6 Jeff Bastian 2013-05-22 19:20:37 EDT
Created attachment 751942 [details]
File: nmcli_dev_list
Comment 7 Jeff Bastian 2013-05-22 19:20:41 EDT
Created attachment 751944 [details]
File: packaging.log
Comment 8 Jeff Bastian 2013-05-22 19:20:44 EDT
Created attachment 751945 [details]
File: program.log
Comment 9 Jeff Bastian 2013-05-22 19:20:48 EDT
Created attachment 751946 [details]
File: storage.log
Comment 10 Jeff Bastian 2013-05-22 19:20:51 EDT
Created attachment 751947 [details]
File: syslog
Comment 11 Jeff Bastian 2013-05-22 19:20:55 EDT
Created attachment 751948 [details]
File: anaconda-tb
Comment 12 Jeff Bastian 2013-05-22 19:37:10 EDT
I created my virtual machine with 6 disks and I selected all 6 of the disks at the "Installation Destination" spoke.  I chose LVM and told it I want to review the partitions.

I clicked the link to create the automatic layout.

I selected the / filesystem and clicked the "Modify..." button for the "fedora" Volume Group.

All 6 disks were selected, but I changed it to just the first 2 disks.

I chose a RAID1 setup and hit Save and Update Settings and a few seconds later Anaconda crashed with the error about the negative disk size.
Comment 13 David Lehman 2013-05-23 12:12:59 EDT

*** This bug has been marked as a duplicate of bug 965805 ***

Note You need to log in before you can comment on or make changes to this bug.