Bug 965877 - Default system custom info: cli default_info remove command gives success message when asked to remove an invalid keyname
Default system custom info: cli default_info remove command gives success mes...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management (Show other bugs)
6.0.1
Unspecified Unspecified
unspecified Severity medium (vote)
: Unspecified
: --
Assigned To: Adam Price
Hayk Hovsepyan
: Triaged
: 970033 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-21 17:49 EDT by sthirugn@redhat.com
Modified: 2014-04-24 13:11 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description sthirugn@redhat.com 2013-05-21 17:49:20 EDT
Description of problem:
cli default_info remove command gives success message when asked to remove an invalid keyname

Version-Release number of selected component (if applicable):
* candlepin-0.8.7-1.el6_4.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.8.7-1.el6_4.noarch
* candlepin-tomcat6-0.8.7-1.el6_4.noarch
* elasticsearch-0.19.9-8.el6sat.noarch
* foreman-1.1.10002-29.noarch
* foreman-postgresql-1.1.10002-29.noarch
* katello-1.4.2-6.el6sat.noarch
* katello-all-1.4.2-6.el6sat.noarch
* katello-certs-tools-1.4.2-2.el6sat.noarch
* katello-cli-1.4.2-5.el6sat.noarch
* katello-cli-common-1.4.2-5.el6sat.noarch
* katello-common-1.4.2-6.el6sat.noarch
* katello-configure-1.4.3-9.el6sat.noarch
* katello-configure-foreman-1.4.3-9.el6sat.noarch
* katello-foreman-all-1.4.2-6.el6sat.noarch
* katello-glue-candlepin-1.4.2-6.el6sat.noarch
* katello-glue-elasticsearch-1.4.2-6.el6sat.noarch
* katello-glue-pulp-1.4.2-6.el6sat.noarch
* katello-selinux-1.4.3-3.el6sat.noarch
* pulp-rpm-plugins-2.1.1-1.el6sat.noarch
* pulp-selinux-2.1.1-1.el6sat.noarch
* pulp-server-2.1.1-1.el6sat.noarch

How reproducible:
Always

Steps to Reproduce:
1. Create an Org (say worldcorp)
2. Create few default system custom info keynames: key1, key2, key3
3. In katello shell, enter the following command to remove a non-existent keyname key1000:
#org default_info remove --name=worldcorp  --type='system' --keyname='key1000'


Actual results:
Successfully removed [ System ] default custom info [ key1000 ] for Org [ worldcorp ]


Expected results:
keyname not found

Additional info:
Comment 1 Tazim Kolhar 2013-06-03 10:06:49 EDT
*** Bug 970033 has been marked as a duplicate of this bug. ***
Comment 3 Adam Price 2013-06-26 15:05:10 EDT
https://github.com/Katello/katello/pull/2561
Comment 5 Hayk Hovsepyan 2013-10-04 09:45:52 EDT
Verified on revision:
Katello-Katello-Installation-RegisterRHNClassic-1.1-4.noarch
katello-cli-common-1.4.3-17.el6sat.noarch
katello-configure-1.4.5-9.el6sat.noarch
pulp-rpm-plugins-2.3.0-0.17.beta.el6sat.noarch
pulp-katello-plugins-0.2-1.el6sat.noarch
katello-glue-pulp-1.4.6-19.el6sat.noarch
katello-1.4.6-19.el6sat.noarch
katello-foreman-all-1.4.6-19.el6sat.noarch
katello-qpid-broker-key-pair-1.0-1.noarch
Katello-Katello-Installation-Satellite6Latest-1.0-10.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-qpid-client-key-pair-1.0-1.noarch
pulp-rpm-handlers-2.3.0-0.17.beta.el6sat.noarch
katello-agent-1.4.4-3.el6sat.noarch
katello-cli-1.4.3-17.el6sat.noarch
katello-certs-tools-1.4.4-1.el6sat.noarch
katello-configure-foreman-proxy-1.4.5-9.el6sat.noarch
pulp-server-2.3.0-0.17.beta.el6sat.noarch
pulp-nodes-common-2.3.0-0.17.beta.el6sat.noarch
pulp-puppet-plugins-2.3.0-0.17.beta.el6sat.noarch
katello-common-1.4.6-19.el6sat.noarch
katello-glue-candlepin-1.4.6-19.el6sat.noarch
katello-glue-elasticsearch-1.4.6-19.el6sat.noarch
katello-all-1.4.6-19.el6sat.noarch
pulp-selinux-2.3.0-0.17.beta.el6sat.noarch
pulp-nodes-parent-2.3.0-0.17.beta.el6sat.noarch
katello-selinux-1.4.4-4.el6sat.noarch
katello-configure-foreman-1.4.5-9.el6sat.noarch
Katello-Katello-Configuration-KatelloClient-1.1-50.noarch
Katello-Katello-Sanity-ImportKeys-1.2-1.noarch
Comment 6 Bryan Kearney 2014-04-24 13:10:39 EDT
This was verified and delivered with MDP2. Closing it out.
Comment 7 Bryan Kearney 2014-04-24 13:11:48 EDT
This was delivered and verified with MDP2. Closing the bug.

Note You need to log in before you can comment on or make changes to this bug.