Bug 970033 - Headpin Nightly : Removing custom info for distributor at organisation level works fine even though invalid key is supplied
Headpin Nightly : Removing custom info for distributor at organisation level ...
Status: CLOSED DUPLICATE of bug 965877
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Installer (Show other bugs)
Nightly
x86_64 Linux
medium Severity medium (vote)
: Unspecified
: --
Assigned To: Katello Bug Bin
Katello QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-03 07:09 EDT by Tazim Kolhar
Modified: 2016-04-25 20:55 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-03 10:06:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tazim Kolhar 2013-06-03 07:09:55 EDT
Description of problem:
Removing custom info for distributor at organisation level
works fine even though invalid key is supplied

Version-Release number of selected component (if applicable):
# rpm -qa | grep katello
signo-katello-0.0.9-1.el6.noarch
katello-configure-1.4.3-1.git.51.c5aa3be.el6.noarch
katello-certs-tools-1.4.2-1.el6.noarch
katello-cli-1.4.2-1.git.71.2a2d883.el6.noarch
katello-cli-common-1.4.2-1.git.71.2a2d883.el6.noarch
katello-glue-candlepin-1.4.2-1.git.523.bdb36c0.el6.noarch
katello-selinux-1.4.3-1.git.3.ce8227b.el6.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-glue-elasticsearch-1.4.2-1.git.523.bdb36c0.el6.noarch
katello-headpin-1.4.2-1.git.523.bdb36c0.el6.noarch
katello-common-1.4.2-1.git.523.bdb36c0.el6.noarch
katello-headpin-all-1.4.2-1.git.523.bdb36c0.el6.noarch
katello-repos-1.4.2-1.el6.noarch


How reproducible:
# yum install -y katello-headpin-all
# katello-configure --user-pass=***

Steps to Reproduce:
1.# headpin -u admin -p *** org default_info remove --name ACME_Corporation --keyname test2 --type distributor
Successfully removed [ Distributor ] default custom info [ test2 ] for Org [ ACME_Corporation ]

2.# echo $?
    0

3.

Actual results:
Here, there is no such key 'test2' added as custom info
for distributor .
Still it got deleted

Expected results:
The command should throw error
stating that invalid key supplied

Additional info:
Comment 1 Tazim Kolhar 2013-06-03 10:06:49 EDT

*** This bug has been marked as a duplicate of bug 965877 ***

Note You need to log in before you can comment on or make changes to this bug.