Bug 966074 - Cassandra Storage installer - Cassandra authentication password from 'rhqadmin' is being reset back to 'cassandra' while installing/adding new node
Cassandra Storage installer - Cassandra authentication password from 'rhqadmi...
Status: CLOSED CURRENTRELEASE
Product: JBoss Operations Network
Classification: JBoss
Component: Installer (Show other bugs)
JON 3.2
Unspecified Linux
unspecified Severity high
: ER01
: JON 3.2.0
Assigned To: John Sanda
Mike Foley
:
Depends On:
Blocks: 951619
  Show dependency treegraph
 
Reported: 2013-05-22 08:18 EDT by Armine Hovsepyan
Modified: 2015-09-02 20:01 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-02 15:35:26 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
cassandra_password_clustering (179.70 KB, image/png)
2013-05-22 08:18 EDT, Armine Hovsepyan
no flags Details
rhq-storage-credentials (18.22 KB, text/x-log)
2013-08-23 08:40 EDT, Armine Hovsepyan
no flags Details

  None (edit)
Description Armine Hovsepyan 2013-05-22 08:18:25 EDT
Created attachment 751689 [details]
cassandra_password_clustering

Description of problem:
Cassandra Storage installer - Cassandra authentication password from 'rhqadmin' is being reset back to 'cassandra' while installing/adding new node

Version-Release number of selected component (if applicable):
rhq-cassandra jenkins build 231

How reproducible:
2 of 2

Steps to Reproduce:
1. Install jon 3.1.2 
2. Install cassandra storage node
3. Upgrade jon 3.1.2 to 3.2
4. Stop cassandra node
5. Install another cassandra storage in another machine
6. Connect both cassandra nodes to each other by adding host-names into cassandra.yaml (seeds)
7. Start both cassandra nodes

Actual results:
After step 3.
cassandra storage authentication username/password is rhqadmin
After step 7.
cassandra storage authentication username/password from rhqadmin changed to cassandra (default password) 

Expected results:
After step 3.
cassandra storage authentication username/password is rhqadmin
After step 7.
cassandra storage authentication username/password is  rhqadmin 

Additional info:
screenshot of
Comment 1 Armine Hovsepyan 2013-05-23 08:07:07 EDT
hi team. 
I've investigated further and found out the root cause of the issue:
When "rhqctl start --storage" is resetting Cassandra username:password to cassandra from rhqadmin.

Steps to reproduce:
1. Install jon server & agent version < 3.2
2. Install cassandra storage
3. Update jon server & agent to  version >= 3.2
4. stop cassandra storage node
5. start storage node using "rhqctl start --storage" command

Actual result:
After step 3. Cassandra username:password is rhqadmin

After step 5. Cassandra username:password set back to cassandra
Comment 2 John Sanda 2013-08-22 21:55:57 EDT
This was due to new nodes not being properly bootstrapped. This should no longer be an issue now that we have the deployment process[1] in place.

https://docs.jboss.org/author/display/RHQ/Deploying+Storage+Nodes
Comment 3 Armine Hovsepyan 2013-08-23 08:39:27 EDT
verified - restart doesn't change Cassandra authentication credentials.

Verification log attached.
Comment 4 Armine Hovsepyan 2013-08-23 08:40:13 EDT
Created attachment 789582 [details]
rhq-storage-credentials

Note You need to log in before you can comment on or make changes to this bug.