Bug 966079 - [abrt] udisks2-2.1.0-2.fc19: udisks_daemon_util_check_authorization_sync: Process /usr/lib/udisks2/udisksd was killed by signal 11 (SIGSEGV)
[abrt] udisks2-2.1.0-2.fc19: udisks_daemon_util_check_authorization_sync: Pro...
Status: CLOSED DUPLICATE of bug 866718
Product: Fedora
Classification: Fedora
Component: udisks2 (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tomáš Bžatek
Fedora Extras Quality Assurance
abrt_hash:80b20a69e2b45ba9f2d207bf91b...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-22 08:31 EDT by steven.woods3
Modified: 2015-03-03 18:06 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-24 10:43:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (61.70 KB, text/plain)
2013-05-22 08:31 EDT, steven.woods3
no flags Details
File: cgroup (160 bytes, text/plain)
2013-05-22 08:31 EDT, steven.woods3
no flags Details
File: core_backtrace (1.85 KB, text/plain)
2013-05-22 08:31 EDT, steven.woods3
no flags Details
File: dso_list (2.28 KB, text/plain)
2013-05-22 08:31 EDT, steven.woods3
no flags Details
File: environ (114 bytes, text/plain)
2013-05-22 08:31 EDT, steven.woods3
no flags Details
File: limits (1.29 KB, text/plain)
2013-05-22 08:32 EDT, steven.woods3
no flags Details
File: maps (12.38 KB, text/plain)
2013-05-22 08:32 EDT, steven.woods3
no flags Details
File: open_fds (416 bytes, text/plain)
2013-05-22 08:32 EDT, steven.woods3
no flags Details
File: proc_pid_status (896 bytes, text/plain)
2013-05-22 08:32 EDT, steven.woods3
no flags Details
File: var_log_messages (529 bytes, text/plain)
2013-05-22 08:32 EDT, steven.woods3
no flags Details

  None (edit)
Description steven.woods3 2013-05-22 08:31:41 EDT
Version-Release number of selected component:
udisks2-2.1.0-2.fc19

Additional info:
reporter:       libreport-2.1.4
backtrace_rating: 4
cmdline:        /usr/lib/udisks2/udisksd --no-debug
crash_function: udisks_daemon_util_check_authorization_sync
executable:     /usr/lib/udisks2/udisksd
kernel:         3.9.2-301.fc19.x86_64
runlevel:       N 5
uid:            0

Truncated backtrace:
Thread no. 4 (10 frames)
 #0 udisks_daemon_util_check_authorization_sync at udisksdaemonutil.c:678
 #1 handle_mount at udiskslinuxfilesystem.c:1416
 #2 ffi_call_unix64 at ../src/x86/unix64.S:76
 #3 ffi_call at ../src/x86/ffi64.c:522
 #4 g_cclosure_marshal_generic at gclosure.c:1454
 #7 g_signal_emitv at gsignal.c:3059
 #8 _udisks_filesystem_skeleton_handle_method_call at udisks-generated.c:20570
 #9 dispatch_in_thread_func at gdbusinterfaceskeleton.c:537
 #10 g_task_thread_pool_thread at gtask.c:1242
 #12 g_thread_proxy at gthread.c:798

Potential duplicate: bug 853316
Comment 1 steven.woods3 2013-05-22 08:31:45 EDT
Created attachment 751691 [details]
File: backtrace
Comment 2 steven.woods3 2013-05-22 08:31:49 EDT
Created attachment 751692 [details]
File: cgroup
Comment 3 steven.woods3 2013-05-22 08:31:51 EDT
Created attachment 751693 [details]
File: core_backtrace
Comment 4 steven.woods3 2013-05-22 08:31:54 EDT
Created attachment 751694 [details]
File: dso_list
Comment 5 steven.woods3 2013-05-22 08:31:57 EDT
Created attachment 751695 [details]
File: environ
Comment 6 steven.woods3 2013-05-22 08:32:00 EDT
Created attachment 751696 [details]
File: limits
Comment 7 steven.woods3 2013-05-22 08:32:03 EDT
Created attachment 751697 [details]
File: maps
Comment 8 steven.woods3 2013-05-22 08:32:06 EDT
Created attachment 751698 [details]
File: open_fds
Comment 9 steven.woods3 2013-05-22 08:32:08 EDT
Created attachment 751699 [details]
File: proc_pid_status
Comment 10 steven.woods3 2013-05-22 08:32:11 EDT
Created attachment 751700 [details]
File: var_log_messages
Comment 11 Hans de Goede 2013-05-24 10:35:00 EDT
I plugged in an sdcard with a Fedora 18 arm image (for the Allwinner A10), udisks2 udisksd seems to crash every time I plug in the specific sdcard it. This card did not cause the same issue with F-18 on my pc.

reporter:       libreport-2.1.4
backtrace_rating: 4
cmdline:        /usr/lib/udisks2/udisksd --no-debug
core_backtrace: 
crash_function: udisks_daemon_util_check_authorization_sync
executable:     /usr/lib/udisks2/udisksd
kernel:         3.9.2-301.fc19.x86_64
package:        udisks2-2.1.0-2.fc19
reason:         Process /usr/lib/udisks2/udisksd was killed by signal 11 (SIGSEGV)
runlevel:       N 5
uid:            0
Comment 12 Tomáš Bžatek 2013-05-24 10:43:13 EDT
(In reply to Hans de Goede from comment #11)
> I plugged in an sdcard with a Fedora 18 arm image (for the Allwinner A10),
> udisks2 udisksd seems to crash every time I plug in the specific sdcard it.
> This card did not cause the same issue with F-18 on my pc.

Glad to see it's reproducible. Could please have a look at bug 866718#c113 and try to reproduce the problem using udisksd started in foreground? Assertion failures would be very valuable in this case.

Please post the result in bug 866718 directly, I'm going to close this bugreport down, abrt is still not able to properly find duplicates.

Thanks

*** This bug has been marked as a duplicate of bug 866718 ***

Note You need to log in before you can comment on or make changes to this bug.