Bug 966155 - ValueError: cannot initialize a disk that has partitions
ValueError: cannot initialize a disk that has partitions
Status: CLOSED DUPLICATE of bug 966162
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
19
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
abrt_hash:1fca86faeb1754697e65ca1d206...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-22 12:11 EDT by Tim Flink
Modified: 2013-05-22 15:31 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-22 15:31:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (540.67 KB, text/plain)
2013-05-22 12:11 EDT, Tim Flink
no flags Details
File: anaconda.log (7.35 KB, text/plain)
2013-05-22 12:11 EDT, Tim Flink
no flags Details
File: backtrace (1.70 KB, text/plain)
2013-05-22 12:11 EDT, Tim Flink
no flags Details
File: environ (778 bytes, text/plain)
2013-05-22 12:11 EDT, Tim Flink
no flags Details
File: ifcfg.log (573 bytes, text/plain)
2013-05-22 12:12 EDT, Tim Flink
no flags Details
File: lsblk_output (2.27 KB, text/plain)
2013-05-22 12:12 EDT, Tim Flink
no flags Details

  None (edit)
Description Tim Flink 2013-05-22 12:11:02 EDT
Description of problem:
I did an install of F19 beta RC3 to an i386 system with dmraid. Selected custom partitioning when the available space appeared incorrect. Once I hit 'next', I was dumped back to the hub with a TB notification shortly thereafter
The following was filed automatically by anaconda:
anaconda 19.29-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 806, in initializeDisk
    raise ValueError("cannot initialize a disk that has partitions")
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 781, in clearPartitions
    self.initializeDisk(disk)
  File "/usr/lib/python2.7/site-packages/pyanaconda/kickstart.py", line 488, in execute
    storage.clearPartitions()
  File "/usr/lib/python2.7/site-packages/pyanaconda/kickstart.py", line 1638, in doKickstartStorage
    ksdata.clearpart.execute(storage, ksdata, instClass)
  File "/usr/lib/python2.7/site-packages/pyanaconda/ui/gui/spokes/storage.py", line 390, in _doExecute
    doKickstartStorage(self.storage, self.data, self.instclass)
  File "/usr/lib/python2.7/threading.py", line 766, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib/python2.7/site-packages/pyanaconda/threads.py", line 168, in run
    threading.Thread.run(self, *args, **kwargs)
  File "/usr/lib/python2.7/site-packages/pyanaconda/threads.py", line 87, in wait
    self.raise_error(name)
  File "/usr/lib/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 822, in refresh
    threadMgr.wait(thread_name)
  File "/usr/lib/python2.7/site-packages/pyanaconda/ui/gui/hubs/__init__.py", line 108, in _runSpoke
    action.refresh()
  File "/usr/lib/python2.7/site-packages/pyanaconda/ui/gui/hubs/__init__.py", line 390, in _on_spoke_clicked
    self._runSpoke(spoke)
  File "/usr/lib/python2.7/site-packages/pyanaconda/ui/gui/hubs/__init__.py", line 406, in _on_spoke_clicked
    self._on_spoke_clicked(self._spokes[dest].selector, None, self._spokes[dest])
ValueError: cannot initialize a disk that has partitions

Version-Release number of selected component:
anaconda-19.29-1

Additional info:
reporter:       libreport-2.1.4
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:UUID=fcc8825b-1a8e-4a9f-ac8f-74e5afe685f2 rd.live.check quiet BOOT_IMAGE=vmlinuz 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.9.2-301.fc19.i686
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        19-Beta

Truncated backtrace:
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/pyanaconda/ui/gui/hubs/__init__.py", line 406, in _on_spoke_clicked
    self._on_spoke_clicked(self._spokes[dest].selector, None, self._spokes[dest])
  File "/usr/lib/python2.7/site-packages/pyanaconda/ui/gui/hubs/__init__.py", line 390, in _on_spoke_clicked
    self._runSpoke(spoke)
  File "/usr/lib/python2.7/site-packages/pyanaconda/ui/gui/hubs/__init__.py", line 108, in _runSpoke
    action.refresh()
  File "/usr/lib/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 822, in refresh
    threadMgr.wait(thread_name)
  File "/usr/lib/python2.7/site-packages/pyanaconda/threads.py", line 87, in wait
    self.raise_error(name)
  File "/usr/lib/python2.7/site-packages/pyanaconda/threads.py", line 168, in run
    threading.Thread.run(self, *args, **kwargs)
  File "/usr/lib/python2.7/threading.py", line 766, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib/python2.7/site-packages/pyanaconda/ui/gui/spokes/storage.py", line 390, in _doExecute
    doKickstartStorage(self.storage, self.data, self.instclass)
  File "/usr/lib/python2.7/site-packages/pyanaconda/kickstart.py", line 1638, in doKickstartStorage
    ksdata.clearpart.execute(storage, ksdata, instClass)
  File "/usr/lib/python2.7/site-packages/pyanaconda/kickstart.py", line 488, in execute
    storage.clearPartitions()
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 781, in clearPartitions
    self.initializeDisk(disk)
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 806, in initializeDisk
    raise ValueError("cannot initialize a disk that has partitions")
ValueError: cannot initialize a disk that has partitions
Comment 1 Tim Flink 2013-05-22 12:11:14 EDT
Created attachment 751773 [details]
File: anaconda-tb
Comment 2 Tim Flink 2013-05-22 12:11:23 EDT
Created attachment 751775 [details]
File: anaconda.log
Comment 3 Tim Flink 2013-05-22 12:11:33 EDT
Created attachment 751776 [details]
File: backtrace
Comment 4 Tim Flink 2013-05-22 12:11:54 EDT
Created attachment 751777 [details]
File: environ
Comment 5 Tim Flink 2013-05-22 12:12:05 EDT
Created attachment 751778 [details]
File: ifcfg.log
Comment 6 Tim Flink 2013-05-22 12:12:27 EDT
Created attachment 751779 [details]
File: lsblk_output
Comment 7 David Lehman 2013-05-22 15:31:52 EDT
When dmraid partitions are created with explicit -p p passed to kpartx, parted partition lookups fail, leading to this condition.

*** This bug has been marked as a duplicate of bug 966162 ***

Note You need to log in before you can comment on or make changes to this bug.