Bug 966162 - fedora-dmraid-activate shouldn't tell kpartx to use a partition delimiter
fedora-dmraid-activate shouldn't tell kpartx to use a partition delimiter
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dmraid (Show other bugs)
19
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: LVM and device-mapper development team
Fedora Extras Quality Assurance
AcceptedBlocker
:
: 966155 (view as bug list)
Depends On:
Blocks: F19Beta/F19BetaBlocker
  Show dependency treegraph
 
Reported: 2013-05-22 12:38 EDT by David Lehman
Modified: 2013-05-24 16:49 EDT (History)
12 users (show)

See Also:
Fixed In Version: dracut-027-46.git20130430.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-24 16:49:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Lehman 2013-05-22 12:38:21 EDT
Description of problem:
Everything is using kpartx logic of "use 'p' delimiter IFF the disk map name ends with a digit", so none of the core tools, &c should be passing -p p explicitly to force the delimiter from kpartx.

Version-Release number of selected component (if applicable):
dmraid-1.0.0.rc16-20.fc20

How reproducible:
Always

Steps to Reproduce:
1. boot a system with a valid dmraid configuration containing one or more partitions
2. observe the dm map names of the partitions
3.

Actual results:
/dev/mapper/pdc_dghjiijjjp1

Expected results:
/dev/mapper/pdc_dghjiijjj1'

Additional info:
bug 957188

This bug is preventing any installation of Fedora 19 onto dmraid sets with preexisting partitions.
Comment 1 Adam Williamson 2013-05-22 13:46:58 EDT
Discussed at 2013-05-22 blocker review meeting: http://meetbot.fedoraproject.org/fedora-blocker-review/2013-05-22/f19beta-blocker-review-8.2013-05-22-16.07.html . Accepted as a blocker per criterion "The installer must be able to detect and install to hardware or firmware RAID storage devices". We are working on fixing this ATM.
Comment 2 David Lehman 2013-05-22 15:31:52 EDT
*** Bug 966155 has been marked as a duplicate of this bug. ***
Comment 3 Fedora Update System 2013-05-22 22:16:44 EDT
dracut-027-46.git20130430.fc19,dmraid-1.0.0.rc16-21.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/dracut-027-46.git20130430.fc19,dmraid-1.0.0.rc16-21.fc19
Comment 4 Tim Flink 2013-05-23 11:33:53 EDT
I did an install with a promise raid array (dmraid) using F19 beta RC4 i386 and everything went as expected. Moving to VERIFIED
Comment 5 Fedora Update System 2013-05-24 16:49:10 EDT
dracut-027-46.git20130430.fc19, dmraid-1.0.0.rc16-21.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.