Bug 966358 - SELinux is preventing /usr/sbin/ldconfig from 'write' accesses on the directory etc.
SELinux is preventing /usr/sbin/ldconfig from 'write' accesses on the directo...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:862d99e66a250dc3c2f5ac2d249...
:
: 966359 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-23 02:58 EDT by Alex Murray
Modified: 2013-06-06 20:58 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-06 13:44:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output of running restorecon on /etc (22.39 KB, text/plain)
2013-06-05 06:53 EDT, Alex Murray
no flags Details

  None (edit)
Description Alex Murray 2013-05-23 02:58:54 EDT
Description of problem:
SELinux is preventing /usr/sbin/ldconfig from 'write' accesses on the directory etc.

*****  Plugin catchall (100. confidence) suggests  ***************************

If you believe that ldconfig should be allowed write access on the etc directory by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep ldconfig /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:ldconfig_t:s0
Target Context                system_u:object_r:initrc_tmp_t:s0
Target Objects                etc [ dir ]
Source                        ldconfig
Source Path                   /usr/sbin/ldconfig
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           glibc-2.17-4.fc19.x86_64
Target RPM Packages           filesystem-3.2-9.fc19.x86_64
Policy RPM                    selinux-policy-3.12.1-44.fc19.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 3.9.3-301.fc19.x86_64 #1 SMP Mon
                              May 20 12:50:56 UTC 2013 x86_64 x86_64
Alert Count                   1
First Seen                    2013-05-22 16:25:26 CST
Last Seen                     2013-05-22 16:25:26 CST
Local ID                      aae1c3fa-c9ba-460e-bac8-9497853bae3f

Raw Audit Messages
type=AVC msg=audit(1369205726.600:598): avc:  denied  { write } for  pid=15337 comm="ldconfig" name="etc" dev="sda3" ino=1184743 scontext=system_u:system_r:ldconfig_t:s0 tcontext=system_u:object_r:initrc_tmp_t:s0 tclass=dir


type=SYSCALL msg=audit(1369205726.600:598): arch=x86_64 syscall=open success=no exit=EACCES a0=a8ae70 a1=20241 a2=180 a3=10 items=0 ppid=9843 pid=15337 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 ses=4294967295 tty=(none) comm=ldconfig exe=/usr/sbin/ldconfig subj=system_u:system_r:ldconfig_t:s0 key=(null)

Hash: ldconfig,ldconfig_t,initrc_tmp_t,dir,write

audit2allow

#============= ldconfig_t ==============
allow ldconfig_t initrc_tmp_t:dir write;

audit2allow -RYou must regenerate interface info by running /usr/bin/sepolgen-ifgen


Additional info:
reporter:       libreport-2.1.4
hashmarkername: setroubleshoot
kernel:         3.9.3-301.fc19.x86_64
type:           libreport

Potential duplicate: bug 830569
Comment 1 Miroslav Grepl 2013-05-23 05:59:29 EDT
*** Bug 966359 has been marked as a duplicate of this bug. ***
Comment 2 Daniel Walsh 2013-06-04 16:15:39 EDT
This looks like your /etc directory is labeled initrc_tmp_t?

Does 
restorecon -R -v /etc

Change lots of labels?
Comment 3 Alex Murray 2013-06-05 06:53:45 EDT
Created attachment 757122 [details]
Output of running restorecon on /etc

Yes it did change a bunch of things, all VMWare related as I have vmware player installed - is this likely to be the culprit do you think?
Comment 4 Daniel Walsh 2013-06-06 13:44:33 EDT
Could be, although I did not see what I was looking for.

Reopen if it happens again.
Comment 5 Alex Murray 2013-06-06 20:58:25 EDT
So I just realised this bug was from a different machine (a VM of F19 Beta which was running VMWare Tools (not VMWare Player) - restorecon output is similar though (ie. /etc itself is not mislabelled, just the VMWare tools specific stuff down in the leaves)

restorecon reset /etc/rc.d/init.d/vmware-tools-thinprint context unconfined_u:object_r:etc_t:s0->unconfined_u:object_r:initrc_exec_t:s0
restorecon reset /etc/rc.d/init.d/vmware-tools context unconfined_u:object_r:etc_t:s0->unconfined_u:object_r:initrc_exec_t:s0
restorecon reset /etc/vmware-tools context unconfined_u:object_r:etc_t:s0->unconfined_u:object_r:bin_t:s0
restorecon reset /etc/vmware-tools/manifest.txt.shipped context unconfined_u:object_r:etc_t:s0->unconfined_u:object_r:bin_t:s0
restorecon reset /etc/vmware-tools/xsession-gdm.sh context unconfined_u:object_r:etc_t:s0->unconfined_u:object_r:bin_t:s0
restorecon reset /etc/vmware-tools/poweroff-vm-default context unconfined_u:object_r:etc_t:s0->unconfined_u:object_r:bin_t:s0
restorecon reset /etc/vmware-tools/poweron-vm-default context unconfined_u:object_r:etc_t:s0->unconfined_u:object_r:bin_t:s0
restorecon reset /etc/vmware-tools/vmware-tools-libraries.conf context unconfined_u:object_r:etc_t:s0->unconfined_u:object_r:bin_t:s0
restorecon reset /etc/vmware-tools/xsession-xdm.pl context unconfined_u:object_r:etc_t:s0->unconfined_u:object_r:bin_t:s0
restorecon reset /etc/vmware-tools/vmware-user.Xresources context unconfined_u:object_r:etc_t:s0->unconfined_u:object_r:bin_t:s0
restorecon reset /etc/vmware-tools/config context unconfined_u:object_r:etc_t:s0->unconfined_u:object_r:bin_t:s0
restorecon reset /etc/vmware-tools/locations context unconfined_u:object_r:etc_t:s0->unconfined_u:object_r:bin_t:s0
restorecon reset /etc/vmware-tools/vmware-tools-prelink.conf context unconfined_u:object_r:etc_t:s0->unconfined_u:object_r:bin_t:s0
restorecon reset /etc/vmware-tools/resume-vm-default context unconfined_u:object_r:etc_t:s0->unconfined_u:object_r:bin_t:s0
restorecon reset /etc/vmware-tools/plugins context system_u:object_r:etc_t:s0->system_u:object_r:bin_t:s0
restorecon reset /etc/vmware-tools/icu context system_u:object_r:etc_t:s0->system_u:object_r:bin_t:s0
restorecon reset /etc/vmware-tools/installer.sh context unconfined_u:object_r:etc_t:s0->unconfined_u:object_r:bin_t:s0
restorecon reset /etc/vmware-tools/vmware-tools context unconfined_u:object_r:etc_t:s0->unconfined_u:object_r:bin_t:s0
restorecon reset /etc/vmware-tools/statechange.subr context unconfined_u:object_r:etc_t:s0->unconfined_u:object_r:bin_t:s0
restorecon reset /etc/vmware-tools/scripts context unconfined_u:object_r:etc_t:s0->unconfined_u:object_r:bin_t:s0
restorecon reset /etc/vmware-tools/scripts/vmware context unconfined_u:object_r:etc_t:s0->unconfined_u:object_r:bin_t:s0
restorecon reset /etc/vmware-tools/scripts/vmware/network context unconfined_u:object_r:etc_t:s0->unconfined_u:object_r:bin_t:s0
restorecon reset /etc/vmware-tools/xsession-xdm.sh context unconfined_u:object_r:etc_t:s0->unconfined_u:object_r:bin_t:s0
restorecon reset /etc/vmware-tools/tpvmlp.conf context unconfined_u:object_r:etc_t:s0->unconfined_u:object_r:bin_t:s0
restorecon reset /etc/vmware-tools/suspend-vm-default context unconfined_u:object_r:etc_t:s0->unconfined_u:object_r:bin_t:s0
restorecon reset /etc/vmware-tools/vmware-user.desktop context unconfined_u:object_r:etc_t:s0->unconfined_u:object_r:bin_t:s0
restorecon reset /etc/vmware-tools/manifest.txt context system_u:object_r:etc_runtime_t:s0->system_u:object_r:bin_t:s0

Note You need to log in before you can comment on or make changes to this bug.