Bug 966431
| Summary: | Keystone Trusts API fails to list trusts with roles specified | ||
|---|---|---|---|
| Product: | Red Hat OpenStack | Reporter: | Pavel Sedlák <psedlak> |
| Component: | openstack-keystone | Assignee: | Jamie Lennox <jlennox> |
| Status: | CLOSED ERRATA | QA Contact: | Udi Kalifon <ukalifon> |
| Severity: | high | Docs Contact: | |
| Priority: | high | ||
| Version: | 3.0 | CC: | ajeain, apevec, ayoung, jagee, jkt, jlennox, mlopes, nkinder, psedlak |
| Target Milestone: | z2 | Keywords: | Rebase, Triaged, ZStream |
| Target Release: | 4.0 | ||
| Hardware: | Unspecified | ||
| OS: | Unspecified | ||
| Whiteboard: | |||
| Fixed In Version: | openstack-keystone-2013.2.2-1.el6ost | Doc Type: | Rebase: Bug Fixes Only |
| Doc Text: |
Previously, listing Trusts would result in a 500 error. This was due to an invalid attempt to append the result with information regarding the roles assigned to the trust.
With this update, this information has been removed from the API call, and consequently the 500 error is no longer presented.
|
Story Points: | --- |
| Clone Of: | Environment: | ||
| Last Closed: | 2014-03-04 20:12:18 UTC | Type: | Bug |
| Regression: | --- | Mount Type: | --- |
| Documentation: | --- | CRM: | |
| Verified Versions: | Category: | --- | |
| oVirt Team: | --- | RHEL 7.3 requirements from Atomic Host: | |
| Cloudforms Team: | --- | Target Upstream Version: | |
| Embargoed: | |||
| Bug Depends On: | 1065319 | ||
| Bug Blocks: | |||
|
Description
Pavel Sedlák
2013-05-23 09:31:03 UTC
Discovered this as well today. It is only reproducable when using role_names not the ids. Upstream bug was marked as a duplicate. Fix was commited in Reviewed: https://review.openstack.org/60301 Committed: https://git.openstack.org/cgit/openstack/keystone/commit/?id=ab0e2c7667a9adc46fece742e1ee8160879b497b Seems that now this bug applies to stable branches, not just master where it was fixed, so maybe it should be backported stable/havana? successfully listed trusts in: openstack-keystone-2013.2.2-1.el6ost.noarch Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. For information on the advisory, and where to find the updated files, follow the link below. If the solution does not work for you, open a new bug report. http://rhn.redhat.com/errata/RHBA-2014-0213.html |