Bug 966533 - While registering a physical client using activation-key which has 1 quantity of Instance Based subscription throws error
While registering a physical client using activation-key which has 1 quantity...
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager (Show other bugs)
5.10
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: candlepin-bugs
IDM QE LIST
:
Depends On:
Blocks: rhsm-rhel510
  Show dependency treegraph
 
Reported: 2013-05-23 08:35 EDT by Shwetha Kallesh
Modified: 2013-06-05 10:41 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-05 10:41:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Shwetha Kallesh 2013-05-23 08:35:46 EDT
Description of problem:
While registering a physical client using activation-key which has 1 quantity of Instance Based subscription  throws error

Version-Release number of selected component (if applicable):
[root@shwethahostname ~]# subscription-manager version
server type: This system is currently not registered.
subscription management server: 0.8.7-1
subscription-manager: 1.8.8-1.git.10.f718984.el6
python-rhsm: 1.8.11-1.git.1.7236cc2.el6


How reproducible:


Steps to Reproduce:
1.[root@shwethahostname ~]# subscription-manager register --org=admin --activationkey TestKey
Quantity '1' is not a multiple of instance multiplier '2'

2.
3.

Actual results:


Expected results:


Additional info:
Comment 2 RHEL Product and Program Management 2013-05-30 11:05:10 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 3 Devan Goodwin 2013-06-05 10:41:16 EDT
This is correct behaviour, though it's exposing some missing functionality in activation keys.

We can't block you from creating an activation key of quantity 1, because you might intend to use it on a guest, and that's fine. We don't know *where* the key will be used, so it is valid to allow it to be created, and it's valid to reject it when a physical system tries to use it.

I think there's a good RFE here to support activation keys that can automatically figure out the quantity to use, *when* it's actually used on a specific system. This would help activation keys that could get a 4 socket system green as well as an 8 socket system. I'm going to add this to backlog to investigate but will close this bug.

However I'm thinking this probably isn't a 5.10 bug. Going to close and add to backlog to investigate as an RFE.

Note You need to log in before you can comment on or make changes to this bug.