Bug 966676 - orphan remove removes the content but the empty directories not deleted
orphan remove removes the content but the empty directories not deleted
Status: CLOSED UPSTREAM
Product: Pulp
Classification: Community
Component: user-experience (Show other bugs)
Master
Unspecified Unspecified
low Severity unspecified
: ---
: ---
Assigned To: pulp-bugs
Preethi Thomas
: Triaged
: 1018949 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-23 12:30 EDT by Preethi Thomas
Modified: 2015-02-28 16:55 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-02-28 16:55:12 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Pulp Redmine 351 None None None Never

  None (edit)
Description Preethi Thomas 2013-05-23 12:30:38 EDT
Description of problem:
After the contents are removed by orphan remove, the empty directories needs to be cleaned up as well

Version-Release number of selected component (if applicable):

[root@qeblade3 ~]# rpm -q pulp-server
pulp-server-2.2.0-0.13.alpha.fc18.noarch

How reproducible:


Steps to Reproduce:
1. create and sync a repo
2.Delete the repo
3. Orphan remove the content
4. see that  /var/lib/pulp/content/rpm/../.. are still exisiting


Actual results:


Expected results:


Additional info:
Comment 1 Preethi Thomas 2013-05-23 12:31:11 EDT
[root@qeblade3 ~]# ls -l /var/lib/pulp/content/rpm/zip/3.0/5.fc18/x86_64/b0f6819fa2d78ab38a8656cc6b41b784892f5829a9cc8f2cbc503703e92fa19f/Packages/z/
total 0
[root@qeblade3 ~]# rpm -q pulp-server
pulp-server-2.2.0-0.13.alpha.fc18.noarch
[root@qeblade3 ~]#
Comment 2 Chris Duryee 2014-11-07 17:54:13 EST
This bug is still outstanding as of 2.5.0.
Comment 3 Chris Duryee 2014-11-07 17:58:14 EST
*** Bug 1018949 has been marked as a duplicate of this bug. ***
Comment 4 Brian Bouterse 2015-02-28 16:55:12 EST
Moved to https://pulp.plan.io/issues/351

Note You need to log in before you can comment on or make changes to this bug.