Bug 966683 - the dts beta channels should be mapped to the RHB product cert 180
the dts beta channels should be mapped to the RHB product cert 180
Status: CLOSED DUPLICATE of bug 820749
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager-migration-data (Show other bugs)
6.5
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Alex Wood
Entitlement Bugs
:
Depends On:
Blocks: rhsm-rhel65
  Show dependency treegraph
 
Reported: 2013-05-23 12:45 EDT by John Sefler
Modified: 2013-09-20 16:20 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-20 16:20:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description John Sefler 2013-05-23 12:45:51 EDT
Description of problem:

According to the CDN Product Baseline http://git.app.eng.bos.redhat.com/?p=rcm/rcm-metadata.git;a=blob;f=cdn/product-baseline.json , the following RHN Channels
rhel-i386-server-dts-5-beta
rhel-i386-server-dts-5-beta-debuginfo
rhel-x86_64-server-dts-5-beta
rhel-x86_64-server-dts-5-beta-debuginfo
each map to more than one product id: [176, 180] 
However, these channels are special cases.  See https://bugzilla.redhat.com/show_bug.cgi?id=820749#c4
They should be treated specially during migration by rhn-migrate-classic-to-rhsm.  In order to treat them specially, they first need to be mapped to the Red Hat Beta product 180 in the channel-cert-mapping.txt.

Currently, subscription-manager-migration-data has them mapped to 176:
[root@jsefler-5 ~]# grep -- -dts-5-beta /usr/share/rhsm/product/RHEL-5/channel-cert-mapping.txt
rhel-i386-server-dts-5-beta: Server-DTS-i386-92bc1559583c-176.pem
rhel-i386-server-dts-5-beta-debuginfo: Server-DTS-i386-92bc1559583c-176.pem
rhel-ppc-server-dts-5-beta: none
rhel-ppc-server-dts-5-beta-debuginfo: none
rhel-x86_64-server-dts-5-beta: Server-DTS-x86_64-0477094217bc-176.pem
rhel-x86_64-server-dts-5-beta-debuginfo: Server-DTS-x86_64-0477094217bc-176.pem

Expected these channels to be mapped to product 180
Expected: rhel-i386-server-dts-5-beta: RHB-i386-ce28032e05c7-180.pem
Expected: rhel-i386-server-dts-5-beta-debuginfo: RHB-i386-ce28032e05c7-180.pem
Expected: rhel-x86_64-server-dts-5-beta: RHB-x86_64-99c22e1e646f-180.pem
Expected: rhel-x86_64-server-dts-5-beta-debuginfo: RHB-x86_64-99c22e1e646f-180.pem


Version-Release number of selected component (if applicable):
[root@jsefler-5 ~]# rpm -q subscription-manager-migration-data
subscription-manager-migration-data-1.11.3.1-1.git.1.78afd75.el5
Comment 1 RHEL Product and Program Management 2013-05-23 12:53:08 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 2 RHEL Product and Program Management 2013-07-24 00:07:46 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 3 Dennis Gregorovic 2013-09-20 16:20:23 EDT

*** This bug has been marked as a duplicate of bug 820749 ***

Note You need to log in before you can comment on or make changes to this bug.