Bug 966769 - Error with transaction check vs depsolve
Error with transaction check vs depsolve
Status: CLOSED DUPLICATE of bug 962188
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-23 18:29 EDT by William Brown
Modified: 2013-05-24 10:02 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-24 10:02:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description William Brown 2013-05-23 18:29:55 EDT
Description of problem:

Running dnf upgrade --enablerepo=updates-testing:

Running Transaction Check
ERROR with transaction check vs depsolve:
openswan < 3.3-1.fc19 conflicts with libreswan-3.3-1.fc19.x86_64
openswan < 3.3-1.fc19 is obsoleted by libreswan-3.3-1.fc19.x86_64
mesa-dri-filesystem < 9.2-0.1.20130514.fc19 is obsoleted by mesa-filesystem-9.2-0.1.20130514.fc19.x86_64
To diagnose the problem, try running: 'rpm -Va --nofiles --nodigest'.
To fix inconsistent RPMDB, try running: 'rpm --rebuilddb'.
If the above doesn't help please report this error at 'https://bugzilla.redhat.com/enter_bug.cgi?product=Fedora&component=dnf'.

I have tried both the rpm commands. The verify shows no errors, the rpmbuild returns successfully.
Comment 1 Ales Kozumplik 2013-05-24 10:02:09 EDT
Hello,

This problem should go away with dnf-0.3.5, see bug 962188.

Closing as a dupe.

*** This bug has been marked as a duplicate of bug 962188 ***

Note You need to log in before you can comment on or make changes to this bug.