Bug 962188 - obsoletes sometimes result in "ERROR with transaction check vs depsolve"
obsoletes sometimes result in "ERROR with transaction check vs depsolve"
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ales Kozumplik
Fedora Extras Quality Assurance
:
: 966769 969873 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-12 08:06 EDT by Laurent Wandrebeck
Modified: 2014-09-30 19:41 EDT (History)
4 users (show)

See Also:
Fixed In Version: dnf-0.3.5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-13 04:37:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Laurent Wandrebeck 2013-05-12 08:06:24 EDT
Description of problem:

dnf upgrade fails.


Version-Release number of selected component (if applicable):

[root@netbook ~]# dnf --version
0.3.4
  Installed: dnf-0:0.3.4-1.git03fd687.fc19.noarch at 2013-05-04 13:48
  Built    : Fedora Project at 2013-05-02 17:14

  Installed: rpm-0:4.11.0.1-1.fc19.i686 at 2013-05-01 20:01
  Built    : Fedora Project at 2013-02-04 07:39

How reproducible:

dnf upgrade

Steps to Reproduce:
1. dnf upgrade
  
Actual results:

[root@netbook ~]# dnf upgrade
Setting up Upgrade Process
Resolving Dependencies
--> Starting dependency resolution
---> Package polkit-pkla-compat.i686 0.1-2.fc19 will be installed
---> Package xorg-x11-drv-modesetting.i686 0.6.0-7.fc19 will be installed
---> Package xorg-x11-drv-ast.i686 0.97.0-8.fc19 will be obsoleted
---> Package ntpdate.i686 4.2.6p5-11.fc19 will be installed
---> Package PackageKit.i686 0.8.8-1.fc19 will be upgraded
---> Package PackageKit.i686 0.8.8-2.fc19 will be an upgrade
---> Package PackageKit-glib.i686 0.8.8-1.fc19 will be upgraded
---> Package PackageKit-glib.i686 0.8.8-2.fc19 will be an upgrade
---> Package PackageKit-yum-plugin.i686 0.8.8-1.fc19 will be upgraded
---> Package PackageKit-yum-plugin.i686 0.8.8-2.fc19 will be an upgrade
---> Package PackageKit-yum.i686 0.8.8-1.fc19 will be upgraded
---> Package PackageKit-yum.i686 0.8.8-2.fc19 will be an upgrade
---> Package PackageKit-gtk3-module.i686 0.8.8-1.fc19 will be upgraded
---> Package PackageKit-gtk3-module.i686 0.8.8-2.fc19 will be an upgrade
---> Package PackageKit-gstreamer-plugin.i686 0.8.8-1.fc19 will be upgraded
---> Package PackageKit-gstreamer-plugin.i686 0.8.8-2.fc19 will be an upgrade
---> Package PackageKit-device-rebind.i686 0.8.8-1.fc19 will be upgraded
---> Package PackageKit-device-rebind.i686 0.8.8-2.fc19 will be an upgrade
---> Package PackageKit-command-not-found.i686 0.8.8-1.fc19 will be upgraded
---> Package PackageKit-command-not-found.i686 0.8.8-2.fc19 will be an upgrade
---> Package anaconda.i686 19.24-1.fc19 will be upgraded
---> Package anaconda.i686 19.25-1.fc19 will be an upgrade
---> Package anaconda-widgets.i686 19.24-1.fc19 will be upgraded
---> Package anaconda-widgets.i686 19.25-1.fc19 will be an upgrade
---> Package control-center.i686 1:3.8.1-3.fc19 will be upgraded
---> Package control-center.i686 1:3.8.1.5-1.fc19 will be an upgrade
---> Package control-center-filesystem.i686 1:3.8.1-3.fc19 will be upgraded
---> Package control-center-filesystem.i686 1:3.8.1.5-1.fc19 will be an upgrade
---> Package file-roller.i686 3.8.1-2.fc19 will be upgraded
---> Package file-roller.i686 3.8.1-4.fc19 will be an upgrade
---> Package file-roller-nautilus.i686 3.8.1-2.fc19 will be upgraded
---> Package file-roller-nautilus.i686 3.8.1-4.fc19 will be an upgrade
---> Package filesystem.i686 3.2-9.fc19 will be upgraded
---> Package filesystem.i686 3.2-10.fc19 will be an upgrade
---> Package frei0r-plugins.i686 1.3-9.fc19 will be upgraded
---> Package frei0r-plugins.i686 1.3-10.fc19 will be an upgrade
---> Package ghostscript.i686 9.07-2.fc19 will be upgraded
---> Package ghostscript.i686 9.07-3.fc19 will be an upgrade
---> Package ghostscript-devel.i686 9.07-2.fc19 will be upgraded
---> Package ghostscript-devel.i686 9.07-3.fc19 will be an upgrade
---> Package ghostscript-cups.i686 9.07-2.fc19 will be upgraded
---> Package ghostscript-cups.i686 9.07-3.fc19 will be an upgrade
---> Package gnome-classic-session.noarch 3.8.1-1.fc19 will be upgraded
---> Package gnome-applet-sensors.i686 3.0.0-4.fc18 will be obsoleted
---> Package gnome-applets.i686 1:3.5.92-3.fc18 will be obsoleted
---> Package gnome-panel-libs.i686 3.6.2-6.fc19 will be obsoleted
---> Package gnome-classic-session.noarch 3.8.1-3.fc19 will be an upgrade
---> Package gnome-shell-extension-launch-new-instance.noarch 3.8.1-1.fc19 will be upgraded
---> Package gnome-shell-extension-launch-new-instance.noarch 3.8.1-3.fc19 will be an upgrade
---> Package gnome-shell-extension-default-min-max.noarch 3.8.1-1.fc19 will be upgraded
---> Package gnome-shell-extension-default-min-max.noarch 3.8.1-3.fc19 will be an upgrade
---> Package gnome-shell-extension-alternate-tab.noarch 3.8.1-1.fc19 will be upgraded
---> Package gnome-shell-extension-alternate-tab.noarch 3.8.1-3.fc19 will be an upgrade
---> Package gnome-shell-extension-apps-menu.noarch 3.8.1-1.fc19 will be upgraded
---> Package gnome-shell-extension-apps-menu.noarch 3.8.1-3.fc19 will be an upgrade
---> Package gnome-shell-extension-window-list.noarch 3.8.1-1.fc19 will be upgraded
---> Package gnome-shell-extension-window-list.noarch 3.8.1-3.fc19 will be an upgrade
---> Package gnome-shell-extension-places-menu.noarch 3.8.1-1.fc19 will be upgraded
---> Package gnome-shell-extension-places-menu.noarch 3.8.1-3.fc19 will be an upgrade
---> Package gnome-shell-extension-static-workspaces.noarch 3.8.1-1.fc19 will be upgraded
---> Package gnome-shell-extension-static-workspaces.noarch 3.8.1-3.fc19 will be an upgrade
---> Package gnome-shell-extension-common.noarch 3.8.1-1.fc19 will be upgraded
---> Package gnome-shell-extension-common.noarch 3.8.1-3.fc19 will be an upgrade
---> Package ibus-anthy.i686 1.5.0-2.fc19 will be upgraded
---> Package ibus-anthy.i686 1.5.1-1.fc19 will be an upgrade
---> Package libgudev1.i686 203-2.fc19 will be upgraded
---> Package libgudev1.i686 204-2.fc19 will be an upgrade
---> Package libgudev1-devel.i686 203-2.fc19 will be upgraded
---> Package libgudev1-devel.i686 204-2.fc19 will be an upgrade
---> Package libnm-gtk.i686 0.9.8.1-2.git20130327.fc19 will be upgraded
---> Package libnm-gtk.i686 0.9.8.1-3.git20130430.fc19 will be an upgrade
---> Package nm-connection-editor.i686 0.9.8.1-2.git20130327.fc19 will be upgraded
---> Package nm-connection-editor.i686 0.9.8.1-3.git20130430.fc19 will be an upgrade
---> Package network-manager-applet.i686 0.9.8.1-2.git20130327.fc19 will be upgraded
---> Package network-manager-applet.i686 0.9.8.1-3.git20130430.fc19 will be an upgrade
---> Package libreport.i686 2.1.4-4.fc19 will be upgraded
---> Package libreport.i686 2.1.4-5.fc19 will be an upgrade
---> Package libreport-filesystem.i686 2.1.4-4.fc19 will be upgraded
---> Package libreport-filesystem.i686 2.1.4-5.fc19 will be an upgrade
---> Package libreport-python.i686 2.1.4-4.fc19 will be upgraded
---> Package libreport-python.i686 2.1.4-5.fc19 will be an upgrade
---> Package libreport-web.i686 2.1.4-4.fc19 will be upgraded
---> Package libreport-web.i686 2.1.4-5.fc19 will be an upgrade
---> Package libreport-plugin-ureport.i686 2.1.4-4.fc19 will be upgraded
---> Package libreport-plugin-ureport.i686 2.1.4-5.fc19 will be an upgrade
---> Package libreport-plugin-reportuploader.i686 2.1.4-4.fc19 will be upgraded
---> Package libreport-plugin-reportuploader.i686 2.1.4-5.fc19 will be an upgrade
---> Package libreport-plugin-logger.i686 2.1.4-4.fc19 will be upgraded
---> Package libreport-plugin-logger.i686 2.1.4-5.fc19 will be an upgrade
---> Package libreport-plugin-kerneloops.i686 2.1.4-4.fc19 will be upgraded
---> Package libreport-plugin-kerneloops.i686 2.1.4-5.fc19 will be an upgrade
---> Package libreport-plugin-bugzilla.i686 2.1.4-4.fc19 will be upgraded
---> Package libreport-plugin-bugzilla.i686 2.1.4-5.fc19 will be an upgrade
---> Package libreport-newt.i686 2.1.4-4.fc19 will be upgraded
---> Package libreport-newt.i686 2.1.4-5.fc19 will be an upgrade
---> Package libreport-gtk.i686 2.1.4-4.fc19 will be upgraded
---> Package libreport-gtk.i686 2.1.4-5.fc19 will be an upgrade
---> Package libreport-cli.i686 2.1.4-4.fc19 will be upgraded
---> Package libreport-cli.i686 2.1.4-5.fc19 will be an upgrade
---> Package libreport-anaconda.i686 2.1.4-4.fc19 will be upgraded
---> Package libreport-anaconda.i686 2.1.4-5.fc19 will be an upgrade
---> Package libreport-fedora.i686 2.1.4-4.fc19 will be upgraded
---> Package libreport-fedora.i686 2.1.4-5.fc19 will be an upgrade
---> Package libsysfs.i686 2.1.0-13.fc19 will be upgraded
---> Package libsysfs.i686 2.1.0-14.fc19 will be an upgrade
---> Package nspr.i686 4.9.5-2.fc19 will be upgraded
---> Package nspr.i686 4.9.6-1.fc19 will be an upgrade
---> Package nspr-devel.i686 4.9.5-2.fc19 will be upgraded
---> Package nspr-devel.i686 4.9.6-1.fc19 will be an upgrade
---> Package perl.i686 4:5.16.3-262.fc19 will be upgraded
---> Package perl.i686 4:5.16.3-263.fc19 will be an upgrade
---> Package perl-libs.i686 4:5.16.3-262.fc19 will be upgraded
---> Package perl-libs.i686 4:5.16.3-263.fc19 will be an upgrade
---> Package perl-CPAN.noarch 1.9800-262.fc19 will be upgraded
---> Package perl-CPAN.noarch 1.9800-263.fc19 will be an upgrade
---> Package perl-Digest-MD5.i686 2.51-262.fc19 will be upgraded
---> Package perl-Digest-MD5.i686 2.51-263.fc19 will be an upgrade
---> Package perl-ExtUtils-Install.noarch 1.58-262.fc19 will be upgraded
---> Package perl-ExtUtils-Install.noarch 1.58-263.fc19 will be an upgrade
---> Package perl-ExtUtils-ParseXS.noarch 1:3.16-262.fc19 will be upgraded
---> Package perl-ExtUtils-ParseXS.noarch 1:3.16-263.fc19 will be an upgrade
---> Package perl-HTTP-Tiny.noarch 0.017-262.fc19 will be upgraded
---> Package perl-HTTP-Tiny.noarch 0.017-263.fc19 will be an upgrade
---> Package perl-Pod-Escapes.noarch 1:1.04-262.fc19 will be upgraded
---> Package perl-Pod-Escapes.noarch 1:1.04-263.fc19 will be an upgrade
---> Package perl-Pod-Simple.noarch 1:3.20-262.fc19 will be upgraded
---> Package perl-Pod-Simple.noarch 1:3.20-263.fc19 will be an upgrade
---> Package perl-Test-Harness.noarch 3.23-262.fc19 will be upgraded
---> Package perl-Test-Harness.noarch 3.23-263.fc19 will be an upgrade
---> Package perl-Text-ParseWords.noarch 3.27-262.fc19 will be upgraded
---> Package perl-Text-ParseWords.noarch 3.27-263.fc19 will be an upgrade
---> Package perl-devel.i686 4:5.16.3-262.fc19 will be upgraded
---> Package perl-devel.i686 4:5.16.3-263.fc19 will be an upgrade
---> Package perl-macros.i686 4:5.16.3-262.fc19 will be upgraded
---> Package perl-macros.i686 4:5.16.3-263.fc19 will be an upgrade
---> Package policycoreutils.i686 2.1.14-37.fc19 will be upgraded
---> Package policycoreutils.i686 2.1.14-38.fc19 will be an upgrade
---> Package policycoreutils-python.i686 2.1.14-37.fc19 will be upgraded
---> Package policycoreutils-python.i686 2.1.14-38.fc19 will be an upgrade
---> Package policycoreutils-sandbox.i686 2.1.14-37.fc19 will be upgraded
---> Package policycoreutils-sandbox.i686 2.1.14-38.fc19 will be an upgrade
---> Package policycoreutils-devel.i686 2.1.14-37.fc19 will be upgraded
---> Package policycoreutils-devel.i686 2.1.14-38.fc19 will be an upgrade
---> Package policycoreutils-restorecond.i686 2.1.14-37.fc19 will be upgraded
---> Package policycoreutils-restorecond.i686 2.1.14-38.fc19 will be an upgrade
---> Package polkit.i686 0.110-3.fc19 will be upgraded
---> Package polkit.i686 0.110-4.fc19 will be an upgrade
---> Package pykickstart.noarch 1.99.28-1.fc19 will be upgraded
---> Package pykickstart.noarch 1.99.30-1.fc19 will be an upgrade
---> Package python-blivet.noarch 0.12-1.fc19 will be upgraded
---> Package python-blivet.noarch 0.13-1.fc19 will be an upgrade
---> Package python3.i686 3.3.1-2.fc19 will be upgraded
---> Package python3.i686 3.3.1-4.fc19 will be an upgrade
---> Package python3-libs.i686 3.3.1-2.fc19 will be upgraded
---> Package python3-libs.i686 3.3.1-4.fc19 will be an upgrade
---> Package squashfs-tools.i686 4.3-0.12.git9353c998.fc19 will be upgraded
---> Package squashfs-tools.i686 4.3-0.13.gitc2362556.fc19 will be an upgrade
---> Package system-config-printer.i686 1.4.0-4.fc19 will be upgraded
---> Package system-config-printer.i686 1.4.1-1.fc19 will be an upgrade
---> Package system-config-printer-libs.noarch 1.4.0-4.fc19 will be upgraded
---> Package system-config-printer-libs.noarch 1.4.1-1.fc19 will be an upgrade
---> Package system-config-printer-udev.i686 1.4.0-4.fc19 will be upgraded
---> Package system-config-printer-udev.i686 1.4.1-1.fc19 will be an upgrade
---> Package systemd.i686 203-2.fc19 will be upgraded
---> Package systemd.i686 204-2.fc19 will be an upgrade
---> Package systemd-libs.i686 203-2.fc19 will be upgraded
---> Package systemd-libs.i686 204-2.fc19 will be an upgrade
---> Package systemd-python.i686 203-2.fc19 will be upgraded
---> Package systemd-python.i686 204-2.fc19 will be an upgrade
---> Package systemd-sysv.i686 203-2.fc19 will be upgraded
---> Package systemd-sysv.i686 204-2.fc19 will be an upgrade
--> Finished dependency resolution

Dependencies Resolved

================================================================================
 Package                         Arch   Version           Repository       Size
================================================================================
Installing:
 ntpdate                         i686   4.2.6p5-11.fc19   updates-testing  80 k
 polkit-pkla-compat              i686   0.1-2.fc19        updates-testing  39 k
 xorg-x11-drv-modesetting        i686   0.6.0-7.fc19      updates-testing  25 k
     replacing  xorg-x11-drv-ast.i686 0.97.0-8.fc19
Upgrading:
 PackageKit                      i686   0.8.8-2.fc19      updates-testing 637 k
 PackageKit-command-not-found    i686   0.8.8-2.fc19      updates-testing  57 k
 PackageKit-device-rebind        i686   0.8.8-2.fc19      updates-testing  48 k
 PackageKit-glib                 i686   0.8.8-2.fc19      updates-testing 155 k
 PackageKit-gstreamer-plugin     i686   0.8.8-2.fc19      updates-testing  48 k
 PackageKit-gtk3-module          i686   0.8.8-2.fc19      updates-testing  48 k
 PackageKit-yum                  i686   0.8.8-2.fc19      updates-testing 113 k
 PackageKit-yum-plugin           i686   0.8.8-2.fc19      updates-testing  43 k
 anaconda                        i686   19.25-1.fc19      updates-testing 1.9 M
 anaconda-widgets                i686   19.25-1.fc19      updates-testing 666 k
 control-center                  i686   1:3.8.1.5-1.fc19  fedora          4.1 M
 control-center-filesystem       i686   1:3.8.1.5-1.fc19  fedora           15 k
 file-roller                     i686   3.8.1-4.fc19      updates-testing 930 k
 file-roller-nautilus            i686   3.8.1-4.fc19      updates-testing  27 k
 filesystem                      i686   3.2-10.fc19       updates-testing 1.0 M
 frei0r-plugins                  i686   1.3-10.fc19       updates-testing 429 k
 ghostscript                     i686   9.07-3.fc19       updates-testing 4.3 M
 ghostscript-cups                i686   9.07-3.fc19       updates-testing  53 k
 ghostscript-devel               i686   9.07-3.fc19       updates-testing  48 k
 gnome-classic-session           noarch 3.8.1-3.fc19      updates-testing  19 k
     replacing  gnome-applet-sensors.i686 3.0.0-4.fc18
     replacing  gnome-applets.i686 1:3.5.92-3.fc18
     replacing  gnome-panel-libs.i686 3.6.2-6.fc19
 gnome-shell-extension-alternate-tab
                                 noarch 3.8.1-3.fc19      updates-testing  13 k
 gnome-shell-extension-apps-menu noarch 3.8.1-3.fc19      updates-testing  16 k
 gnome-shell-extension-common    noarch 3.8.1-3.fc19      updates-testing  76 k
 gnome-shell-extension-default-min-max
                                 noarch 3.8.1-3.fc19      updates-testing  12 k
 gnome-shell-extension-launch-new-instance
                                 noarch 3.8.1-3.fc19      updates-testing  12 k
 gnome-shell-extension-places-menu
                                 noarch 3.8.1-3.fc19      updates-testing  15 k
 gnome-shell-extension-static-workspaces
                                 noarch 3.8.1-3.fc19      updates-testing  12 k
 gnome-shell-extension-window-list
                                 noarch 3.8.1-3.fc19      updates-testing  19 k
 ibus-anthy                      i686   1.5.1-1.fc19      updates-testing 161 k
 libgudev1                       i686   204-2.fc19        updates-testing  39 k
 libgudev1-devel                 i686   204-2.fc19        updates-testing  51 k
 libnm-gtk                       i686   0.9.8.1-3.git20130430.fc19
                                                          updates-testing  71 k
 libreport                       i686   2.1.4-5.fc19      updates-testing 305 k
 libreport-anaconda              i686   2.1.4-5.fc19      updates-testing  28 k
 libreport-cli                   i686   2.1.4-5.fc19      updates-testing  37 k
 libreport-fedora                i686   2.1.4-5.fc19      updates-testing  27 k
 libreport-filesystem            i686   2.1.4-5.fc19      updates-testing  25 k
 libreport-gtk                   i686   2.1.4-5.fc19      updates-testing  75 k
 libreport-newt                  i686   2.1.4-5.fc19      updates-testing  32 k
 libreport-plugin-bugzilla       i686   2.1.4-5.fc19      updates-testing  54 k
 libreport-plugin-kerneloops     i686   2.1.4-5.fc19      updates-testing  35 k
 libreport-plugin-logger         i686   2.1.4-5.fc19      updates-testing  36 k
 libreport-plugin-reportuploader i686   2.1.4-5.fc19      updates-testing  39 k
 libreport-plugin-ureport        i686   2.1.4-5.fc19      updates-testing  35 k
 libreport-python                i686   2.1.4-5.fc19      updates-testing  52 k
 libreport-web                   i686   2.1.4-5.fc19      updates-testing  36 k
 libsysfs                        i686   2.1.0-14.fc19     updates-testing  47 k
 network-manager-applet          i686   0.9.8.1-3.git20130430.fc19
                                                          updates-testing 214 k
 nm-connection-editor            i686   0.9.8.1-3.git20130430.fc19
                                                          updates-testing 797 k
 nspr                            i686   4.9.6-1.fc19      updates-testing 122 k
 nspr-devel                      i686   4.9.6-1.fc19      updates-testing 109 k
 perl                            i686   4:5.16.3-263.fc19 updates-testing 8.2 M
 perl-CPAN                       noarch 1.9800-263.fc19   updates-testing 289 k
 perl-Digest-MD5                 i686   2.51-263.fc19     updates-testing  55 k
 perl-ExtUtils-Install           noarch 1.58-263.fc19     updates-testing  70 k
 perl-ExtUtils-ParseXS           noarch 1:3.16-263.fc19   updates-testing 102 k
 perl-HTTP-Tiny                  noarch 0.017-263.fc19    updates-testing  54 k
 perl-Pod-Escapes                noarch 1:1.04-263.fc19   updates-testing  47 k
 perl-Pod-Simple                 noarch 1:3.20-263.fc19   updates-testing 235 k
 perl-Test-Harness               noarch 3.23-263.fc19     updates-testing 287 k
 perl-Text-ParseWords            noarch 3.27-263.fc19     updates-testing  44 k
 perl-devel                      i686   4:5.16.3-263.fc19 updates-testing 448 k
 perl-libs                       i686   4:5.16.3-263.fc19 updates-testing 673 k
 perl-macros                     i686   4:5.16.3-263.fc19 updates-testing  39 k
 policycoreutils                 i686   2.1.14-38.fc19    updates-testing 729 k
 policycoreutils-devel           i686   2.1.14-38.fc19    updates-testing 231 k
 policycoreutils-python          i686   2.1.14-38.fc19    updates-testing 397 k
 policycoreutils-restorecond     i686   2.1.14-38.fc19    updates-testing 155 k
 policycoreutils-sandbox         i686   2.1.14-38.fc19    updates-testing 152 k
 polkit                          i686   0.110-4.fc19      updates-testing 159 k
 pykickstart                     noarch 1.99.30-1.fc19    updates-testing 341 k
 python-blivet                   noarch 0.13-1.fc19       updates-testing 467 k
 python3                         i686   3.3.1-4.fc19      updates-testing  42 k
 python3-libs                    i686   3.3.1-4.fc19      updates-testing 6.1 M
 squashfs-tools                  i686   4.3-0.13.gitc2362556.fc19
                                                          updates-testing 109 k
 system-config-printer           i686   1.4.1-1.fc19      updates-testing 290 k
 system-config-printer-libs      noarch 1.4.1-1.fc19      updates-testing 944 k
 system-config-printer-udev      i686   1.4.1-1.fc19      updates-testing  89 k
 systemd                         i686   204-2.fc19        updates-testing 2.5 M
 systemd-libs                    i686   204-2.fc19        updates-testing 151 k
 systemd-python                  i686   204-2.fc19        updates-testing  70 k
 systemd-sysv                    i686   204-2.fc19        updates-testing  27 k

Transaction Summary
================================================================================
Install   3 Packages
Upgrade  82 Packages

Total size: 41 M
Installed size: 41 M
Is this ok [y/N]: y
Downloading Packages:
Running Transaction Check
ERROR with transaction check vs depsolve:
xorg-x11-drv-ast < 0.97.0-9 is obsoleted by xorg-x11-drv-modesetting-0.6.0-7.fc19.i686
To diagnose the problem, try running: 'rpm -Va --nofiles --nodigest'.
To fix inconsistent RPMDB, try running: 'rpm --rebuilddb'.
If the above doesn't help please report this error at 'https://bugzilla.redhat.com/enter_bug.cgi?product=Fedora&component=dnf'.
[root@netbook ~]# rpm -Va --nofiles --nodigest
Unsatisfied dependencies for gnome-applets-1:3.5.92-3.fc18.i686:
	libgweather-3.so.1 is needed by (installed) gnome-applets-1:3.5.92-3.fc18.i686

rpm --rebuilddb doesn't help.

Expected results:

dnf upgrade works.

Additional info:

F18 updated to F19 alpha, so it's no clean alpha install.
Comment 1 Laurent Wandrebeck 2013-05-12 08:18:47 EDT
[root@netbook ~]# yum update
<snip>
(85/85): system-config-printer-libs-1.4.1-1.fc19.noarch.rp | 944 kB   00:06     
Finishing delta rebuilds of 30 package(s) (28 M)
error: rpmdb: BDB0113 Thread/process 4537/3078158144 failed: BDB1507 Thread died in Berkeley DB library
error: db5 error(-30973) from dbenv->failchk: BDB0087 DB_RUNRECOVERY: Fatal error, run database recovery
error: cannot open Packages index using db5 -  (-30973)
error: cannot open Packages database in 
error: rpmdb: BDB0113 Thread/process 4583/3078022976 failed: BDB1507 Thread died in Berkeley DB library
error: db5 error(-30973) from dbenv->failchk: BDB0087 DB_RUNRECOVERY: Fatal error, run database recovery
error: cannot open Packages index using db5 -  (-30973)
error: cannot open Packages database in 
--------------------------------------------------------------------------------
Total                                           127 kB/s |  15 MB     02:01     
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
Warning: RPMDB altered outside of yum.
  Updating   : gnome-shell-extension-common-3.8.1-3.fc19.noarch 
etc etc.

As far as I can remember, it's a first-timer for me to see rpmdb thread dying.
Update is ongoing anyway. And yes, rpm --rebuilddb was run prior to yum udate, and reported nothing.
Comment 2 Ales Kozumplik 2013-05-13 02:17:51 EDT
Hello and thank you for the report,

I just found out in my own testing last week that in some cases DNF fails to handle obsoleting packages correctly, resulting in the 'transaction check vs depsolve' error. I fixed this on a development branch:

https://github.com/akozumpl/dnf/commit/ad2525664d6c08697c6e168f6069c6a7aff36378

This fix should make dnf-0.3.5, and I'll make sure to update this bug then.
Comment 3 Ales Kozumplik 2013-05-13 04:37:21 EDT
The fix is on the master branch now, commit ad25256, will be included in dnf-0.3.5.
Comment 4 Ales Kozumplik 2013-05-24 10:02:09 EDT
*** Bug 966769 has been marked as a duplicate of this bug. ***
Comment 5 Ales Kozumplik 2013-06-03 03:53:35 EDT
*** Bug 969873 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.