Bug 966861 - unattended installation failure on unpartitioned image when using virtio_blk
unattended installation failure on unpartitioned image when using virtio_blk
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virtio-win (Show other bugs)
6.5
Unspecified Unspecified
urgent Severity urgent
: beta
: ---
Assigned To: Vadim Rozenfeld
Virtualization Bugs
: Regression, TestBlocker
: 1000070 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-24 02:59 EDT by Xiaoqing Wei
Modified: 2014-01-01 11:40 EST (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-01 11:40:57 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
snapshot (36.90 KB, image/jpeg)
2013-05-24 02:59 EDT, Xiaoqing Wei
no flags Details
disk img (91.08 KB, application/octet-stream)
2013-05-25 05:52 EDT, Xiaoqing Wei
no flags Details

  None (edit)
Description Xiaoqing Wei 2013-05-24 02:59:20 EDT
Created attachment 752481 [details]
snapshot

Description of problem:

unattended installation failure while manually success when using virtio_blk(W2012 saying unsupported NTFS version)

Version-Release number of selected component (if applicable):
virtio-win-prewhql-0.1-62

How reproducible:
100%

Steps to Reproduce:
1. start a Win2012 unattended installation, with virtio_blk device
/home/staf-kvm-devel/autotest-devel/client/tests/virt/qemu/qemu \
    -S \
    -name 'vm1' \
    -chardev socket,id=qmp_id_qmpmonitor1,path=/tmp/monitor-qmpmonitor1-20130523-203459-YyMKnKrR,server,nowait \
    -mon chardev=qmp_id_qmpmonitor1,mode=control \
    -chardev socket,id=serial_id_serial1,path=/tmp/serial-serial1-20130523-203459-YyMKnKrR,server,nowait \
    -device isa-serial,chardev=serial_id_serial1 \
    -chardev socket,id=seabioslog_id_20130523-203459-YyMKnKrR,path=/tmp/seabios-20130523-203459-YyMKnKrR,server,nowait \
    -device isa-debugcon,chardev=seabioslog_id_20130523-203459-YyMKnKrR,iobase=0x402 \
    -device ich9-usb-uhci1,id=usb1,bus=pci.0,addr=0x4 \
    -drive file='/home/staf-kvm-devel/autotest-devel/client/tests/virt/shared/data/images/win2012-64-virtio.qcow2',if=none,id=drive-virtio-disk1,media=disk,cache=none,snapshot=off,format=qcow2,aio=native \
    -device virtio-blk-pci,bus=pci.0,addr=0x5,drive=drive-virtio-disk1 \
    -device virtio-net-pci,netdev=idJdZlo8,mac=9a:7b:7c:7d:7e:7f,bus=pci.0,addr=0x3,id='idf9WYpR' \
    -netdev tap,id=idJdZlo8,vhost=on,fd=23 \
    -m 4096 \
    -smp 2,maxcpus=2,cores=1,threads=1,sockets=2 \
    -cpu 'Opteron_G2' \
    -M rhel6.5.0 \
    -drive file='/home/staf-kvm-devel/autotest-devel/client/tests/virt/shared/data/isos/ISO/Win2012/en_windows_server_2012_x64_dvd_915478.iso',if=none,id=drive-ide0-0-0,media=cdrom,snapshot=off,format=raw \
    -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0 \
    -drive file='/home/staf-kvm-devel/autotest-devel/client/tests/virt/shared/data/isos/windows/winutils.iso',if=none,id=drive-ide0-0-1,media=cdrom,snapshot=off,format=raw \
    -device ide-drive,bus=ide.0,unit=1,drive=drive-ide0-0-1 \
    -drive file='/root/virtio-win-prewhql-0.1-58.iso',if=none,id=drive-ide0-1-0,media=cdrom,snapshot=off,format=raw \
    -device ide-drive,bus=ide.1,unit=0,drive=drive-ide0-1-0 \
    -device AC97 \
    -drive file='/home/staf-kvm-devel/autotest-devel/client/tests/virt/shared/data/images/win2012-64/answer.vfd',if=none,id=fdc0-0-0,media=disk,snapshot=off,readonly=off,format=raw \
    -global isa-fdc.driveA=fdc0-0-0 \
    -device usb-tablet,id=usb-tablet1,bus=usb1.0,port=1 \
    -vnc :0 \
    -vga std \
    -rtc base=localtime,clock=host,driftfix=slew  \
    -boot order=cdn,once=d,menu=off  \
    -enable-kvm

2.
3.

Actual results:
W2012 fail to copy files, and saying(with snap attached.):
'Windows cannot be installed to this hard disk space. This hard disk space is formmatted with an unsupported version of the NTFS file system. Please back up any data you have on this partition. then, restart the computer using the Windows installation disk, perform a custom installation and reformat the hard disk partition'
 

Expected results:
VM installation success w/o any problem.

Additional info:
1) when using virtio_scsi, everything works fine.
/home/staf-kvm-devel/autotest-devel/client/tests/virt/qemu/qemu \
    -S \
    -name 'vm1' \
    -chardev socket,id=qmp_id_qmpmonitor1,path=/tmp/monitor-qmpmonitor1-20130523-203459-YyMKnKrR,server,nowait \
    -mon chardev=qmp_id_qmpmonitor1,mode=control \
    -chardev socket,id=serial_id_serial1,path=/tmp/serial-serial1-20130523-203459-YyMKnKrR,server,nowait \
    -device isa-serial,chardev=serial_id_serial1 \
    -chardev socket,id=seabioslog_id_20130523-203459-YyMKnKrR,path=/tmp/seabios-20130523-203459-YyMKnKrR,server,nowait \
    -device isa-debugcon,chardev=seabioslog_id_20130523-203459-YyMKnKrR,iobase=0x402 \
    -device ich9-usb-uhci1,id=usb1,bus=pci.0,addr=0x4 \
    -device virtio-scsi-pci,id=virtio_scsi_pci0,addr=0x5 \
    -drive file='/home/staf-kvm-devel/autotest-devel/client/tests/virt/shared/data/images/win2012-64-virtio.qcow2',if=none,id=virtio-scsi-id0,media=disk,cache=none,snapshot=off,format=qcow2,aio=native \
    -device scsi-hd,drive=virtio-scsi-id0 \
    -device virtio-net-pci,netdev=idJdZlo8,mac=9a:8c:8d:8e:8f:90,bus=pci.0,addr=0x3,id='idf9WYpR' \
    -netdev tap,id=idJdZlo8,vhost=on,fd=23 \
    -m 2048 \
    -smp 2,maxcpus=2,cores=1,threads=1,sockets=2 \
    -cpu 'Opteron_G2' \
    -M rhel6.5.0 \
    -drive file='/home/staf-kvm-devel/autotest-devel/client/tests/virt/shared/data/isos/ISO/Win2012/en_windows_server_2012_x64_dvd_915478.iso',if=none,id=virtio-scsi-id1,media=cdrom,snapshot=off,readonly=on,format=raw \
    -device scsi-cd,drive=virtio-scsi-id1 \
    -drive file='/home/staf-kvm-devel/autotest-devel/client/tests/virt/shared/data/isos/windows/winutils.iso',if=none,id=virtio-scsi-id2,media=cdrom,snapshot=off,readonly=on,format=raw \
    -device scsi-cd,drive=virtio-scsi-id2 \
    -drive file='/root/virtio-win-prewhql-0.1-62.iso',if=none,id=virtio-scsi-id3,media=cdrom,snapshot=off,readonly=on,format=raw \
    -device scsi-cd,drive=virtio-scsi-id3 \
    -device AC97 \
    -drive file='/home/staf-kvm-devel/autotest-devel/client/tests/virt/shared/data/images/win2012-64/answer.vfd',if=none,id=fdc0-0-0,media=disk,snapshot=off,readonly=off,format=raw \
    -global isa-fdc.driveA=fdc0-0-0 \
    -device usb-tablet,id=usb-tablet1,bus=usb1.0,port=1 \
    -vnc :0 \
    -vga std \
    -rtc base=localtime,clock=host,driftfix=slew  \
    -boot order=cdn,once=d,menu=off  \
    -enable-kvm
Comment 6 Vadim Rozenfeld 2013-05-24 06:58:55 EDT
the problem is really very unusual. 
Can you please try running the same
scenario on pre-formatted disk image?

Thanks,
Vadim.
Comment 7 Xiaoqing Wei 2013-05-25 05:50:09 EDT
(In reply to Vadim Rozenfeld from comment #6)
> the problem is really very unusual. 
> Can you please try running the same
> scenario on pre-formatted disk image?
> 
> Thanks,
> Vadim.

No knowing how to unattended install a win os w/ a pre-formatted disk, or even whether it supports,

will search msft docs and try to do that.

and I will upload the xz'ed qcow2 file, which met this bz.


Regards,
Xiaoqing.
Comment 8 Xiaoqing Wei 2013-05-25 05:52:12 EDT
Created attachment 752969 [details]
disk img
Comment 10 Xiaoqing Wei 2013-05-29 03:26:45 EDT
Hi Vadim,

I tried removed the partitioning statements from https://bugzilla.redhat.com/show_bug.cgi?id=966861#c1 ,
with a pre-formatted img, it works !
installation didn't stuck at NTFS formation.


lines removed from BZ autounattend.xml
----------
<             <DiskConfiguration>
<                 <WillShowUI>OnError</WillShowUI>
<                 <Disk wcm:action="add">
<                     <CreatePartitions>
<                         <CreatePartition wcm:action="add">
<                             <Order>1</Order>
<                             <Size>30000</Size>
<                             <Type>Primary</Type>
<                         </CreatePartition>
<                     </CreatePartitions>
<                     <ModifyPartitions>
<                         <ModifyPartition wcm:action="add">
<                             <Active>true</Active>
<                             <Extend>false</Extend>
<                             <Format>NTFS</Format>
<                             <Label>OS_Install</Label>
<                             <Letter>C</Letter>
<                             <Order>1</Order>
<                             <PartitionID>1</PartitionID>
<                         </ModifyPartition>
<                     </ModifyPartitions>
<                     <DiskID>0</DiskID>
<                     <WillWipeDisk>true</WillWipeDisk>
<                 </Disk>
<             </DiskConfiguration>

----------


with virtio-win-prewhql-63
Comment 13 Xiaoqing Wei 2013-06-03 22:51:45 EDT
change the bz to more descriptive name
Comment 14 Keno Fischer 2013-06-08 23:34:38 EDT
I am having the same problem trying to install Windows 7 on a VirtIO drive. Anything you need me to test?
Comment 15 Keno Fischer 2013-06-08 23:46:01 EDT
FWIW, this works fine with virtio-win-0.1-52.iso, but fails with virtio-win-0.1-59.iso.
Comment 16 Vadim Rozenfeld 2013-06-10 04:11:30 EDT
(In reply to Keno Fischer from comment #15)
> FWIW, this works fine with virtio-win-0.1-52.iso, but fails with
> virtio-win-0.1-59.iso.

Yes, it's a regression. Will fix it soon.
Vadim.
Comment 17 Xiaoqing Wei 2013-08-02 04:05:43 EDT
(In reply to Vadim Rozenfeld from comment #16)
> (In reply to Keno Fischer from comment #15)
> > FWIW, this works fine with virtio-win-0.1-52.iso, but fails with
> > virtio-win-0.1-59.iso.
> 
> Yes, it's a regression. Will fix it soon.
> Vadim.

Hello Vadim,

could you pls give a update of this bug ?

as both RHEL.6.5 and RHEL.7 use identical virtio-win binary,
this bz blocked both Acceptance Tests, is there any plan of fixing ?

Regards,
Xiaoqing.
Comment 18 Xiaoqing Wei 2013-08-02 04:09:52 EDT
as both RHEL.6.5 and RHEL.7 Acceptances blocked, Setting urgent/urgent
Comment 19 Vadim Rozenfeld 2013-08-02 07:31:31 EDT
(In reply to Xiaoqing Wei from comment #17)
> (In reply to Vadim Rozenfeld from comment #16)
> > (In reply to Keno Fischer from comment #15)
> > > FWIW, this works fine with virtio-win-0.1-52.iso, but fails with
> > > virtio-win-0.1-59.iso.
> > 
> > Yes, it's a regression. Will fix it soon.
> > Vadim.
> 
> Hello Vadim,
> 
> could you pls give a update of this bug ?
> 
> as both RHEL.6.5 and RHEL.7 use identical virtio-win binary,
> this bz blocked both Acceptance Tests, is there any plan of fixing ?
> 
> Regards,
> Xiaoqing.

Hi Xiaoqing,
Hopefully it will be fixed next week.
Best regards,
Vadim.
Comment 20 Vadim Rozenfeld 2013-08-22 20:38:07 EDT
*** Bug 1000070 has been marked as a duplicate of this bug. ***
Comment 21 Vadim Rozenfeld 2013-09-08 01:51:10 EDT
please re-check with build 68 or 69 available at https://brewweb.devel.redhat.com/buildinfo?buildID=293655

Thanks
Vadim.
Comment 23 Mike Cao 2013-10-11 06:06:13 EDT
Move status to VERIFIED according to comment #22

Note You need to log in before you can comment on or make changes to this bug.