Bug 966899 - thermostat: GUI window content does not fill whole window
thermostat: GUI window content does not fill whole window
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: java-1.7.0-openjdk (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Omair Majid
Fedora Extras Quality Assurance
:
: 966905 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-24 04:47 EDT by Mikolaj Izdebski
Modified: 2013-09-09 16:35 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-09 16:35:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of GUI (20.91 KB, image/png)
2013-05-24 04:47 EDT, Mikolaj Izdebski
no flags Details

  None (edit)
Description Mikolaj Izdebski 2013-05-24 04:47:46 EDT
Created attachment 752512 [details]
Screenshot of GUI

Description of problem:
Thermostat GUI content does not fill the whole available space in the window.

How reproducible:
Always.

Steps to Reproduce:
1. yum install thermostat awesome xserver-xorg
2. thermostat service &
3. echo exec awesome >~/.xinitrc && chmod +x ~/.xinitrc
4. startx
5. press Mod4+Space (Mod4 is the key between Control and Alt, usually)
6. press Mod4+Enter to open xterm
7. run "thermostat gui" from xterm

Actual results:
GUI content does not fill the whole available space in the window.

Expected results:
GUI content does fill the whole available space in the window.

Additional info:
See attachement.
Comment 1 Omair Majid 2013-05-24 09:48:11 EDT
This is a bug in OpenJDK/swing, not thermostat. OpenJDK is sensitive to which window manager is being used and things break with an unknown window manager [1][2].

You can work around this by:
1. yum install wmname
2. wmname LG3D

[1] http://omajid.wordpress.com/2012/04/11/openjdk-and-awesome/
[2] http://awesome.naquadah.org/wiki/Problems_with_Java
Comment 2 Omair Majid 2013-05-24 09:54:04 EDT
*** Bug 966905 has been marked as a duplicate of this bug. ***
Comment 3 Omair Majid 2013-09-09 16:35:53 EDT
awesomewm is now a reparenting window manager. I can not reproduce this bug any more with F19.

Note You need to log in before you can comment on or make changes to this bug.