Bug 966948 - Displaying of some parts of gnome-shell isn't correct on some nVidia cards
Displaying of some parts of gnome-shell isn't correct on some nVidia cards
Status: CLOSED EOL
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nouveau (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ben Skeggs
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-24 07:13 EDT by Petr Schindler
Modified: 2015-02-17 10:19 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-02-17 10:19:45 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Video with displaying errors (13.16 MB, video/mp4)
2013-05-24 07:13 EDT, Petr Schindler
no flags Details

  None (edit)
Description Petr Schindler 2013-05-24 07:13:40 EDT
Created attachment 752542 [details]
Video with displaying errors

Description of problem:
It happens on GeForce 7300 GT and . There are some displaying errors especially in Activity (overview). For example: when I move cursor over some button of some gnome-shell dialog (for example power off dialog) this button disappears so there is only shadow rectangle (it should highlight the button).

Worse case is displaying overview mode. As you can see on the attached video. It isn't displayed correctly at all, there isn't background, when I move cursor over icons the display is blinking. And when I am in application overview, there isn't any visible icon. Please look on the video.

I'm sorry that the video is in mp4, but I had to tape it on mobile, because when I started gnome-shell recording it acted differently.

Version-Release number of selected component (if applicable):
xorg-x11-drv-nouveau-1.0.7-1.fc19.x86_64

How reproducible:
overview every time, buttons disappear only once (mostly

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Petr Schindler 2013-05-24 07:29:33 EDT
The second graphic I tested is Quadro NVS 110M/GeForce Go 7300 and it is broken too.
Comment 2 Kamil Páral 2013-05-24 08:11:11 EDT
I worked on the system from comment 1 several times and quite shortly it may end up in a state where GNOME is totally unusable. For example the whole screen goes black/some other color, or the image is totally distorted in some way.
Comment 3 Petr Schindler 2013-05-27 03:23:09 EDT
Desktop QA team tested this on another nVidia cards and it seems like there is a problem only with one particular chipset (G72M).
Comment 4 zwartgat 2013-05-29 17:07:48 EDT
The exact same problem also occurs on a GeForce 7900 GS graphics card.
Comment 5 Kamil Páral 2013-06-05 06:37:53 EDT
Please note that with "Quadro NVS 110M/GeForce Go 7300" I have problems to even boot F19 TC1 from PXE/DVD/netinst, unless I have "quiet" specified on the command line.
Comment 6 Clarke Wixon 2013-06-11 14:55:28 EDT
Like zwartgat above (Comment 4), I experience identical artifacts on a 7900GS card.  Same red/green gradients and everything.

So I confirm the problem is seemingly broader than just the G72M chipset -- but all the reports/descriptions I have seen DO seem to involve nVidia 7-series.

See also duplicate bug 971590 for another user's report.
Comment 7 Marian 2013-06-24 11:16:53 EDT
Same as this bug https://bugzilla.redhat.com/show_bug.cgi?id=977346
Comment 8 Didier G 2013-07-15 06:50:52 EDT
Same bug on Toshiba M5 laptop with:

01:00.0 VGA compatible controller: NVIDIA Corporation G72M [Quadro NVS 110M] (rev a1)

On this laptop Fedora 19 is unusable out of the box.


Based on information found in Bugzilla # 977346 I worked around this problem with a xorg.conf file in /etc/X11

1/ start in level 3

2/ run 
Xorg :1 -configure

3/ move xorg.conf.new
mv /root/xorg.conf.new /etc/X11/xorg.conf

4/ reboot


With this xorg.conf display is now correct.
Comment 9 Marian 2013-08-27 06:46:39 EDT
No way to use nvidia open source module consider to use nvidia proprietary driver.
Comment 10 Alexandre Franke 2013-09-16 15:08:37 EDT
Duplicate of bug 991806 ?
Comment 11 Fedora End Of Life 2015-01-09 13:12:37 EST
This message is a notice that Fedora 19 is now at end of life. Fedora 
has stopped maintaining and issuing updates for Fedora 19. It is 
Fedora's policy to close all bug reports from releases that are no 
longer maintained. Approximately 4 (four) weeks from now this bug will
be closed as EOL if it remains open with a Fedora 'version' of '19'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 19 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 12 Fedora End Of Life 2015-02-17 10:19:45 EST
Fedora 19 changed to end-of-life (EOL) status on 2015-01-06. Fedora 19 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.