Bug 966949 - Empty result bar remains open on sync status page and set size of repo to '0' byte
Empty result bar remains open on sync status page and set size of repo to '0'...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI (Show other bugs)
6.0.1
Unspecified Unspecified
unspecified Severity low (vote)
: Unspecified
: --
Assigned To: Justin Sherrill
Sachin Ghai
: Triaged
: 970723 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-24 07:14 EDT by Sachin Ghai
Modified: 2013-07-18 17:21 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-18 17:21:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
sync status page showing resuly bar empty for the repos which are successfully synced and size reset to '0' (35.80 KB, image/png)
2013-05-24 07:14 EDT, Sachin Ghai
no flags Details
UI shows all repos on clicking 'only show syncing' (55.16 KB, image/png)
2013-05-24 07:24 EDT, Sachin Ghai
no flags Details
sync status page correctly showing the sync status, repo size and result bar (41.14 KB, image/png)
2013-06-07 06:23 EDT, Sachin Ghai
no flags Details

  None (edit)
Description Sachin Ghai 2013-05-24 07:14:16 EDT
Created attachment 752543 [details]
sync status page showing resuly bar empty for the repos which are successfully synced and size reset to '0'

Description of problem:
Create a repo and sync it. Once sync is finished, move away from sync status page to other page and navigate back to sync status.

Two issues:

- Result bar remains open and empty
- size of repo sets to '0' byte

Version-Release number of selected component (if applicable):
Sat6-MDP1-Drop2 
katello-glue-elasticsearch-1.4.2-7.el6sat.noarch
ruby193-rubygem-katello-foreman-engine-0.0.1-1.el6_4.noarch
katello-qpid-broker-key-pair-1.0-1.noarch
katello-cli-1.4.2-6.el6sat.noarch
katello-qpid-client-key-pair-1.0-1.noarch
katello-cli-common-1.4.2-6.el6sat.noarch
ruby193-rubygem-foreman-katello-engine-0.0.7-1.el6sat.noarch
signo-katello-0.0.12-1.el6sat.noarch
katello-selinux-1.4.3-3.el6sat.noarch
katello-glue-pulp-1.4.2-7.el6sat.noarch
katello-all-1.4.2-7.el6sat.noarch
katello-common-1.4.2-7.el6sat.noarch
katello-1.4.2-7.el6sat.noarch
katello-foreman-all-1.4.2-7.el6sat.noarch
ruby193-rubygem-katello_api-0.0.3-2.el6_4.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-configure-1.4.3-10.el6sat.noarch
katello-glue-candlepin-1.4.2-7.el6sat.noarch
katello-configure-foreman-1.4.3-10.el6sat.noarch
katello-certs-tools-1.4.2-2.el6sat.noarch

How reproducible:
always

Steps to Reproduce:
1. Create a repo
2. sync it
3. Once sync is finished, move away from sync status page and navigate back 

Actual results:
- Result bar remains open and empty
- size of repo re-sets to '0' byte

Expected results:
Empty result bar shouldn't be displayed on UI
Size of existing repo's shouldn't be set to '0'

Additional info:
Please see the screenshot
Comment 1 Sachin Ghai 2013-05-24 07:23:04 EDT
One more observation which I think related to this bug is, when you click 'only show syncing' the UI displays all repo's for which sync is actually not running.
Comment 2 Sachin Ghai 2013-05-24 07:24:09 EDT
Created attachment 752548 [details]
UI shows all repos on clicking 'only show syncing'
Comment 3 Og Maciel 2013-05-31 17:48:11 EDT
Here's what Firebug shows as the response for that page:

  [{"id":10,"product_id":3,"progress":{"count":0,"left":0,"progress":0},"sync_id":null,"state":null,"raw_state":"success","start_time":"about 6 hours ago","finish_time":"about 3 hours ago","duration":"about 3 hours","packages":0,"display_size":"0 Bytes","size":0,"is_running":true,"error_details":[]},{"id":11,"product_id":9,"progress":{"count":0,"left":0,"progress":0},"sync_id":null,"state":null,"raw_state":"success","start_time":"about 6 hours ago","finish_time":"about 6 hours ago","duration":"1 minute","packages":0,"display_size":"0 Bytes","size":0,"is_running":true,"error_details":[]},{"id":12,"product_id":9,"progress":{"count":0,"left":0,"progress":0},"sync_id":null,"state":null,"raw_state":"success","start_time":"about 6 hours ago","finish_time":"about 6 hours ago","duration":"1 minute","packages":0,"display_size":"0 Bytes","size":0,"is_running":true,"error_details":[]},{"id":13,"product_id":10,"progress":{"count":0,"left":0,"progress":0},"sync_id":null,"state":null,"raw_state":"success","start_time":"4 minutes ago","finish_time":"4 minutes ago","duration":"less than a minute","packages":0,"display_size":"0 Bytes","size":0,"is_running":true,"error_details":[]}]
Comment 4 Justin Sherrill 2013-06-03 10:21:27 EDT
Couple of issues here:

1) Once a sync task gets moved to the 'history queue' we aren't recognizing that its finished

2) The package size is not being properly calculated



for 1) this is easy to fix. 

for 2) its a bit more complicated.  Pulpv2 does not ever give us the total size of a repo, only the size of packages being synced.  That information seems to go away once the sync task is moved to the history queue. 

I will fix 1) in this bugzilla and open a new one for the size issue.  

Relevant pulp bugzilla to support repo sizes:  https://bugzilla.redhat.com/show_bug.cgi?id=861409
Comment 5 Justin Sherrill 2013-06-03 13:29:07 EDT
https://github.com/Katello/katello/pull/2414

so i fixed the size disappearing too, but keep in mind that this only shows the size of the content that was last synced.  i.e. if you sync a repo once, it will show the full size of the repo, if you sync it again it will only show what has been added (which may be zero).
Comment 6 Justin Sherrill 2013-06-04 15:31:28 EDT
*** Bug 970723 has been marked as a duplicate of this bug. ***
Comment 8 Brad Buckingham 2013-06-06 17:58:35 EDT
Mass move to ON_QA
Comment 9 Sachin Ghai 2013-06-07 06:22:09 EDT
Verified with following build:

* apr-util-ldap-1.3.9-3.el6_0.1.x86_64
* candlepin-0.8.9-1.el6_4.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.8.9-1.el6_4.noarch
* candlepin-tomcat6-0.8.9-1.el6_4.noarch
* elasticsearch-0.19.9-8.el6sat.noarch
* foreman-1.1.10004-1.noarch
* foreman-installer-puppet-concat-0-2.d776701.git.0.21ef926.el6sat.noarch
* foreman-installer-puppet-dhcp-0-5.3a4a13c.el6sat.noarch
* foreman-installer-puppet-dns-0-7.fcae203.el6sat.noarch
* foreman-installer-puppet-foreman-0-6.568c5c4.el6sat.noarch
* foreman-installer-puppet-foreman_proxy-0-8.bd1e35d.el6sat.noarch
* foreman-installer-puppet-puppet-0-3.ab46748.el6sat.noarch
* foreman-installer-puppet-tftp-0-5.ea6c5e5.el6sat.noarch
* foreman-installer-puppet-xinetd-0-50a267b8.git.0.44aca6a.el6sat.noarch
* foreman-postgresql-1.1.10004-1.noarch
* foreman-proxy-1.1.10003-1.el6sat.noarch
* foreman-proxy-installer-1.0.1-8.f5ae2cd.el6sat.noarch
* katello-1.4.2-10.el6sat.noarch
* katello-all-1.4.2-10.el6sat.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.4.2-2.el6sat.noarch
* katello-cli-1.4.2-7.el6sat.noarch
* katello-cli-common-1.4.2-7.el6sat.noarch
* katello-common-1.4.2-10.el6sat.noarch
* katello-configure-1.4.3-14.el6sat.noarch
* katello-configure-foreman-1.4.3-14.el6sat.noarch
* katello-foreman-all-1.4.2-10.el6sat.noarch
* katello-glue-candlepin-1.4.2-10.el6sat.noarch
* katello-glue-elasticsearch-1.4.2-10.el6sat.noarch
* katello-glue-pulp-1.4.2-10.el6sat.noarch
* katello-qpid-broker-key-pair-1.0-1.noarch
* katello-qpid-client-key-pair-1.0-1.noarch
* katello-selinux-1.4.3-3.el6sat.noarch
* openldap-2.4.23-31.el6.x86_64
* pulp-rpm-plugins-2.1.1-1.el6sat.noarch
* pulp-selinux-2.1.1-1.el6sat.noarch
* pulp-server-2.1.1-1.el6sat.noarch
* python-ldap-2.3.10-1.el6.x86_64
* ruby193-rubygem-ldap_fluff-0.2.2-1.el6sat.noarch
* ruby193-rubygem-net-ldap-0.3.1-2.el6sat.noarch
* signo-0.0.16-1.el6sat.noarch
* signo-katello-0.0.16-1.el6sat.noarch

Sync status page looking absolutely fine. The result bar correctly showing the progress and on completion the status bar replaced by 'sync complete' message.

Also the size of repo is correctly displayed.
Comment 10 Sachin Ghai 2013-06-07 06:23:27 EDT
Created attachment 758113 [details]
sync status page correctly showing the sync status, repo size and result bar
Comment 11 Mike McCune 2013-07-18 17:21:34 EDT
mass move to CLOSED:CURRENTRELEASE since MDP1 has been released.

Note You need to log in before you can comment on or make changes to this bug.