Bug 967154 - virt-viewer does not respect auto configuration of monitors
virt-viewer does not respect auto configuration of monitors
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: mingw-virt-viewer (Show other bugs)
3.1.3
Unspecified Unspecified
high Severity high
: ---
: 3.3.0
Assigned To: Marc-Andre Lureau
Desktop QE
spice
: ZStream
Depends On:
Blocks: 973664
  Show dependency treegraph
 
Reported: 2013-05-24 21:33 EDT by Bryan Yount
Modified: 2016-02-10 15:20 EST (History)
8 users (show)

See Also:
Fixed In Version: mingw-virt-viewer-0.5.6-3.el6_4
Doc Type: Bug Fix
Doc Text:
Previously, virt-viewer did not respect the automatic configuration of monitors as set by the client machine. Now, monitor settings are respected by virt-viewer and no longer need to be manually changed every time the virtual machine is restarted.
Story Points: ---
Clone Of:
: 973664 (view as bug list)
Environment:
Last Closed: 2014-01-21 09:45:48 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Spice
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 379873 None None None Never

  None (edit)
Description Bryan Yount 2013-05-24 21:33:21 EDT
Description of problem:
The virt-viewer Spice client does not respect the auto-conf setting passed from controller. This results in a guest being configured for 2 displays and not automatically enabling the 2nd monitor if the user has 2 monitors on their client machine.

Version-Release number of selected component (if applicable):
virt-viewer-0.5.3-25 (3.2 beta client)

How reproducible:
Very

Steps to Reproduce:
1. Create VM with only 1 display configured
2. Install rhev-tools-3.1-9
3. Seal the VM with sysprep utility and create a template from it
4. Create a pool of VMs from that template and configure them to have 2 displays


Actual results:
Users connect with virt-viewer and *only 1 display* appears. The user has to open the Windows display GUI and enable the 2nd monitor manually.

Expected results:
The configuration of the VM to have 2 displays should cause virt-viewer to detect if the client also has 2 displays and automatically open up (enable) the 2nd display in the guest.


Additional info:
This is a big enough issue that I am formally requesting a GA (or if that's not possible, a Z stream) patch to 3.2.

Here's what the behavior was with the old spicec:
1. Create VM with only 1 display configured
2. Install rhev-tools-3.1-9
3. Seal the VM with sysprep utility and create a template from it
4. Create a pool of VMs from that template and configure them to have 2 displays
5. Users connect with old spicec and 2 displays appear
Comment 2 Marc-Andre Lureau 2013-05-27 08:30:00 EDT
patch sent:
https://www.redhat.com/archives/virt-tools-list/2013-May/msg00088.html

This bug is the result of a lack of specification (there was a FIXME in the code). It has not been reported before, after 1y of RHEL6 and 6 months of RHEVM integration. I think we could just reconsider the severity. Fortunately, the solution is simple.
Comment 8 Charlie 2013-11-27 20:26:37 EST
This bug is currently attached to errata RHEA-2013:15512. If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to 
minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.
* Consequence: What happens when the bug presents.
* Fix: What was done to fix the bug.
* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:

https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes 

Thanks in advance.
Comment 10 errata-xmlrpc 2014-01-21 09:45:48 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0034.html

Note You need to log in before you can comment on or make changes to this bug.