Bug 967159 - When you run command "beesu" does not show modal dialog asking for password using "alt + f2"
When you run command "beesu" does not show modal dialog asking for password u...
Status: CLOSED EOL
Product: Fedora
Classification: Fedora
Component: beesu (Show other bugs)
19
All Linux
unspecified Severity high
: ---
: ---
Assigned To: Tom "spot" Callaway
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-24 23:51 EDT by Bastián Díaz
Modified: 2015-02-17 10:20 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-02-17 10:20:07 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bastián Díaz 2013-05-24 23:51:49 EDT
Description of problem:
The command "beesu" continues to operate from the terminal, however, to execute any command or application running with root privileges "beesu" from "Alt-F2" (eg beesu nautilus), does not appear any window or modal dialog asking for password and therefore can not run the application with root privileges.

Version-Release number of selected component:
OS: fedora 19 (rawhide)
Environment: GNOME 3.8.2
Beesu: version 2.7 (beesu-2.7-9.fc19)

Steps to Reproduce:
1.Typing on the keyboard "Alt + F2"
2.After appearing dialog "Run", type "beesu nautilus" and type enter.
3. Wait a while ... nothing happens.

Actual results:
Nothing happens (graphically)

Expected results:
A dialog box appears asking for root password. Password is entered and executed application.
Comment 1 D. Charles Pyle 2013-09-03 16:33:28 EDT
You might want to visit Koji and grab 2.7-11 and its related packages to update all beesu components.  There are updates in that version that address specific compatibility problems in GNOME 3.8.x.

Do you have the usermode package installed? If not, you might have to install it.  Also make sure that you have all dependencies installed that can be installed.  Sometimes needed dependencies for beesu and its components might get deleted by uninstalling other software packages.

You also may want to visit the following bug for additional information about other incompatibilities and workarounds necessary in GNOME 3.8 and above:

https://bugzilla.redhat.com/show_bug.cgi?id=972600

Comments 13 and 18 in that bug discussion are the newest workarounds to eliminate crashing due to a longtime bug in gEdit when running as root user in GNOME.
Comment 2 Bastián Díaz 2013-09-03 16:43:11 EDT
(In reply to D. Charles Pyle from comment #1)

Hi, thanks for replying.

This is a problem that I solved a while ago and actually is due to the absence of some required packages to run beesu.

As a user I would suggest that the packages needed to run beesu be mandatory dependencies (ie that installed when installing beesu). I noticed when installing fedora-liveusb utility that beesu began operating.

Beesu is an excellent utility and even think it should be among the basic packages to be integrated fedora and gnome-shell.

Thank you.
Comment 3 D. Charles Pyle 2013-09-03 17:14:46 EDT
I agree that it is an excellent utility.  That's why I have been working on fixes to get everything working with GNOME 3.8, nautilus scripts included, and also forked the nautilus scripts to nemo.

Do you by chance remember what dependencies those were that were not automatically installed with beesu?
Comment 4 Bastián Díaz 2013-09-03 17:40:52 EDT
(In reply to D. Charles Pyle from comment #3)

I do not remember all, and although I retried beg for brand new installation, however, is not very efficient yum uninstalling dependencies of a specific package. (now even uninstall liveusb-creator, beesu still works).

usermode
usermode-gtk *

Reviewing the softwarecenter, I see that beesu dependent packages not appear "usermode-gtk", and apparently that was the cause of the problem (since beesu worked from the terminal, but not working in graphical mode).

Hope this helps.

* You know a way to propose to beesu as basic package in fedora. Could usefully be incorporated into the livecd, since like debian / ubuntu, gksudo is very useful for solving problems from the livecd.

Thank you.
Comment 5 D. Charles Pyle 2013-09-03 18:19:43 EDT
Thank you for the information.  That information is exactly what I was looking for.

Unfortunately, I have no idea how to propose making beesu and components basic packages for Fedora.  I think that they should be, unless there are plans in the works to add the functionality directly into the shell.  I am not privy to such information at this time.

I would love for it to be the default but who knows? Again, thank you for the information.
Comment 6 Fedora End Of Life 2015-01-09 13:12:57 EST
This message is a notice that Fedora 19 is now at end of life. Fedora 
has stopped maintaining and issuing updates for Fedora 19. It is 
Fedora's policy to close all bug reports from releases that are no 
longer maintained. Approximately 4 (four) weeks from now this bug will
be closed as EOL if it remains open with a Fedora 'version' of '19'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 19 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 7 Fedora End Of Life 2015-02-17 10:20:07 EST
Fedora 19 changed to end-of-life (EOL) status on 2015-01-06. Fedora 19 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.