Bug 972600 - Beesu - gedit-beesu-plugin does not load in gedit preferences -> plugins; plugin does not work
Beesu - gedit-beesu-plugin does not load in gedit preferences -> plugins; plu...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: beesu (Show other bugs)
19
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Tom "spot" Callaway
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-10 04:10 EDT by D. Charles Pyle
Modified: 2014-06-28 00:44 EDT (History)
5 users (show)

See Also:
Fixed In Version: beesu-2.7-11.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-24 18:49:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed Patch to make gedit-beesu-plugin work in Gedit 3.8 on Fedora 19 (1.81 KB, patch)
2013-06-10 14:34 EDT, D. Charles Pyle
no flags Details | Diff
Proposed Patch to make gedit-beesu-plugin work in Gedit 3.8 on Fedora 19 (Supersedes last proposal) (2.55 KB, patch)
2013-06-11 02:35 EDT, D. Charles Pyle
no flags Details | Diff
Screenshot of gEdit beesu plugin prompt. (115.48 KB, image/png)
2013-09-03 03:33 EDT, D. Charles Pyle
no flags Details

  None (edit)
Description D. Charles Pyle 2013-06-10 04:10:28 EDT
Description of problem:
gedit-beesu-plugin does not load, gives errors stating that loader python cannot be found, and displays a red dialog-error icon.  If run from terminal, errors like the following appear:

$ gedit
Traceback (most recent call last):
  File "/usr/lib64/gedit/plugins/beesu/__init__.py", line 1, in <module>
    from beesu import beesuPlugin
  File "/usr/lib64/gedit/plugins/beesu/beesu.py", line 16, in <module>
    import gedit
ImportError: No module named gedit

(gedit:3051): libpeas-WARNING **: Error loading plugin 'beesu'

Version-Release number of selected component (if applicable):
gedit-beesu-plugin-0.4-9.fc19.x86_64

How reproducible:
100% for me, and for others around the Internet.

Steps to Reproduce:
1. Open preferences dialog.
2. Click plugins tab.
3. Click "Open as root" checkbox.

Actual results:
Errors as above given, error icon displays, plugin does not load, loader python cannot be found.

Expected results:
Plugin loads and Open as 'root'" should appear in Tools menu in Gedit.

Additional info:
Related to prior bug:
https://bugzilla.redhat.com/show_bug.cgi?id=786734

I tried to create a patch file but for some reason I am at the moment unable to do so.  In the meantime, here are the changes that need to be made to the files for the plugin to make it load and work as expected.

In beesu.plugin (python 3 is a dependency because of gedit 3.8):

Loader=python

- should read -

Loader=python3

IAge=2

-should read-

IAge=3

In __init__.py:

from beesu import beesuPlugin

- should read -

from .beesu import beesuPlugin

In beesu.py:

print shell_args

- should read -

print(shell_args)

print 'Hey, it says the Popen succeeded.'

- should read -

print('Hey, it says the Popen succeeded.')

After making these above changes on the relevant files on my system, the plugin began working properly (I regularly have been using the modified files for a couple days now with no errors that I have noticed) and plugin now is compatible with Gedit 3.8 and more compatible with python3 and gtk3 on Fedora 19 x86_64.  Relevant debug output from terminal is now as follows:

$ gedit
['beesu', '-l', '-c', '/usr/libexec/gedit-beesu-plugin', 'gedit-beesu-plugin', 'gedit', 'gedit', '/tmp/tmpy3c7de', '/home/dcpyle/.local/share/cinnamon/applets/screen-inhibitor@dcpyle/applet.js']
Last login: Sun Jun  9 23:09:40 MDT 2013 on pts/0
DEBUG: Number of necessary args found.
DEBUG: strcmp succeeded.
DEBUG: Appending additional args to commandline.
DEBUG: lstat on lockfile succeeded.
DEBUG: buf checks passed.
DEBUG: fd initialized.
DEBUG: About to close fd.
DEBUG: fd closed, about to fork.
DEBUG: Going into PID switch.
DEBUG: PID switch case default.
DEBUG: Going into PID switch.
DEBUG: PID switch case 0.
DEBUG: About to call signal(SIGHUP, SIG_IGN).
DEBUG: Going into FORK switch.
DEBUG: FORK switch default.
DEBUG: Waiting for the syncfile to be removed.
DEBUG: FORK switch case 0.
DEBUG: About to execvp gedit gedit /home/dcpyle/.local/share/cinnamon/applets/screen-inhibitor@dcpyle/applet.js.
DEBUG: Syncfile success.
DEBUG: usleeping for 5000000, hope that is long enough for gedit to respawn.
DEBUG: About to return SUCCESS.
Hey, it says the Popen succeeded.

As you can see from the debug output, the plugin now seems to be working as expected. If I can manage to remember how to generate a properly formatted Fedora patch file, I'll submit it ASAP.  Otherwise, the above changes I have proposed should work either if done manually or if submitted as a properly formatted patch file to patch the source files for Fedora 19.

Hope this helps in any case.
Comment 1 D. Charles Pyle 2013-06-10 14:34:38 EDT
Created attachment 759311 [details]
Proposed Patch to make gedit-beesu-plugin work in Gedit 3.8 on Fedora 19

I think I have this formatted right.  It may need to have the locations of the files changed to match the sources archives, however.  Not sure how to go about doing that at the moment since I do not have the sources in front of me as you might have them.

Hopefully this is useful to you.
Comment 2 D. Charles Pyle 2013-06-11 02:35:44 EDT
Created attachment 759439 [details]
Proposed Patch to make gedit-beesu-plugin work in Gedit 3.8 on Fedora 19 (Supersedes last proposal)

This diff/patch file fixes the loading problem and another problem I discovered while testing the patched version.

In this case, I had to do something rather funky to make it work correctly but it now works.  The execvp() function was truncating file names if spaces occurred within the file names.  This made Gedit attempt to create new files containing names before the first space rather than opening the actual file that the Gedit running under a non-root user already had open.

shell_args = ['beesu', '-l', '-c', '/usr/libexec/gedit-beesu-plugin','gedit-beesu-plugin','gedit','gedit',lockfile, filename]

-- was modified to --

shell_args = ['beesu', '-l', '-c', '/usr/libexec/gedit-beesu-plugin','gedit-beesu-plugin','/usr/bin/gedit','gedit', lockfile, '\"%s\"' %filename]

The truncation of file names containing spaces ceased after this modification and the plugin still loaded as expected.

I added a str() function to print(shell_args) because it would have thrown an error otherwise, had the flow of information in the program gotten to that point.  The print() function requires a string and shell_args is not type string in the script.  Coding as print(str(shell_args)) prevents a potential type error that I saw at least once in the debugging output while testing.

I also added two additional lines of code for further debugging info.  This enables the user to see what information was passed to the functions and make comparisons between what was passed to execvp() and what was passed to beesu.

Again, this diff/patch file supersedes the last proposal.  Hope this is helpful and not a hindrance or interference.  The last thing I want to do is to step on anyone's toes.  I just want to help out where I can.
Comment 3 Fedora Update System 2013-06-25 14:34:31 EDT
beesu-2.7-10.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/beesu-2.7-10.fc19
Comment 4 Fedora Update System 2013-06-26 13:08:15 EDT
Package beesu-2.7-10.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing beesu-2.7-10.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-11719/beesu-2.7-10.fc19
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2013-07-02 12:11:13 EDT
beesu-2.7-11.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/beesu-2.7-11.fc19
Comment 6 David Batson 2013-09-02 07:21:34 EDT
This is not working for me.  I made the changes as per the opening comment and per comment #2.  In gedit under the Tools menu is see "Open as root".  When I click on that, the dialog closes, but any files I open, open as user.  I cannot save any files as root.

When I open gedit as user in terminal, gedit opens but I do not see any messages regarding beesu or anything else.

$ gedit
$

Note that I have already added beesu in dconf-editor.  I do not see Edit > Prefernces in my version of gedit, but there is Tools > Open as root.

Schema org.gnome.gedit.plugins

active-plugins ['docinfo', 'beesu', 'filebrowser', 'time', 'spell', 'modelines']

# rpm -qa *beesu*
beesu-2.7-9.fc19.x86_64
gedit-beesu-plugin-0.4-9.fc19.x86_64
nautilus-beesu-manager-1.7-9.fc19.noarch
Comment 7 David Batson 2013-09-02 15:49:35 EDT
I learned a little more.  If I open gedit in terminal, then open a file in gedit, then choose "Open as root" from gedit, in the terminal window I get the following:

$ gedit
['beesu', '-l', '-c', '/usr/libexec/gedit-beesu-plugin', 'gedit-beesu-plugin', '/usr/bin/gedit', 'gedit', '/tmp/tmpyfy5g7', '"/home/dkb/Documents/Beesu-plugin"']
You are attempting to run "beesu" which requires administrative
privileges, but more information is needed in order to do so.
Authenticating as "root"

It is now waiting for me to type root's password in terminal.  If I do that, then the file is opened as root.

However if I open gedit from the Activities menu or from the gedit icon, although the option to "Open is root" is on the gedit menu, it never completes because I am never asked to enter root's password.

Additionally I discovered that the preferences menu for gedit is not on the gedit window, but is available from the taskbar icon next to Activities in the hot corner.

This brings up another more important issue that I haven't been able to resolve.  I was hoping that the gedit-beesu-plugin would work around the issue of the gnome shell crashing when the Activities menu hot corner is clicked on, but alas it does not.  Haven't found a way yet to open gedit as root and have the Activities menu available without crashing gnome shell. :(

It looks like I might have to learn a primative non-gui editor such as vi for creating files as root.  Heck, I'd rather use EDLIN!
Comment 8 D. Charles Pyle 2013-09-02 16:04:30 EDT
The changes stated in the opening comment and in Comment 2 above must be typed exactly, including the spaces and non-spaces and proper single and double quotes in the exact places, and the original lines must either be commented out or removed entirely.  You also should not need to add anything to org.gnome.gedit.plugins using dconf-editor.

The easiest and best way to incorporate the working modifications is to install the latest beesu components for your system.  Try going to koji at the following URL:

http://koji.fedoraproject.org/koji/packageinfo?packageID=7613

Download the packages and upgrade them all (and, if you are using nemo, download the nemo beesu scripts package as well and install that).  While the nemo package isn't required to enable the plugin it is nice to have it when you are using nemo as your file manager.  This will put you at the following versions:

$ rpm -qa *beesu*
gedit-beesu-plugin-0.4-11.fc19.x86_64
beesu-debuginfo-2.7-11.fc19.x86_64
beesu-2.7-11.fc19.x86_64
nemo-beesu-manager-1.7-11.fc19.noarch
nautilus-beesu-manager-1.7-11.fc19.noarch

That should work for you.  If not, let us know what happens and what you have done further.  Also, it would be helpful to include your system specs and configuration for better troubleshooting of any potential problem.  Thanks.

I will log on to my GNOME Shell installation momentarily and see if I can reproduce what you are seeing.  I haven't used GNOME Shell in a while so some new setting of change may have done something to affect beesu like when they came out with 3.8.
Comment 9 D. Charles Pyle 2013-09-02 18:42:33 EDT
Thanks for reporting this. The crashing on hot corner problem only occurs in GNOME and GNOME Classic.  Looks like another change in GNOME broke things again.  Every once in a while something like that happens as the Devs change the internals of GNOME Shell.

I have made another modification that stops the crashing problem thus far for me.  I'll notify the package maintainer and also submit a patch file for the plugin script as soon as I can, but only if the below works for you as well.

In the meantime, edit the /usr/lib64/gedit/plugins/beesu.py file using the nautilus scripts menu item.  You can do this doing the following:

1. Navigate to the file, right-click on it, and navigate the scripts menu to the beesu scripts menu item named "Edit with gEdit."

2. Locate the line that reads:

shell_args = ['beesu', '-l', '-c', '/usr/libexec/gedit-beesu-plugin','gedit-beesu-plugin','/usr/bin/gedit','gedit', lockfile, '\"%s\"' %filename]

3. Remove the l character from the command line, leaving only the - character.  The line should now read as follows (still only a single line):

shell_args = ['beesu', '-', '-c', '/usr/libexec/gedit-beesu-plugin','gedit-beesu-plugin','/usr/bin/gedit','gedit', lockfile, '\"%s\"' %filename]

4. Save the change.

5. Reboot.

See whether the crashing problem when running gedit as root user has been resolved by the change.  Hopefully it will stop crashing.

The application menu on the panel will no longer work while running as root, as still has long been the case when running gedit as another user in GNOME Shell.  But, so far I am no longer seeing the crash I saw.

Please try the above and let us know whether the crashing still occurs when moving the mouse to the hot corner in GNOME Shell.  Hopefully at least that crashing problem will be resolved.
Comment 10 David Batson 2013-09-02 19:15:26 EDT
Still crashing after the change.  It hangs when I click on 'Activities'.
Comment 11 D. Charles Pyle 2013-09-02 20:33:21 EDT
Yes, I have been crashing again, too, since rebooting last. The good news is that I think I have pinpointed the underlying cause.  Something involving menu handling in the GNOME Shell Panel in combination with gEdit causes this.

After killing several GNOME processes, followed by killing X, I found that so long as gEdit displays the full Edit menu that includes the menu item Preferences on the application window, and only the Quit menu item shows up in the menu that you click for the gEdit application (the menu to the right of the Activities menu when running gEdit in GNOME Shell) the crash does not occur at all no matter what is done or how many times the Activities menu is clicked or the mouse is cornered in the hot corner.

To recap, the moment the Panel displays the application menu in full before running the plugin, the crashing occurs again and again.  So long as the application menu does not display the full menu and only displays quit, no crashes occur at all.

So, there is something that GNOME Shell does not like about gEdit in the Panel while running gEdit as another user, but only if anything other than Quit alone is displayed in the application menu to the right of the Activities menu.

I'm looking into this further but it looks like a GNOME Shell/gEdit problem at the moment.  The same thing occurs even if logged on in the shell as root user without the use of beesu.  This does not occur at all in Cinnamon DE, even with hot corner usage, and a lot of Cinnamon DE still is dependent upon elements of GNOME Shell.
Comment 12 D. Charles Pyle 2013-09-02 20:37:04 EDT
In the meantime, try Alt+F2 and typing the following:

beesu gedit

followed by pressing Enter.  Does crashing of GNOME Shell still occur?
Comment 13 D. Charles Pyle 2013-09-03 00:49:49 EDT
OK, I now know what is doing this.  It is the same bug/issue that affected gEdit and GNOME Shell back in 2010!  It has come back to bite us it would appear.

Edit the /usr/lib64/gedit/plugins/beesu.py file using the nautilus scripts menu item.  You can do this doing the following:

1. Navigate to the file, right-click on it, and navigate the scripts menu to the beesu scripts menu item named "Edit with gEdit."

2. Locate the line that reads:

shell_args = ['beesu', '-l', '-c', '/usr/libexec/gedit-beesu-plugin','gedit-beesu-plugin','/usr/bin/gedit','gedit', lockfile, '\"%s\"' %filename]

3. Change the line to read exactly as follows (all on one line):

shell_args = ['beesu','-l','-c','unset','XDG_RUNTIME_DIR',';','/usr/libexec/gedit-beesu-plugin','gedit-beesu-plugin','/usr/bin/gedit','gedit',lockfile,'\"%s\"' %filename]

4. Save the file and reboot.

Since I made the modification I have not seen a crash when using either the hot corner or clicking on the Activities menu in GNOME Shell. The workaround also has persisted across multiple reboots--at least for me.

Let us know the results and whether there is improvement for you.  If it works for you and eliminates the crashing, I'll queue up the requisite patch files and supply them to the package maintainer ASAP.
Comment 14 David Batson 2013-09-03 01:58:44 EDT
Since my last comment I updated the *beesu* files as per comment #8 and edited beesu.py as per comment #13 .  Note that the path is different on my system.

/usr/lib64/gedit/plugins/beesu/beesu.py

Good job on solving the crashing/freezing issue with gedit-beesu-plugin!

Too bad that it doesn't work with just beesu.  It would be simpler to open terminal and use the following:

$ beesu gedit
or
$ beesu gedit myfile

and enter root's password when prompted, than to open gedit from terminal, open a file in gedit, click on "Open as root", go back to terminal and enter root's password, then go back to gedit.

If somehow gedit would prompt for root's password when choosing "Open as root" from gedit's menu, that would be a big improvement.
Comment 15 David Batson 2013-09-03 02:38:49 EDT
I have been remiss for not posting this earlier.  Apparently gedit is not the only gnome app with this problem.

http://forums.fedoraforum.org/showpost.php?p=1648576&postcount=3

I had found some other related links when searching for solutions, but I don't have them atm.
Comment 16 D. Charles Pyle 2013-09-03 03:22:04 EDT
Thanks.  I'm glad it worked for you.  Yes, the root cause is a very old and moldy bug involving gEdit and GNOME Shell, and it seems like it keeps coming back just when you think it is gone.

I agree that it would be nice to do it the easy way in a terminal with beesu, as you write, but the workaround will work for that, too.  Unfortunately, it is a little longer because of what has to be added to the command line to keep GNOME Shell happy.

Under the current circumstances, you would do that by running in terminal as follows:

beesu - unset XDG_RUNTIME_DIR ; gedit myfile

or

beesu -lc unset XDG_RUNTIME_DIR ; gedit myfile

Not as short and convenient as only two or three parameters but that is how it has to be until that bug involving gEdit actually gets taken seriously and is permanently squashed by GNOME developers.

As touching the differences in your path vs. what is in the file, I have the same path.  I just mistyped it.  Sorry about that.  Unfortunately, I cannot go back and edit that post here.  The correct location of the plugin is /usr/lib64/gedit/plugins/beesu/ for the beesu.py file.

As to what you are seeing in gEdit when run in terminal, it is supposed to ask for your root password without having to go back to the terminal to do that, even if gEdit is run from the terminal.  You should get prompted by the plugin for your root password as soon as you select "Open as 'root'."

That it is not behaving correctly for you is something to look into further.

Do you by chance have terminal set to take focus from other windows? Or, have you another setting enabled that might be sending the prompt behind another windows or not show up at all? I'm also wondering as to whether you might be missing a dependency.

Can you provide your system specs and also your configuration, including version of gnome-shell? Also, what is generated in the debug output in terminal? Can you paste that complete output into your reply?

I'll shortly attach a screenshot of what gEdit is supposed to look like when you are prompted for your root password.
Comment 17 D. Charles Pyle 2013-09-03 03:33:13 EDT
Created attachment 793046 [details]
Screenshot of gEdit beesu plugin prompt.

Attached to this post is what you should be seeing when you choose the Open as "root" menu item in gEdit using the gedit-beesu plugin.
Comment 18 D. Charles Pyle 2013-09-03 11:14:44 EDT
You might also run into the same problem with the beesu scripts named "Edit with gEdit."

In the meantime, open each of those scripts in both /usr/libexec/nautilus-beesu-manager/scripts/ and /usr/libexec/nemo-beesu-manager/scripts/ (if you have the nemo-beesu scripts package installed).

Locate the line(s) that read(s):

beesu - gedit "$quoted"

and modify to the following:

beesu - 'unset XDG_RUNTIME_DIR ; gedit' "$quoted"

Save the changes.  This will not require a reboot.  Doing this also will prevent the same crash using gEdit in those two scripts.

As soon as I get a little extra time I'll queue up patch files and submit them for consideration if the modifications continue to work.  In any case, they also are here for people to try if they are affected by this.
Comment 19 David Batson 2013-09-03 14:12:11 EDT
(In reply to D. Charles Pyle from comment #17)
> Created attachment 793046 [details]
> Screenshot of gEdit beesu plugin prompt.
> 
> Attached to this post is what you should be seeing when you choose the Open
> as "root" menu item in gEdit using the gedit-beesu plugin.

No, I do not get that dialog box.

Regarding my setup, I hope the following answers your questions...
I just installed Fedora 19 a few days ago. Installed from the 64-bit DVD using the standard Gnome DE. Fully updated atm. This is on a Lenovo X220 Intel Sandybridge laptop.

I installed dconf-editor trying to get the Preferences menu to show up in gedit, and to get the gedit-beesu-plugin running. I didn't know at the time that the preferences menu is only availble in gedit from the taskbar icon next to Activities. I also copied the beesu folder to /usr/share/gedit/plugins/ as I believe dconf-editor looks for gedit plugins there.

I haven't installed too many things yet. Installed VLC and associated dependencies, installed the Opera browser, and installed Adobe Reader. Installed gnome-tweak-tool yesterday for getting the maximize and minimize buttons on my windows. Installed acpid, acpitool, infinality fonts, rfkill, yumex, hdapsd, policycoreutils-devel (to get audit2allow - needed for my rfkill script to shut off my bluetooth radio), and not much else that I can think of.

I was trying to get gedit to run as root to create the bash script for shutting off my bluetooth radio with a hotkey combo (done btw). Haven't done much tweaking that I can think of.
Comment 20 D. Charles Pyle 2013-09-03 16:20:47 EDT
You might want to delete the beesu you copied over to /usr/share (or, if you moved it, put it back in /usr/lib64/gedit).  So far as I am aware (and the evidence of the filesystem supports that), gEdit looks in /usr/lib64/gedit.

I am thinking you are missing a dependency for some reason.  You should be seeing the dialog and not have to go to the terminal window to enter your root password.  Sometimes that can happen when a dependency is removed by accident when removing other software, or because you are forced to do so when updates come around and fail to update unless you do.

Sometimes permissions problems also can result in certain dialogs not showing up.  Sometimes it is the fault of your video configuration and/or missing driver elements.  Not all are installed by default.  Also check to make sure you have all necessary gtk2 and gtk3 packages installed, as well as libgcc and glibc, and libstdc++.

Since you have yumex installed, you can use that tool to determine if you have all the needed dependencies installed.

1. What you can do is to open yumex, and then type beesu in the search field.  Once that shows a result, you will see the result marked in green letters because it is installed (or whatever custom color you might have selected to change that).

2. Click the button that shows the dependencies for beesu.  It is on the right side and should be the fifth icon button down.

3. Expand each listing to see the libraries and other dependencies. Note the color of each under beesu. If any of them are not green, meaning installed, use yumex to install them.

4. Once all of them are green for beesu, reboot and try again to use the plugin. See whether or not you see the dialog.

If all are green in beesu, the next step is to look at gedit-beesu-plugin.  All but beesu in that listing should be green.  Ignore the fact that beesu will not be in that list as installed.  That plugin needs an update to recognize the newer beesu package installed even though it is.  (It should be getting one when patches are supplied).

After that and if it is not solved, we will need to take a look at the drivers for your video graphics card.  Make sure that the 32-bit drivers for your card also are installed. Many drivers require both 64-bit and 32-bit packages to function correctly, but only if your machine is a 64-bit installation (yours is, so you should do this if they are available).  My AMD video graphics card requires both 64-bit and 32-bit components for certain software to run correctly, if run at all.  For top performance I have to install all DRI components, too.  These may not apply to your situation, however.

One other thing to check is to make sure all necessary PolicyKit (polkit) files are installed. In future, if any are missing, you also won't see the dialog. This is because consolehelper (upon which beesu also depended) is deprecated and the functionality being replaced by policykit.  

You might be forced to install usermode as well (it will be installed if you followed the above), if that does not help.

And, if you are not already aware of it, someone else filed a bug relating to what you are seeing as to no dialog appearing.  You can visit that bug at the following URL:

https://bugzilla.redhat.com/show_bug.cgi?id=967159
Comment 21 D. Charles Pyle 2013-09-03 16:26:03 EDT
I forgot to add that exceptions to the above steps in Comment 20 are that you do not need pygtk2.i686 or python3.i686 for use with gedit-beesu-plugin if you have the x86_64 versions installed.  You likely won't be able to install them together anyway.
Comment 22 D. Charles Pyle 2013-09-03 18:25:56 EDT
One other thing.  I was reminded by Bastián Díaz that there is another dependency that beesu fails to list as necessary--but will--now that I have been reminded of which one might be missing in your configuration, as it often is not installed by default.

In addition to having usermode installed, you also need usermode-gtk installed. That one might be the only one you need to see the dialog, unless other dependencies are pulled in with it. If that one is not installed, please do install it.  Let us know if things start working as intended with the dialog from that point or not.

Again, thanks for reporting the problems you are experiencing with the plugin not working.  It helps improve the packages for everybody else.
Comment 23 David Batson 2013-09-03 20:16:16 EDT
I would have never seen that button in yumex normally.  It is hidden behind the Apply button.  Only the barest edge shows out from under it.

gedit-beesu-plugin says that I need a different version of beesu.
beesu 2.7-9.fc19 x86_64

I have beesu 2.7-11 x86_64 installed.

Nevermind, I just installed usermode-gtk as you suggested and now I see the previously missing password dialog box.

Looks like a winner!  Thanks!
Comment 24 Fedora Update System 2013-09-24 18:49:34 EDT
beesu-2.7-11.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 25 Christian von Behren 2014-06-13 18:41:17 EDT
Well, I guess it was about time that gedit-plugin-beesu is hit again...

Using Gedit 3.12.2 (from f20 Copr repo) I got:

sys:1: Warning: invalid cast from 'GeditPreferencesDialog' to 'GeditWindow'
Traceback (most recent call last):
  File "/usr/lib64/gedit/plugins/beesu/beesu.py", line 53, in do_activate
    self._insert_menu()
  File "/usr/lib64/gedit/plugins/beesu/beesu.py", line 66, in _insert_menu
    manager = self.window.get_ui_manager()
AttributeError: 'Window' object has no attribute 'get_ui_manager'
Traceback (most recent call last):
  File "/usr/lib64/gedit/plugins/beesu/beesu.py", line 56, in do_deactivate
    self._remove_menu()
  File "/usr/lib64/gedit/plugins/beesu/beesu.py", line 59, in _remove_menu
    manager = self.window.get_ui_manager()
AttributeError: 'Window' object has no attribute 'get_ui_manager'

I am aware that 3.12.2 is lets say a problem about to come in the near future and currently no default...
still, there should be something to do about.

Since gedit has been redesigned a lot menus and dependancies have changed:
http://www.linuxfromscratch.org/blfs/view/cvs/gnome/gedit.html 

I was able to activate the plugin in preferences->plugins but I can't find an option to actually reload a file as root.

I tried version 2.7-20.fc21 (beesu and gedit-plugin) from rawhide but the problem perists!
Comment 26 D. Charles Pyle 2014-06-13 18:52:15 EDT
Several people are aware of this problem.  I've been working on this off and on and still have not come up with a working solution.  Tom Callaway tried as well and was unable to get it to work with Gedit as it now is redesigned.

I should have some time in a few weeks to work on it again but it may require a complete rewrite of the plugin from scratch if a workaround cannot be found in the interim.  But, thanks for reporting it.
Comment 27 D. Charles Pyle 2014-06-28 00:44:37 EDT
For a workaround, you either can do Alt + F2, and run beesu - 'unset XDG_RUNTIME_DIR ; gedit', followed by using that to open the file you want to edit.

You also can grab pluma off of Koji, as well as the beesu plugin for pluma, if you don't want to go the scripts route.

If you are using Rawhide, splitting off packages and renaming them for rawhide caused the plume-beesu-plugin to break and ask for dependencies to be installed even though they already are installed. To work around that problem until it is fixed, find the following line in /usr/libexec/caja-beesu-manager/scripts/Edit with Pluma:

beesu_requires "mate-text-editor" "mate-text-editor"

Replace that with the following:

#beesu_requires "mate-text-editor" "mate-text-editor"
if [ ! -x /usr/bin/pluma ]; then
    beesu_requires "mate-text-editor" "pluma (or, depending on available package for your Fedora version, beesu - yum install mate-text-editor)"
fi

Note You need to log in before you can comment on or make changes to this bug.