Bug 967172 - SELinux is preventing /usr/bin/clamscan from 'getattr' accesses on the file /var/log/audit/audit.log.1.
SELinux is preventing /usr/bin/clamscan from 'getattr' accesses on the file /...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:3316fcf9ee0750ef9841e7a7690...
:
: 967173 967174 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-25 03:07 EDT by Grosswiler Roger
Modified: 2013-05-29 23:34 EDT (History)
3 users (show)

See Also:
Fixed In Version: selinux-policy-3.12.1-47.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-29 23:34:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Grosswiler Roger 2013-05-25 03:07:19 EDT
Description of problem:
SELinux is preventing /usr/bin/clamscan from 'getattr' accesses on the file /var/log/audit/audit.log.1.

*****  Plugin catchall (100. confidence) suggests  ***************************

If sie denken, dass es clamscan standardmässig erlaubt sein sollte, getattr Zugriff auf audit.log.1 file zu erhalten.
Then sie sollten dies als Fehler melden.
Um diesen Zugriff zu erlauben, können Sie ein lokales Richtlinien-Modul erstellen.
Do
zugriff jetzt erlauben, indem Sie die nachfolgenden Befehle ausführen:
# grep clamscan /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:antivirus_t:s0-s0:c0.c1023
Target Context                system_u:object_r:auditd_log_t:s0
Target Objects                /var/log/audit/audit.log.1 [ file ]
Source                        clamscan
Source Path                   /usr/bin/clamscan
Port                          <Unbekannt>
Host                          (removed)
Source RPM Packages           clamav-0.97.8-1.fc19.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.12.1-44.fc19.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 3.9.3-301.fc19.x86_64 #1 SMP Mon
                              May 20 12:50:56 UTC 2013 x86_64 x86_64
Alert Count                   9
First Seen                    2013-05-13 06:45:56 CEST
Last Seen                     2013-05-25 06:53:59 CEST
Local ID                      7bcca938-1d1e-4227-ae46-e4816d302e11

Raw Audit Messages
type=AVC msg=audit(1369457639.418:24525): avc:  denied  { getattr } for  pid=23901 comm="clamscan" path="/var/log/audit/audit.log.1" dev="dm-1" ino=393430 scontext=system_u:system_r:antivirus_t:s0-s0:c0.c1023 tcontext=system_u:object_r:auditd_log_t:s0 tclass=file


type=SYSCALL msg=audit(1369457639.418:24525): arch=x86_64 syscall=lstat success=no exit=EACCES a0=8f5a90 a1=7fff1f06cf70 a2=7fff1f06cf70 a3=b items=0 ppid=23899 pid=23901 auid=0 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 ses=13 tty=(none) comm=clamscan exe=/usr/bin/clamscan subj=system_u:system_r:antivirus_t:s0-s0:c0.c1023 key=(null)

Hash: clamscan,antivirus_t,auditd_log_t,file,getattr

Additional info:
reporter:       libreport-2.1.4
hashmarkername: setroubleshoot
kernel:         3.9.3-301.fc19.x86_64
type:           libreport
Comment 1 Miroslav Grepl 2013-05-27 06:59:54 EDT
*** Bug 967173 has been marked as a duplicate of this bug. ***
Comment 2 Miroslav Grepl 2013-05-27 06:59:59 EDT
*** Bug 967174 has been marked as a duplicate of this bug. ***
Comment 3 Miroslav Grepl 2013-05-27 07:06:30 EDT
Fixed.

commit 5785096f1f4d5c708eaa1ec0cd5404d4205a2613
Author: Miroslav Grepl <mgrepl@redhat.com>
Date:   Mon May 27 13:06:13 2013 +0200

    Update antivirus_can_scan_system boolean
Comment 4 Fedora Update System 2013-05-29 10:20:16 EDT
selinux-policy-3.12.1-47.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/selinux-policy-3.12.1-47.fc19
Comment 5 Fedora Update System 2013-05-29 13:47:14 EDT
Package selinux-policy-3.12.1-47.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing selinux-policy-3.12.1-47.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-9565/selinux-policy-3.12.1-47.fc19
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2013-05-29 23:34:14 EDT
selinux-policy-3.12.1-47.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.