Bug 967174 - SELinux is preventing /usr/bin/clamscan from 'getattr' accesses on the file /etc/audit/rules.d/audit.rules.
SELinux is preventing /usr/bin/clamscan from 'getattr' accesses on the file /...
Status: CLOSED DUPLICATE of bug 967172
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:b883c4732d39922c28955103356...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-25 03:08 EDT by Grosswiler Roger
Modified: 2013-05-27 06:59 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-27 06:59:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Grosswiler Roger 2013-05-25 03:08:45 EDT
Description of problem:
SELinux is preventing /usr/bin/clamscan from 'getattr' accesses on the file /etc/audit/rules.d/audit.rules.

*****  Plugin catchall (100. confidence) suggests  ***************************

If sie denken, dass es clamscan standardmässig erlaubt sein sollte, getattr Zugriff auf audit.rules file zu erhalten.
Then sie sollten dies als Fehler melden.
Um diesen Zugriff zu erlauben, können Sie ein lokales Richtlinien-Modul erstellen.
Do
zugriff jetzt erlauben, indem Sie die nachfolgenden Befehle ausführen:
# grep clamscan /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:antivirus_t:s0-s0:c0.c1023
Target Context                system_u:object_r:auditd_etc_t:s0
Target Objects                /etc/audit/rules.d/audit.rules [ file ]
Source                        clamscan
Source Path                   /usr/bin/clamscan
Port                          <Unbekannt>
Host                          (removed)
Source RPM Packages           clamav-0.97.8-1.fc19.x86_64
Target RPM Packages           audit-2.3-2.fc19.x86_64
Policy RPM                    selinux-policy-3.12.1-44.fc19.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 3.9.3-301.fc19.x86_64 #1 SMP Mon
                              May 20 12:50:56 UTC 2013 x86_64 x86_64
Alert Count                   26
First Seen                    2013-05-13 06:45:34 CEST
Last Seen                     2013-05-25 06:53:13 CEST
Local ID                      61cc0969-2f56-4907-8fbb-06cdfdb536dd

Raw Audit Messages
type=AVC msg=audit(1369457593.976:24139): avc:  denied  { getattr } for  pid=23901 comm="clamscan" path="/etc/audit/rules.d/audit.rules" dev="dm-1" ino=2753783 scontext=system_u:system_r:antivirus_t:s0-s0:c0.c1023 tcontext=system_u:object_r:auditd_etc_t:s0 tclass=file


type=SYSCALL msg=audit(1369457593.976:24139): arch=x86_64 syscall=lstat success=no exit=EACCES a0=8d7420 a1=7fff1f06cf70 a2=7fff1f06cf70 a3=b items=0 ppid=23899 pid=23901 auid=0 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 ses=13 tty=(none) comm=clamscan exe=/usr/bin/clamscan subj=system_u:system_r:antivirus_t:s0-s0:c0.c1023 key=(null)

Hash: clamscan,antivirus_t,auditd_etc_t,file,getattr

Additional info:
reporter:       libreport-2.1.4
hashmarkername: setroubleshoot
kernel:         3.9.3-301.fc19.x86_64
type:           libreport
Comment 1 Miroslav Grepl 2013-05-27 06:59:59 EDT

*** This bug has been marked as a duplicate of bug 967172 ***

Note You need to log in before you can comment on or make changes to this bug.