Bug 967251 - sagemath: Hardcoded Requires: firefox
sagemath: Hardcoded Requires: firefox
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: sagemath (Show other bugs)
18
All Linux
unspecified Severity low
: ---
: ---
Assigned To: Paulo Andrade
Fedora Extras Quality Assurance
:
: 971430 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-25 22:03 EDT by Kevin Kofler
Modified: 2013-09-26 20:41 EDT (History)
2 users (show)

See Also:
Fixed In Version: sagemath-5.9-9.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-18 22:43:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kevin Kofler 2013-05-25 22:03:58 EDT
Description of problem:
sagemath explicitly requires firefox. Why is that necessary? The web-based notebook should work with any browser, and what if I don't want to use the web-based interface at all (but either Cantor or the sage command line directly)?

Version-Release number of selected component (if applicable):
sagemath-5.9-5.fc18 and older
Comment 1 Paulo Andrade 2013-05-27 08:49:33 EDT
I did not test recently with web browsers other than firefox
and konqueror, but it does not work correctly with knoqueror,
mostly several javascript warnings all over the place.
You can test other browsers by just commenting to use default
or change default in /usr/bin/sage:

export SAGE_BROWSER=firefox

I will try to work on getting it to work correctly with
other browsers, if hard to debug issues arise, usually it
is java plugin related. At first I preferred to make it
have as few issues as possible, so that if an user installs
sagemath, by typing "notebook()" in the command line,
everything should work, instead of needing the user to
debug why things do not work "out of the box".
Comment 2 Rex Dieter 2013-09-10 07:25:24 EDT
*** Bug 971430 has been marked as a duplicate of this bug. ***
Comment 3 Rex Dieter 2013-09-10 07:41:55 EDT
IMO, leave it to the user to set a sane browser, if they choose badly, it's on them.

The easiest fix here would be to just do
export SAGE_BROWSER=xdg-open

(and and a dependency on xdg-utils, if you don't already have one)
Comment 4 Paulo Andrade 2013-09-10 11:23:27 EDT
  I know it used to work with firefox and chromium-browser.
Other browers (opera I never saw working with icedtea-web,
but it was long ago I last tested), and with konqueror it
keeps pop'ing up some warnig messages from jsMath.
  I left it in the /usr/bin/sage script so that it is easy
to spot, and this way I would trade receiving a few bug
reports of hardcoded firefox usage vs a lot of bug reports
about not working properly on other browsers.
Comment 5 Kevin Kofler 2013-09-13 18:38:23 EDT
But the thing is, Firefox is a ridiculous dependency if I want to use SAGE inside Cantor or on the command line. SAGE is more than just the web app.
Comment 6 Paulo Andrade 2013-09-14 12:46:55 EDT
Curiously, only yesterday I tested again sage with
cantor and noticed the problem. I think it is a good
enough reason to tell people to set SAGE_BROWSER
if it does not work good enough with konqueror
(did not last time I tested).
Comment 7 Kevin Kofler 2013-09-14 13:29:33 EDT
Well, of course, if you run notebook() in Cantor, it will behave no differently than if you do it in a SAGE running in a terminal. But that's not really how Cantor is intended to be used. :-) (Cantor has its own notebooks, it's not supposed to be a frontend to fire up the web notebook.)
Comment 8 Fedora Update System 2013-09-14 21:14:52 EDT
sagemath-5.10-4.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/sagemath-5.10-4.fc20
Comment 9 Fedora Update System 2013-09-14 21:15:47 EDT
sagemath-5.9-8.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/sagemath-5.9-8.fc19
Comment 10 Fedora Update System 2013-09-14 21:16:50 EDT
sagemath-5.9-8.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/sagemath-5.9-8.fc18
Comment 11 Fedora Update System 2013-09-15 13:36:20 EDT
Package sagemath-5.10-4.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing sagemath-5.10-4.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-16782/sagemath-5.10-4.fc20
then log in and leave karma (feedback).
Comment 12 Fedora Update System 2013-09-17 13:56:09 EDT
sagemath-5.9-9.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/sagemath-5.9-9.fc18
Comment 13 Fedora Update System 2013-09-17 13:57:38 EDT
sagemath-5.9-9.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/sagemath-5.9-9.fc19
Comment 14 Fedora Update System 2013-09-18 22:43:00 EDT
sagemath-5.10-4.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 15 Fedora Update System 2013-09-26 20:39:12 EDT
sagemath-5.9-9.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 16 Fedora Update System 2013-09-26 20:41:41 EDT
sagemath-5.9-9.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.