Bug 967291 - packstack doesn't open port 9696 on quantum server host
packstack doesn't open port 9696 on quantum server host
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-packstack (Show other bugs)
3.0
Unspecified Unspecified
high Severity high
: snapshot2
: 3.0
Assigned To: Martin Magr
Ofer Blaut
:
: 928424 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-26 07:41 EDT by Ofer Blaut
Modified: 2016-04-26 13:14 EDT (History)
8 users (show)

See Also:
Fixed In Version: openstack-packstack-2013.1.1-0.8.dev601
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-11 14:51:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 30627 None None None Never

  None (edit)
Description Ofer Blaut 2013-05-26 07:41:56 EDT
Description of problem:

packstack must configure iptables to accept port 9696 ( listen port of quantum server )

Currently it doesn't.


-A INPUT -p tcp -m multiport --dports 9696 -m comment --comment "001 quantum incoming" -j ACCEPT 



[root@puma04 ~]# rpm -qa | grep packstack
openstack-packstack-2013.1.1-0.7.dev580.el6ost.noarch
packstack-modules-puppet-2013.1.1-0.7.dev580.el6ost.noarch


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.install quantum on clean host
2. check iptables to see port 9696 is accepted 
3.

Actual results:


Expected results:


Additional info:
Comment 2 Terry Wilson 2013-05-28 20:28:49 EDT
*** Bug 928424 has been marked as a duplicate of this bug. ***
Comment 5 Ofer Blaut 2013-06-06 16:10:51 EDT
Tested

[root@puma04 ~]# iptables -L | grep 9696
ACCEPT     tcp  --  anywhere             anywhere            multiport dports 9696 /* 001 quantum incoming */ 
[root@puma04 ~]# rpm -qa | grep packstack
openstack-packstack-2013.1.1-0.10.dev605.el6ost.noarch
Comment 6 errata-xmlrpc 2013-06-11 14:51:47 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0938.html

Note You need to log in before you can comment on or make changes to this bug.