Bug 967310 - [RFE] add packstack support for installation & config of ceilometer
[RFE] add packstack support for installation & config of ceilometer
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-packstack (Show other bugs)
3.0
Unspecified Unspecified
high Severity medium
: Upstream M3
: 4.0
Assigned To: Martin Magr
Nir Magnezi
: FutureFeature
Depends On: 994571 1015878
Blocks: RHOS40RFE
  Show dependency treegraph
 
Reported: 2013-05-26 08:58 EDT by Attila Fazekas
Modified: 2016-04-26 23:49 EDT (History)
9 users (show)

See Also:
Fixed In Version: openstack-packstack-2013.2.1-0.6.dev749.el6ost
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-19 19:03:22 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
nmagnezi: needinfo-


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 41245 None None None Never

  None (edit)
Description Attila Fazekas 2013-05-26 08:58:18 EDT
packstack does not able install and configure ceilometer

openstack-packstack-2013.1.1-0.7.dev580.el6ost.noarch
Comment 2 Eoghan Glynn 2013-06-05 06:40:14 EDT
There is a puppet module for ceilometer upstream in stackforge:

  https://github.com/stackforge/puppet-ceilometer

which could potentially provide a good starting point for packstack ceilometer support.

This puppet-ceilometer module was contributed by eNovance, who have apparently tested it extensively and proved it in the field with their customers.

However, their usage has been Ubuntu-centric, so we would need to contribute some changes upstream in order for this to be usable with packstack on Fedora/RHEL.

In particular, it supports only rabbitmq as the AMQP provider currently:

  https://github.com/stackforge/puppet-ceilometer/blob/master/manifests/init.pp#L33-L38

so this would need to optionally accept the qpid configuration parameters also, as do puppet modules for the other openstack projects:

  https://github.com/stackforge/puppet-nova/blob/master/manifests/init.pp#L191-L207

Also, one other departure from the usual pattern of the puppet modules used by packstack (IIUC), is that the ceilometer compute agent has a direct cross-project dependency on the nova compute agent catalog entry:

  https://github.com/stackforge/puppet-ceilometer/blob/master/manifests/agent/compute.pp#L107-L110

(this change to the nova-compute's nova.config is required so that a special ceilometer notification driver is installed, in order to catch the dieing breath of a deleted instance)

Finally, eNovance targetted this work at Folsom initially, and there appear to be some throwbacks to Folsom-ness in the code, e.g. this setting of notification_driver=nova.openstack.common.notifier.rabbit_notifier as opposed to notification_driver=nova.openstack.common.notifier.rpc_notifier & rpc_backend=nova.openstack.common.rpc.impl_kombu:

  https://github.com/stackforge/puppet-ceilometer/blob/master/manifests/agent/compute.pp#L102-L105

However, overall, it looks like a decent enough starting point for packstack ceilometer support.
Comment 3 Ami Jeain 2013-07-31 05:36:46 EDT
will this be part og RHOS 4.0?
It is currently not blocking the Havana tracker bug
Comment 5 Martin Magr 2013-09-03 05:45:54 EDT
Taking over Ceilometer support.
Comment 8 Nir Magnezi 2013-10-15 05:27:39 EDT
Due to Bug #1015878, Ceilometer cannot tested for basic sanity.
Setting Bug #1015878 as a blocker for this bug.
Comment 10 Martin Magr 2013-10-22 04:15:09 EDT
Bug #1015878 is in MODIFIED state, please check installation with the appropriate version of openstack-ceilometer.
Comment 11 Nir Magnezi 2013-11-11 08:32:30 EST
Verified NVR: openstack-packstack-2013.2.1-0.9.dev840.el6ost.noarch
Puddle 2013-11-08.1

Verification Steps:
1. Install OpenStack
2. Verify that 'ceilomter meter-list' works (for sanity)
3. Verified that there are no errors in Celimeter logs
4. Verified that all Ceilomter services are up
# for svc in api central collector compute ; do service openstack-ceilometer-$svc status ; done
openstack-ceilometer-api (pid  22755) is running...
openstack-ceilometer-central (pid  22725) is running...
openstack-ceilometer-collector (pid  22696) is running...
openstack-ceilometer-compute (pid  6091) is running...
Comment 15 errata-xmlrpc 2013-12-19 19:03:22 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1859.html

Note You need to log in before you can comment on or make changes to this bug.