Bug 967649 - Filter dd-written USB media from potential target disk set
Filter dd-written USB media from potential target disk set
Status: CLOSED DUPLICATE of bug 874381
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Brian Lane
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-27 15:34 EDT by Adam Williamson
Modified: 2013-06-21 19:24 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-21 19:24:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam Williamson 2013-05-27 15:34:57 EDT
If you are installing from a USB stick, it should be filtered from consideration as an installation target in all ways. This seems to be working at present for livecd-iso-to-disk written media, but not dd-written media. These appear on the Installation Destination screen as an available target device, which should not happen.

Here is blkid output from the F19 Beta netinst image dd'ed to a USB stick:

[root@adam Beta-RC4]# blkid /dev/sdd
/dev/sdd: UUID="2013-05-23-00-43-30-00" LABEL="Fedora 19-Beta x86_64" TYPE="iso9660" PTTYPE="dos" 
[root@adam Beta-RC4]# blkid /dev/sdd1
/dev/sdd1: UUID="2013-05-23-00-43-30-00" LABEL="Fedora 19-Beta x86_64" TYPE="iso9660" PTTYPE="dos" 
[root@adam Beta-RC4]# blkid /dev/sdd2
/dev/sdd2: SEC_TYPE="msdos" LABEL="ANACONDA" UUID="E70E-7C39" TYPE="vfat" 
[root@adam Beta-RC4]# blkid /dev/sdd3
/dev/sdd3: UUID="26a0e7d8-f305-3d87-8e53-2317fd190b7e" LABEL="ANACONDA" TYPE="hfsplus" 

and from an F19 Beta desktop live image dd'ed:

[root@adam Beta-RC4]# blkid /dev/sdd
/dev/sdd: UUID="2013-05-23-03-45-50-00" LABEL="Fedora-Live-Desktop-x86_64-19-Be" TYPE="iso9660" PTTYPE="dos" 
[root@adam Beta-RC4]# blkid /dev/sdd1
/dev/sdd1: UUID="2013-05-23-03-45-50-00" LABEL="Fedora-Live-Desktop-x86_64-19-Be" TYPE="iso9660" PTTYPE="dos" 
[root@adam Beta-RC4]# blkid /dev/sdd2
/dev/sdd2: SEC_TYPE="msdos" LABEL="EFI" UUID="BE8A-3C58" TYPE="vfat" 
[root@adam Beta-RC4]# blkid /dev/sdd3
/dev/sdd3: UUID="9174fb32-f7b1-31fa-8b5e-51c153e98f55" LABEL="Fedora Live" TYPE="hfsplus"
Comment 1 Brian Lane 2013-06-21 19:24:43 EDT

*** This bug has been marked as a duplicate of bug 874381 ***

Note You need to log in before you can comment on or make changes to this bug.