Bug 874381 - USB stick install is running from doesn't get filtered out as an install target
Summary: USB stick install is running from doesn't get filtered out as an install target
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: rawhide
Hardware: All
OS: All
unspecified
medium
Target Milestone: ---
Assignee: Brian Lane
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedFreezeException https://fedor...
: 882516 967649 (view as bug list)
Depends On:
Blocks: F19-accepted, F19FinalFreezeException
TreeView+ depends on / blocked
 
Reported: 2012-11-08 03:35 UTC by Adam Williamson
Modified: 2014-10-07 17:11 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-07 17:11:05 UTC


Attachments (Terms of Use)

Description Adam Williamson 2012-11-08 03:35:22 UTC
It seems like the code that's supposed to filter out the USB stick you're installing from as a possible install target isn't working. I've checked that at least with smoke15 netinst .iso, written to USB with dd or litd, the USB stick appears at the disk picker screen. blkid output for dd:

/run/install/repo//LiveOS/squashfs.img: TYPE="squashfs" 
/dev/loop0: TYPE="squashfs" 
/dev/loop1: LABEL="Anaconda" UUID="c861edc6-6007-41cf-a957-bf6f5edd396d" TYPE="ext4" 
/dev/sdb1: UUID="2012-11-07-03-48-50-00" LABEL="Fedora 18 x86_64" TYPE="iso9660" PTTYPE="dos" 
/dev/sdb2: SEC_TYPE="msdos" LABEL="ANACONDA" UUID="0719-BC31" TYPE="vfat" 
/dev/sdb3: UUID="071d85fc-f5ea-3ad3-843e-0942e4f7d684" LABEL="ANACONDA" TYPE="hfsplus" 
/dev/mapper/live-rw: LABEL="Anaconda" UUID="c861edc6-6007-41cf-a957-bf6f5edd396d" TYPE="ext4" 

for livecd-iso-to-disk:

/run/install/repo//LiveOS/squashfs.img: TYPE="squashfs" 
/dev/loop0: TYPE="squashfs" 
/dev/loop1: LABEL="Anaconda" UUID="c861edc6-6007-41cf-a957-bf6f5edd396d" TYPE="ext4" 
/dev/sda1: UUID="5c095d38-7598-4dd4-9d18-d58804acc1d9" TYPE="ext4" 
/dev/sda2: UUID="ggB29a-vHN0-NC2y-mrm2-WlbS-b81a-2pUX4n" TYPE="LVM2_member" 
/dev/sdb1: LABEL="LIVE" UUID="52bfb5fe-bee6-4ee3-bfcb-e2ab0cc23557" TYPE="ext4" 
/dev/mapper/live-rw: LABEL="Anaconda" UUID="c861edc6-6007-41cf-a957-bf6f5edd396d" TYPE="ext4" 

I'll attach storage.log if needed, but it should be pretty easy to reproduce for diagnosis.

Comment 1 Chris Lumens 2012-11-12 14:25:29 UTC
Looks like we're excluding those devices in the UI (or at least are trying to), so I would first investigate whether the USB device is even being marked as protected to begin with.

Comment 2 Chris Lumens 2012-12-01 20:35:09 UTC
*** Bug 882516 has been marked as a duplicate of this bug. ***

Comment 3 Fedora Blocker Bugs Application 2013-06-18 23:48:03 UTC
Proposed as a Freeze Exception for 19-alpha by Fedora user bcl using the blocker tracking app because:

 Install media should not show up in the list of drives to install to.

Comment 4 Brian Lane 2013-06-20 16:11:20 UTC
Fixed in commit 21841786 on master branch only.

Comment 5 Adam Williamson 2013-06-20 23:58:13 UTC
I'd like to see this fixed in f19 final if the change isn't too big. Any other likely consequences here? i'm trying to think of other cases with a \\ in the cmdline and how it might affect those...

Comment 6 Adam Williamson 2013-06-20 23:58:40 UTC
we don't support windows-style syntax for cifs shares do we? that uses \\machine\share iirc.

Comment 7 Brian Lane 2013-06-21 13:19:00 UTC
It wouldn't matter anyway since the actual problem is that shlex removes \\ from the input. All the patch can do is make it better.

Comment 8 Adam Williamson 2013-06-21 16:53:36 UTC
okay, sign me up for Team What Could Possibly Go Wrong...

Comment 9 Brian Lane 2013-06-21 23:24:43 UTC
*** Bug 967649 has been marked as a duplicate of this bug. ***

Comment 10 Adam Williamson 2013-06-21 23:25:47 UTC
AdamW Enterprises: Filing Two Bugs For The Price Of One Since 2009

Comment 11 Cybertimber2011 2013-06-24 13:39:44 UTC
Possibly related/I thought it was fixed in https://bugzilla.redhat.com/show_bug.cgi?id=959677

Comment 12 Adam Williamson 2013-06-24 17:35:12 UTC
Discussed at 2013-06-24 freeze exception review meeting: http://meetbot.fedoraproject.org/fedora-blocker-review/2013-06-24/f19final-blocker-review-8.2013-06-24-16.00.log.txt . Accepted as a freeze exception issue: showing the stick being installed from is confusing and can cause people to do silly things, and we really can't see that the fix will break anything. (kparal notes we should check it doesn't filter out too much and impede QA:Testcase_install_repository_Hard_drive_variation , but we don't think it should).

Comment 13 Fedora Update System 2013-06-24 23:30:32 UTC
python-blivet-0.17-1.fc19, anaconda-19.30.11-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/python-blivet-0.17-1.fc19,anaconda-19.30.11-1.fc19

Comment 14 Fedora Update System 2013-06-25 21:18:08 UTC
Package python-blivet-0.17-1.fc19, anaconda-19.30.11-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing python-blivet-0.17-1.fc19 anaconda-19.30.11-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-11679/python-blivet-0.17-1.fc19,anaconda-19.30.11-1.fc19
then log in and leave karma (feedback).

Comment 15 Fedora Update System 2013-06-26 17:11:05 UTC
Package python-blivet-0.17-1.fc19, anaconda-19.30.12-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing python-blivet-0.17-1.fc19 anaconda-19.30.12-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-11679/python-blivet-0.17-1.fc19,anaconda-19.30.12-1.fc19
then log in and leave karma (feedback).

Comment 16 Adam Williamson 2013-06-27 05:20:16 UTC
Somehow still not fixed in Final RC2 - dd'ed USB sticks still show up on the select screen. Oh, well.

Comment 17 Fedora Update System 2013-06-28 07:18:22 UTC
python-blivet-0.17-1.fc19, anaconda-19.30.13-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 18 Adam Williamson 2013-07-01 06:01:38 UTC
Re-opening as I was definitely seeing this in RC3 testing.

Comment 19 Brian Lane 2013-12-19 21:03:22 UTC
This bug remains elusive. With F20 litd written USB's are filtered. But dd'd sticks are not. Maybe we'll get all the variations nailed down for F21.

Comment 20 Adam Williamson 2013-12-19 23:29:41 UTC
Yeah :( Sorry I didn't have time to pin it down more precisely for F20.

Comment 21 Brian Lane 2014-10-07 17:11:05 UTC
The problem here is that the dd written usb has BOTH a iso9660 fs and a disklabel with partitions, making it harder than it should be to tell whether the USB device is the one we booted from.

FYI writing them with liveusb-creator or livecd-iso-to-disk will result in the usb device being filtered out.

So, just don't try to install to the dd written usb stick you just booted from and you'll be fine.


Note You need to log in before you can comment on or make changes to this bug.