Bug 967679 - QXL driver crashes RHEL6.4 host VM.
QXL driver crashes RHEL6.4 host VM.
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-qxl (Show other bugs)
19
i386 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Alon Levy
Fedora Extras Quality Assurance
https://fedoraproject.org/wiki/Common...
: CommonBugs
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-27 21:21 EDT by Dave Airlie
Modified: 2014-08-04 18:10 EDT (History)
16 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 965101
Environment:
Last Closed: 2013-12-17 14:19:46 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Airlie 2013-05-27 21:21:25 EDT
Originally reported wrongly, I've reproduced this problem.

No idea how to fix it.

We hit the assert in spice-server that was removed.

((null):3743): SpiceWorker-CRITICAL **: red_worker.c:9306:red_create_surface: Untested path stride >= 0

Alon any idea how we can avoid that?
Comment 1 Dave Airlie 2013-05-27 21:22:40 EDT
to reproduce install F19 in a RHEL6.4 VM under not spice, then switch to spice.

The problem is I don't know of anything we can trigger to avoid using stride >= 0 cases
Comment 2 Hans de Goede 2013-05-28 02:02:01 EDT
(In reply to Dave Airlie from comment #1)
> to reproduce install F19 in a RHEL6.4 VM under not spice, then switch to
> spice.
> 
> The problem is I don't know of anything we can trigger to avoid using stride
> >= 0 cases

AFAIK there is no way to find out if the assert is there or not, so indeed there is nothing the guest can do to avoid it.

I believe this is best fixed on the RHEL side as the assert actually is a spice-server bug there. The RHEL side of this is being tracked in bug 952666
Comment 3 Neil 2013-07-31 21:17:06 EDT
seeing this on x86_64 arch also.
Comment 4 Cole Robinson 2013-12-17 14:19:46 EST
RHEL6.5 has the fix, and sounds like the opinion is this can't be avoided guest side, so just closing as CANTFIX

Note You need to log in before you can comment on or make changes to this bug.