Bug 967805 - Anaconda does not accept proxy settings for network installation
Anaconda does not accept proxy settings for network installation
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
20
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Brian Lane
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks: 1029245
  Show dependency treegraph
 
Reported: 2013-05-28 07:15 EDT by A.J. Werkman
Modified: 2014-10-07 19:31 EDT (History)
8 users (show)

See Also:
Fixed In Version: anaconda-20.25.6-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1029245 (view as bug list)
Environment:
Last Closed: 2014-10-07 19:31:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Packaging.log (30.17 KB, text/plain)
2013-11-05 16:44 EST, A.J. Werkman
no flags Details
Anaconda.log (7.51 KB, text/plain)
2013-11-05 16:45 EST, A.J. Werkman
no flags Details
Program.log (34.57 KB, text/plain)
2013-11-05 16:46 EST, A.J. Werkman
no flags Details

  None (edit)
Description A.J. Werkman 2013-05-28 07:15:42 EDT
Description of problem:
When installing fedora behind a firewall, the proxy settings given in the 'installation source' spoke are not used.

Version-Release number of selected component (if applicable):
Anaconda 19.30-1

How reproducible:
Everytime

Steps to Reproduce:
1. Start the Fedora installation
2. Accept your faith and go to the 'installation source' spoke
3. Check 'on the network', select 'Closest mirror' and select 'Proxy setup...'.
4. Check 'Enable HTTP Proxy' and supply the proxy URL and click 'Add'
5. Click 'Done' in the 'installation source' spoke
6. See 'Error setting up software source' appear.

Actual results:
Anaconda reports a failure to find the software source

Expected results:
Anaconda should fetch the installation packages information using the proxy settings and make 'Software selection' possible.

Additional info:
Workaround is to supply the proxy settings on the commandline.
Comment 1 Brian Lane 2013-06-07 20:59:45 EDT
Fairly sure I fixed this, but now I'm hitting bug 971109
Comment 2 Fedora Update System 2013-06-11 12:32:15 EDT
anaconda-19.30.4-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/anaconda-19.30.4-1.fc19
Comment 3 Fedora Update System 2013-06-12 15:08:16 EDT
Package anaconda-19.30.5-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-19.30.5-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-10652/anaconda-19.30.5-1.fc19
then log in and leave karma (feedback).
Comment 4 A.J. Werkman 2013-11-05 15:35:04 EST
I see this bug again in F20.
Comment 5 Brian Lane 2013-11-05 16:05:14 EST
Please attach the logs from /tmp/*log as individual text/plain files.

packaging.log should log whether it is using the proxy when it sets up the repo.
Comment 6 A.J. Werkman 2013-11-05 16:44:52 EST
Created attachment 820020 [details]
Packaging.log

I selected 'Closest mirror' and gave proxy host thlin.digifarma.nl.
Can't find any reference in the logs to this hostname.
Comment 7 A.J. Werkman 2013-11-05 16:45:24 EST
Created attachment 820021 [details]
Anaconda.log
Comment 8 A.J. Werkman 2013-11-05 16:46:00 EST
Created attachment 820022 [details]
Program.log
Comment 9 Brian Lane 2013-11-05 18:08:02 EST
During the install does /tmp/anaconda-yum.conf have a proxy= line in it?
Comment 10 Brian Lane 2013-11-05 20:12:58 EST
I cannot reproduce this.

I setup a kvm with a network that can only connect to my proxy (running on the same host). I used RC2 netinst to boot with. I confirmed that it failed to setup the mirror. I add the proxy url (and port) and it correctly uses the proxy to download metadata, and the install works fine.

I think you may have something else wrong with your setup or proxy.
Comment 11 A.J. Werkman 2013-11-06 02:15:56 EST
/tmp/anaconda-yum.conf does not have a proxy= line when bug appears.

I work on bare metal. Proxy is proven all right.

My strategy is somewhat different.
I boot from USB. This USB is recognised as installation media (There is a repodata subdir).
I click 'Localmedia' and press the 'Verify' button. This gives me 'This media is not good to install from'.
So I decide to change over to 'closest mirror'. I select the proxy form and fill in the data for the proxy.
Anaconda fails to find a mirror.

Things work when I put proxy= on the commandline. But when I have this on the commandline and go into the proxy-form of anaconda, the proxy values don't show up. And in my user strategy, described here, it is not obvious to put proxy data on the commandline as user intended to install from USB.

To me it looks like the anaconda proxy-form is not 'communicating' well with the data in the back office once it has found localmedia.

I admit this is not the most obvious path a user would go, but on the other hand it is not unthinkable a user could go this way.

In my opinion this bug is relevant.
Comment 12 Brian Lane 2013-11-11 19:20:23 EST
Try this updates.img against RC5 (Beta) - http://bcl.fedorapeople.org/updates/967805.img

The problem was that the proxy was being set on the method that was set on entry to the spoke, not on the one that would be set on exit. If you enter the spoke, set it to mirror, exit, re-enter and then set proxy it would work.
Comment 13 A.J. Werkman 2013-11-12 12:50:40 EST
The updates images fixed the problem for me.

Note You need to log in before you can comment on or make changes to this bug.