Bug 967842 - RolloutPlanTestCase#testMaxFailServersPercentageRolloutPlan incorrectly refers to a rollout plan from different test method
RolloutPlanTestCase#testMaxFailServersPercentageRolloutPlan incorrectly refer...
Status: CLOSED DUPLICATE of bug 969381
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Testsuite (Show other bugs)
6.1.0
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: Ivo Studensky
:
Depends On:
Blocks: 969381
  Show dependency treegraph
 
Reported: 2013-05-28 08:15 EDT by Ivo Studensky
Modified: 2013-08-28 04:50 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 969381 (view as bug list)
Environment:
Last Closed: 2013-07-02 02:40:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker WFLY-1403 Major Resolved RolloutPlanTestCase#testMaxFailServersPercentageRolloutPlan incorrectly refers to a rollout plan from different test met... 2014-09-04 02:57:02 EDT

  None (edit)
Description Ivo Studensky 2013-05-28 08:15:58 EDT
Description of problem:
The RolloutPlanTestCase#testMaxFailServersPercentageRolloutPlan in EAP testsuite contains a bug as it refers to 'maxFailOnePlan' plan instead of 'maxFailPercPlan' on line 298.

Version-Release number of selected component (if applicable):
EAP 6.1.0, upstream

How reproducible:
If the test methods are not run in alphabetical order they will fail due to this bug.
Comment 1 JBoss JIRA Server 2013-05-28 10:17:11 EDT
Ivo Studensky <istudens@redhat.com> made a comment on jira WFLY-1403

Created a PR with the fix.
Comment 2 JBoss JIRA Server 2013-05-29 08:15:18 EDT
Ivo Studensky <istudens@redhat.com> made a comment on jira WFLY-1403

Merged.
Comment 4 Ivo Studensky 2013-05-31 06:19:55 EDT
Changing flags from jboss‑eap‑6.1.1 to jboss‑eap‑6.2.0 as this bugzilla is an EAP 6.2 one. I will clone this BZ for 6.1.1 and also create a new PR for EAP 6.1.1.
Comment 5 Ivo Studensky 2013-05-31 07:40:46 EDT
Github PR:

https://github.com/jbossas/jboss-eap/pull/155
Comment 6 Ivo Studensky 2013-07-02 02:40:34 EDT

*** This bug has been marked as a duplicate of bug 969381 ***
Comment 7 Rostislav Svoboda 2013-08-28 04:50:23 EDT
Removing flags

Note You need to log in before you can comment on or make changes to this bug.