Bug 967866 - Allow configuring bridgeless networks on ovirt-node
Allow configuring bridgeless networks on ovirt-node
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.5
Unspecified Unspecified
unspecified Severity high
: rc
: 6.5
Assigned To: Fabian Deutsch
Virtualization Bugs
network
: TestOnly
Depends On: 971410
Blocks: 891056 976691
  Show dependency treegraph
 
Reported: 2013-05-28 08:50 EDT by Moti Asayag
Modified: 2014-01-21 14:34 EST (History)
21 users (show)

See Also:
Fixed In Version: ovirt-node-3.0.1-5.el6
Doc Type: Bug Fix
Doc Text:
When configuring a network on ovirt-node, the created network was implemented as a bridge type with no option to control it otherwise. NICs can now be configured without being the slave of a bridge.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 14:34:57 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Moti Asayag 2013-05-28 08:50:14 EDT
When configuring a network on ovirt-node, the created network is implemented as a bridge type with no option to control it otherwise.

A nic could serve as a storage network, a management network, or another kind of usages which doesn't require the traffic to flow through a bridge device, with its added latency and cpu overhead.

Bridges should be used only when virtual machines are expected to be connected via the edited network (or at least, there should be a means to avoid the bridge elsewhere).
Comment 2 RHEL Product and Program Management 2013-10-13 23:29:48 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 3 Fabian Deutsch 2013-10-21 16:10:18 EDT
NICs can no be configured without being the slave of a bridge.
This feature got available due to the rebase onto 3.0.
Comment 7 Cheryn Tan 2013-11-07 19:34:52 EST
This bug is currently attached to errata RHBA-2013:15277. If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.
* Consequence: What happens when the bug presents.
* Fix: What was done to fix the bug.
* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:

https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes 

Thanks in advance.
Comment 10 errata-xmlrpc 2014-01-21 14:34:57 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0033.html

Note You need to log in before you can comment on or make changes to this bug.