Bug 971410 - [RFE] Allow bridgeless networking
[RFE] Allow bridgeless networking
Status: CLOSED CURRENTRELEASE
Product: oVirt
Classification: Community
Component: ovirt-node (Show other bugs)
3.2
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Fabian Deutsch
:
Depends On:
Blocks: ovirt-node-3.0 967866
  Show dependency treegraph
 
Reported: 2013-06-06 08:58 EDT by Fabian Deutsch
Modified: 2016-04-26 10:32 EDT (History)
11 users (show)

See Also:
Fixed In Version: ovrt-node-3.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-26 05:48:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Fabian Deutsch 2013-06-06 08:58:41 EDT
Description of problem:
Currently Node is creating a bridge by default for it's primary nic.
Sometimes this is not needed, therefor Node should also be able to do a simple net setup by just using a NIC directly.

Feature page:
http://www.ovirt.org/Features/Node/Bridgeless_Networking
Comment 1 Fabian Deutsch 2013-06-10 06:07:15 EDT
This will introduce a new configuration item (tbd) to choose the topology to be configured.
Comment 2 Fabian Deutsch 2013-06-12 14:31:43 EDT
An update:
There are now patches in gerrit which introduce the necessary changes.
With those patches a basic installation works.
A few glitches, reminders for myself:
* Look at biosdevname
* bootif and bootproto are lost after reboot after install
* topology=direct isn't handled correctly
* ui doesn't get all necessary infos (ip, ...)

The patches are a major rewrite of the net backend and the auto-installer part.
Comment 3 Fabian Deutsch 2013-06-13 09:09:00 EDT
(In reply to Fabian Deutsch from comment #2)ks.
> A few glitches, reminders for myself:
> * Look at biosdevname

bisodevname was nat called in any code segment that I touched.

> * bootif and bootproto are lost after reboot after install

That was the default case.
I modified the logic to keep BOOTIF. The reason is to keep the information what bootif the user selected during ai

> * topology=direct isn't handled correctly

Just a bug. Fixed.

> * ui doesn't get all necessary infos (ip, ...)

Was related to the missing BOOTIF entry
Comment 4 Fabian Deutsch 2013-08-26 05:45:51 EDT
The fix for this patch has been merged and is present in the released ovirt-node-3.0.0.

Note You need to log in before you can comment on or make changes to this bug.