Bug 967968 - Forced shutdown freezes virt-manager after serial console was used
Forced shutdown freezes virt-manager after serial console was used
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Cole Robinson
Fedora Extras Quality Assurance
:
: 967961 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-28 13:02 EDT by Filip Skola
Modified: 2016-05-05 00:40 EDT (History)
6 users (show)

See Also:
Fixed In Version: virt-manager-0.10.0-1.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-29 14:14:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Filip Skola 2013-05-28 13:02:15 EDT
Description of problem: SSIA


Version-Release number of selected component (if applicable):
virt-manager-0.10.0-0.4.gitb68faac8.fc19.noarch
virt-manager-common-0.10.0-0.4.gitb68faac8.fc19.noarch

How reproducible: always


Steps to Reproduce:
1. set up VM & serial console as in http://fedoraproject.org/wiki/QA:Testcase_Virt_Serial_Console
2. In the graphical window, select View->Text Consoles->Text Console 1
3. Switch back to graphical console
4. Force guest shut down

Actual results: Message "Error: viewer connection to hypervisor host got refused or disconnected!" appears and virt-manager starts eating 100 % CPU.

Expected results: guest shutdown


Additional info: May be related with bz 967961.
Comment 1 Cole Robinson 2013-06-18 10:51:08 EDT
I think this fixes it:

commit 77fb38e60207874d4293448b64945c3d4ec11c30
Author: Martin Kletzander <mkletzan@redhat.com>
Date:   Tue Jun 11 09:32:13 2013 +0200

    serialcon: Close the console at the end of the stream
Comment 2 Cole Robinson 2013-06-18 10:51:36 EDT
*** Bug 967961 has been marked as a duplicate of this bug. ***
Comment 3 Fedora Update System 2013-06-19 19:01:04 EDT
virt-manager-0.10.0-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/virt-manager-0.10.0-1.fc19
Comment 4 Fedora Update System 2013-06-20 14:00:37 EDT
Package virt-manager-0.10.0-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing virt-manager-0.10.0-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-11349/virt-manager-0.10.0-1.fc19
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2013-06-29 14:14:29 EDT
virt-manager-0.10.0-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.