Bug 968121 - Flask example has an internal server error when uploaded
Flask example has an internal server error when uploaded
Status: CLOSED DUPLICATE of bug 966465
Product: OpenShift Origin
Classification: Red Hat
Component: Templates (Show other bugs)
2.x
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Dan McPherson
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-28 23:00 EDT by bweber14
Modified: 2015-05-14 22:20 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-28 23:02:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description bweber14 2013-05-28 23:00:20 EDT
Description of problem:
Trying to run the Flask example on Openshift, but keep getting an internal server error.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.Start a new python 2.6 app
2.Grab the flask-example from hit
3.Push the example to the site

Actual results:
Internal server error when visiting site

Expected results:
See Hello World output of flask example

Additional info:
Git push log:
remote: Searching for markupsafe
remote: Reading http://mirror1.ops.rhcloud.com/mirror/python/web/simple/markupsafe/
remote: Couldn't find index page for 'markupsafe' (maybe misspelled?)
remote: Scanning index of all packages (this may take a while)
remote: Reading http://mirror1.ops.rhcloud.com/mirror/python/web/simple/
remote: No local packages or download links found for markupsafe
remote: Best match: None
remote: Traceback (most recent call last):
remote: File "/var/lib/openshift/51a3d348e0b8cd687e000259/app-root/runtime/repo/setup.py", line 9, in 
remote: install_requires=['Flask'],

And my app logs on the server look like this:

==> python-2.6/logs/error_log-20130528-000000-EST <== [Tue May 28 08:58:48 2013] [error] [client ] from jinja2.utils import Markup [Tue May 28 08:58:49 2013] [error] [client ] File "/var/lib/openshift/51a3d348e0b8cd687e000259/python-2.6/virtenv/lib/python2.6/site-packages/Jinja2-2.7-py2.6.egg/jinja2/utils.py", line 520, in [Tue May 28 08:58:49 2013] [error] [client ] from markupsafe import Markup, escape, soft_unicode [Tue May 28 08:58:49 2013] [error] [client ] ImportError: No module named markupsafe

So it looks like it is not finding some dependencies for Junja2. I am following the example from this site and using the official Flask example code from GIT.
Comment 1 Dan McPherson 2013-05-28 23:02:26 EDT

*** This bug has been marked as a duplicate of bug 966465 ***

Note You need to log in before you can comment on or make changes to this bug.