Bug 968175 - yum tracebacks with "ImportError: No module named rhsm.config"
yum tracebacks with "ImportError: No module named rhsm.config"
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager (Show other bugs)
5.10
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: candlepin-bugs
IDM QE LIST
:
Depends On:
Blocks: rhsm-rhel510
  Show dependency treegraph
 
Reported: 2013-05-29 03:26 EDT by Jan Hutař
Modified: 2013-06-05 09:22 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-05 09:22:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Hutař 2013-05-29 03:26:26 EDT
Description of problem:
Yum thrown this traceback.


Version-Release number of selected component (if applicable):
yum-3.2.22-40.el5.noarch
subscription-manager-1.8.8-1.el5.x86_64


How reproducible:
1 of 1 attempt


Steps to Reproduce:
1. # yum --disablerepo='*' --enablerepo=myrepo -y -d 100 -e 100 install mytool


Actual results:
Loading "aliases" plugin
Loading "changelog" plugin
Loading "downloadonly" plugin
Loading "fastestmirror" plugin
Loading "filter-data" plugin
Loading "keys" plugin
Loading "kmod" plugin
Loading "list-data" plugin
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in ?
    yummain.user_main(sys.argv[1:], exit_code=True)
  File "/usr/share/yum-cli/yummain.py", line 309, in user_main
    errcode = main(args)
  File "/usr/share/yum-cli/yummain.py", line 157, in main
    base.getOptionsConfig(args)
  File "/usr/share/yum-cli/cli.py", line 187, in getOptionsConfig
    self.conf
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 665, in <lambda>
    conf = property(fget=lambda self: self._getConfig(),
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 238, in _getConfig
    startupconf.pluginconfpath,disabled_plugins,enabled_plugins)
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 409, in doPluginSetup
    plugin_types, confpath, disabled_plugins, enabled_plugins)
  File "/usr/lib/python2.4/site-packages/yum/plugins.py", line 154, in __init__
    self._importplugins(types)
  File "/usr/lib/python2.4/site-packages/yum/plugins.py", line 198, in _importplugins
    self._loadplugin(modulefile, types)
  File "/usr/lib/python2.4/site-packages/yum/plugins.py", line 260, in _loadplugin
    module = imp.load_module(modname, fp, pathname, description)
  File "/usr/lib/yum-plugins/product-id.py", line 24, in ?
    from subscription_manager.injectioninit import init_dep_injection
  File "/usr/share/rhsm/subscription_manager/injectioninit.py", line 17, in ?
    from subscription_manager.cache import ProductStatusCache, StatusCache
  File "/usr/share/rhsm/subscription_manager/cache.py", line 28, in ?
    from rhsm.config import initConfig
ImportError: No module named rhsm.config


Expected results:
There should be no traceback in the output.


Additional info:
This seems to be a regression.

Note You need to log in before you can comment on or make changes to this bug.