Bug 968218 - SELinux is preventing /usr/sbin/unbound-anchor from 'add_name' accesses on the directory root.anchor.1631-0.
SELinux is preventing /usr/sbin/unbound-anchor from 'add_name' accesses on th...
Status: CLOSED DUPLICATE of bug 968216
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2013-05-29 04:55 EDT by Moez Roy
Modified: 2013-05-29 05:50 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2013-05-29 05:50:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Moez Roy 2013-05-29 04:55:06 EDT
Description of problem:
SELinux is preventing /usr/sbin/unbound-anchor from 'add_name' accesses on the directory root.anchor.1631-0.

*****  Plugin catchall (100. confidence) suggests  ***************************

If you believe that unbound-anchor should be allowed add_name access on the root.anchor.1631-0 directory by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
allow this access for now by executing:
# grep unbound-anchor /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:named_t:s0
Target Context                system_u:object_r:named_conf_t:s0
Target Objects                root.anchor.1631-0 [ dir ]
Source                        unbound-anchor
Source Path                   /usr/sbin/unbound-anchor
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           unbound-libs-1.4.19-5.fc19.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.12.1-44.fc19.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 3.9.4-300.fc19.x86_64 #1 SMP Fri
                              May 24 22:17:06 UTC 2013 x86_64 x86_64
Alert Count                   1
First Seen                    2013-05-29 04:53:54 EDT
Last Seen                     2013-05-29 04:53:54 EDT
Local ID                      d10e451d-677d-4bfb-a9d2-14148a6708aa

Raw Audit Messages
type=AVC msg=audit(1369817634.921:405): avc:  denied  { add_name } for  pid=1631 comm="unbound-anchor" name="root.anchor.1631-0" scontext=system_u:system_r:named_t:s0 tcontext=system_u:object_r:named_conf_t:s0 tclass=dir

type=SYSCALL msg=audit(1369817634.921:405): arch=x86_64 syscall=open success=no exit=EACCES a0=7fff4632cbc0 a1=241 a2=1b6 a3=0 items=0 ppid=1 pid=1631 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 ses=4294967295 tty=(none) comm=unbound-anchor exe=/usr/sbin/unbound-anchor subj=system_u:system_r:named_t:s0 key=(null)

Hash: unbound-anchor,named_t,named_conf_t,dir,add_name

Additional info:
reporter:       libreport-2.1.4
hashmarkername: setroubleshoot
kernel:         3.9.4-300.fc19.x86_64
type:           libreport

Potential duplicate: bug 962985
Comment 1 Miroslav Grepl 2013-05-29 05:50:14 EDT

*** This bug has been marked as a duplicate of bug 968216 ***

Note You need to log in before you can comment on or make changes to this bug.