Bug 968335 - minetest update
minetest update
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: minetest (Show other bugs)
19
x86_64 Linux
unspecified Severity low
: ---
: ---
Assigned To: Igor Gnatenko
Fedora Extras Quality Assurance
:
: 979816 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-29 09:27 EDT by James
Modified: 2013-11-10 02:23 EST (History)
5 users (show)

See Also:
Fixed In Version: minetest-0.4.7-1.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-14 13:10:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James 2013-05-29 09:27:48 EDT
package is out of date, latest is 0.4.6, need more recent version to connect to online games
can't successfully compile more recent version from programs website

pheonixfire
Comment 1 Aleksandra Fedorova 2013-05-29 09:48:41 EDT
Thanks for the report. I am going to build an update for F19 this weekend.

The problem with updating it for F17 and F18 is that it could destroy the previous maps made by 0.3.1 version. Thus I am not sure if I should push an update there. I'll check if I can change the default path for the map to something version-specific.
Comment 2 James 2013-05-29 22:57:00 EDT
(In reply to Aleksandra Bookwar from comment #1)
> The problem with updating it for F17 and F18 is that it could destroy the
> previous maps made by 0.3.1 version. Thus I am not sure if I should push an
> update there. I'll check if I can change the default path for the map to
> something version-specific.

I can pass the question on to the minetest forum if you like?

pheonixfire
Comment 3 Gwyn Ciesla 2013-07-19 10:53:10 EDT
*** Bug 979816 has been marked as a duplicate of this bug. ***
Comment 4 Gwyn Ciesla 2013-07-19 10:54:55 EDT
This should be rawhide-only.  I was looking at this, and it fails to build against either jthread 1.2.1 in Fedora or 1.3.1, the current release.  If you're not able to patch it to work with system jthread, you might need to file for a bundling exception with FPC for jthread.  I'm not sure what version minetest is bundling, or if it's modified.
Comment 5 Igor Gnatenko 2013-09-04 02:53:12 EDT
Will update to 0.4.7 today at the night. For F19/F20/Rawhide
Comment 6 Michael Cronenworth 2013-09-06 23:19:09 EDT
Igor, it looks like you updated to 0.4.4 instead of 0.4.7. Is there something preventing a 0.4.7 update?
Comment 7 Igor Gnatenko 2013-09-07 02:13:55 EDT
(In reply to Michael Cronenworth from comment #6)
> Igor, it looks like you updated to 0.4.4 instead of 0.4.7. Is there
> something preventing a 0.4.7 update?
Yes. Unfortunately minetest since 0.4.5 improved modifications to jthread and we can't use minetest w/ system jthread. I've contacted w/ developers minetest, jthread about this. If per week they not do I will write to FPC for exception.
Comment 8 Fedora Update System 2013-10-11 04:54:17 EDT
minetest-0.4.7-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/minetest-0.4.7-1.fc20
Comment 9 Fedora Update System 2013-10-11 12:48:16 EDT
Package minetest-0.4.7-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing minetest-0.4.7-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-18856/minetest-0.4.7-1.fc20
then log in and leave karma (feedback).
Comment 10 Fedora Update System 2013-10-11 16:52:39 EDT
minetest-0.4.7-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/minetest-0.4.7-1.fc19
Comment 11 Fedora Update System 2013-10-14 13:10:56 EDT
minetest-0.4.7-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2013-11-10 02:23:35 EST
minetest-0.4.7-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.