Bug 968356 - [abrt] dnf-0.3.6-1.git24ce938.fc19: __init__.py:364:hashopen:DBNoSuchFileError: (2, 'No such file or directory')
[abrt] dnf-0.3.6-1.git24ce938.fc19: __init__.py:364:hashopen:DBNoSuchFileErro...
Status: CLOSED DUPLICATE of bug 967732
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
abrt_hash:b23f75fb54166cf4ef2130b3003...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-29 10:13 EDT by Michael Schwendt
Modified: 2013-05-29 10:29 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-29 10:29:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (1.83 KB, text/plain)
2013-05-29 10:13 EDT, Michael Schwendt
no flags Details
File: core_backtrace (1.24 KB, text/plain)
2013-05-29 10:13 EDT, Michael Schwendt
no flags Details
File: environ (2.23 KB, text/plain)
2013-05-29 10:14 EDT, Michael Schwendt
no flags Details

  None (edit)
Description Michael Schwendt 2013-05-29 10:13:49 EDT
Description of problem:
Ran "yum -y install dnf ; dnf check-update", but actually any command crashes in the same way. Some initialization is missing.

Version-Release number of selected component:
dnf-0.3.6-1.git24ce938.fc19

Additional info:
reporter:       libreport-2.1.4
cmdline:        /usr/bin/python /bin/dnf update
dso_list:       python-libs-2.7.5-1.fc19.x86_64
executable:     /bin/dnf
kernel:         3.9.4-300.fc19.x86_64
runlevel:       N 5
uid:            0

Truncated backtrace:
__init__.py:364:hashopen:DBNoSuchFileError: (2, 'No such file or directory')

Traceback (most recent call last):
  File "/bin/dnf", line 35, in <module>
    main.user_main(sys.argv[1:], exit_code=True)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 304, in user_main
    errcode = main(args)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 39, in main
    _main(base, args)
  File "/usr/lib/python2.7/site-packages/dnf/yum/base.py", line 125, in __exit__
    self.close()
  File "/usr/lib/python2.7/site-packages/dnf/yum/base.py", line 232, in close
    self._store_persistent_data()
  File "/usr/lib/python2.7/site-packages/dnf/yum/base.py", line 168, in _store_persistent_data
    self._persistor.set_expired_repos(expired)
  File "/usr/lib/python2.7/site-packages/dnf/persistor.py", line 60, in set_expired_repos
    shelf = self._expired_repos()
  File "/usr/lib/python2.7/site-packages/dnf/persistor.py", line 39, in _expired_repos
    return shelve.open(path)
  File "/usr/lib64/python2.7/shelve.py", line 239, in open
    return DbfilenameShelf(filename, flag, protocol, writeback)
  File "/usr/lib64/python2.7/shelve.py", line 223, in __init__
    Shelf.__init__(self, anydbm.open(filename, flag), protocol, writeback)
  File "/usr/lib64/python2.7/anydbm.py", line 85, in open
    return mod.open(file, flag, mode)
  File "/usr/lib64/python2.7/dbhash.py", line 18, in open
    return bsddb.hashopen(file, flag, mode)
  File "/usr/lib64/python2.7/bsddb/__init__.py", line 364, in hashopen
    d.open(file, db.DB_HASH, flags, mode)
DBNoSuchFileError: (2, 'No such file or directory')

Local variables in innermost frame:
lorder: None
e: <DBEnv object at 0x1972c60>
d: <DB object at 0x18cd880>
flag: 'c'
ffactor: None
pgsize: None
flags: 33
mode: 438
file: '/var/cache/dnf/x86_64/19/expired_repos'
cachesize: None
nelem: None
hflags: 0
Comment 1 Michael Schwendt 2013-05-29 10:13:53 EDT
Created attachment 754415 [details]
File: backtrace
Comment 2 Michael Schwendt 2013-05-29 10:13:56 EDT
Created attachment 754416 [details]
File: core_backtrace
Comment 3 Michael Schwendt 2013-05-29 10:14:00 EDT
Created attachment 754417 [details]
File: environ
Comment 4 Ales Kozumplik 2013-05-29 10:29:01 EDT

*** This bug has been marked as a duplicate of bug 967732 ***

Note You need to log in before you can comment on or make changes to this bug.