Bug 967732 - [abrt] dnf-0.3.6-1.git24ce938.fc19: __init__.py:364:hashopen:DBNoSuchFileError: (2, 'Datei oder Verzeichnis nicht gefunden')
[abrt] dnf-0.3.6-1.git24ce938.fc19: __init__.py:364:hashopen:DBNoSuchFileErro...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ales Kozumplik
Fedora Extras Quality Assurance
abrt_hash:5d954f4daa2f3dd7ac5e4071763...
:
: 968356 968576 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-28 03:59 EDT by Heiko Adams
Modified: 2014-09-30 19:41 EDT (History)
5 users (show)

See Also:
Fixed In Version: hawkey-0.3.13-2.git15db39f.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-07 00:38:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (1.87 KB, text/plain)
2013-05-28 03:59 EDT, Heiko Adams
no flags Details
File: core_backtrace (1.25 KB, text/plain)
2013-05-28 03:59 EDT, Heiko Adams
no flags Details
File: environ (2.89 KB, text/plain)
2013-05-28 03:59 EDT, Heiko Adams
no flags Details

  None (edit)
Description Heiko Adams 2013-05-28 03:59:28 EDT
Description of problem:
Just ran dnf as a normal user and without any parameters provided

Version-Release number of selected component:
dnf-0.3.6-1.git24ce938.fc19

Additional info:
reporter:       libreport-2.1.4
cmdline:        /usr/bin/python /usr/bin/dnf
dso_list:       python-libs-2.7.5-1.fc19.x86_64
executable:     /usr/bin/dnf
kernel:         3.9.4-300.fc19.x86_64
runlevel:       N 5
uid:            1000

Truncated backtrace:
__init__.py:364:hashopen:DBNoSuchFileError: (2, 'Datei oder Verzeichnis nicht gefunden')

Traceback (most recent call last):
  File "/usr/bin/dnf", line 35, in <module>
    main.user_main(sys.argv[1:], exit_code=True)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 304, in user_main
    errcode = main(args)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 39, in main
    _main(base, args)
  File "/usr/lib/python2.7/site-packages/dnf/yum/base.py", line 125, in __exit__
    self.close()
  File "/usr/lib/python2.7/site-packages/dnf/yum/base.py", line 232, in close
    self._store_persistent_data()
  File "/usr/lib/python2.7/site-packages/dnf/yum/base.py", line 168, in _store_persistent_data
    self._persistor.set_expired_repos(expired)
  File "/usr/lib/python2.7/site-packages/dnf/persistor.py", line 60, in set_expired_repos
    shelf = self._expired_repos()
  File "/usr/lib/python2.7/site-packages/dnf/persistor.py", line 39, in _expired_repos
    return shelve.open(path)
  File "/usr/lib64/python2.7/shelve.py", line 239, in open
    return DbfilenameShelf(filename, flag, protocol, writeback)
  File "/usr/lib64/python2.7/shelve.py", line 223, in __init__
    Shelf.__init__(self, anydbm.open(filename, flag), protocol, writeback)
  File "/usr/lib64/python2.7/anydbm.py", line 85, in open
    return mod.open(file, flag, mode)
  File "/usr/lib64/python2.7/dbhash.py", line 18, in open
    return bsddb.hashopen(file, flag, mode)
  File "/usr/lib64/python2.7/bsddb/__init__.py", line 364, in hashopen
    d.open(file, db.DB_HASH, flags, mode)
DBNoSuchFileError: (2, 'Datei oder Verzeichnis nicht gefunden')

Local variables in innermost frame:
lorder: None
e: <DBEnv object at 0x258ef38>
d: <DB object at 0x2508dd8>
flag: 'c'
ffactor: None
pgsize: None
flags: 33
mode: 438
file: '/var/tmp/dnf-heiko-5DRQ3A/x86_64/19/expired_repos'
cachesize: None
nelem: None
hflags: 0
Comment 1 Heiko Adams 2013-05-28 03:59:32 EDT
Created attachment 753769 [details]
File: backtrace
Comment 2 Heiko Adams 2013-05-28 03:59:35 EDT
Created attachment 753770 [details]
File: core_backtrace
Comment 3 Heiko Adams 2013-05-28 03:59:39 EDT
Created attachment 753771 [details]
File: environ
Comment 4 Ales Kozumplik 2013-05-29 07:34:51 EDT
Fixed by 6c8b803, I'll make a new update today as this bites many users.
Comment 5 Fedora Update System 2013-05-29 08:53:56 EDT
hawkey-0.3.13-2.git15db39f.fc19, dnf-0.3.7-1.gitf8bdc98.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/FEDORA-2013-9385/hawkey-0.3.13-2.git15db39f.fc19,dnf-0.3.7-1.gitf8bdc98.fc19
Comment 6 Ales Kozumplik 2013-05-29 10:29:01 EDT
*** Bug 968356 has been marked as a duplicate of this bug. ***
Comment 7 Fedora Update System 2013-05-29 13:49:20 EDT
Package hawkey-0.3.13-2.git15db39f.fc19, dnf-0.3.7-1.gitf8bdc98.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing hawkey-0.3.13-2.git15db39f.fc19 dnf-0.3.7-1.gitf8bdc98.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-9385/hawkey-0.3.13-2.git15db39f.fc19,dnf-0.3.7-1.gitf8bdc98.fc19
then log in and leave karma (feedback).
Comment 8 Ales Kozumplik 2013-05-30 01:29:40 EDT
*** Bug 968576 has been marked as a duplicate of this bug. ***
Comment 9 Fedora Update System 2013-06-07 00:38:34 EDT
hawkey-0.3.13-2.git15db39f.fc19, dnf-0.3.7-1.gitf8bdc98.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.