Bug 968531 - nodejs-ansi-0.1.2-7.el6 not providing npm(ansi) = 0.1.2
nodejs-ansi-0.1.2-7.el6 not providing npm(ansi) = 0.1.2
Status: CLOSED ERRATA
Product: Fedora EPEL
Classification: Fedora
Component: nodejs-ansi (Show other bugs)
el6
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: T.C. Hollingsworth
Fedora Extras Quality Assurance
:
Depends On: 968776
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-29 16:06 EDT by Troy Dawson
Modified: 2013-06-03 08:22 EDT (History)
2 users (show)

See Also:
Fixed In Version: nodejs-ansi-0.1.2-7.el6.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-31 13:55:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Troy Dawson 2013-05-29 16:06:52 EDT
Description of problem:
The latest build of nodejs-ansi on EPEL6 is not providing npm(ansi)
This breaks dependancies, so packages that usually depend on npm(ansi) are not able to install

Version-Release number of selected component (if applicable):
nodejs-ansi-0.1.2-7.el6 - only this version (which is the latest)


How reproducible:
100%

Steps to Reproduce:
1. yum install nodejs-npmlog
2. Failure
3.

Actual results:
Error: Package: nodejs-npmlog-0.0.2-4.el6.noarch (build)
             Requires: npm(ansi) < 0.2
Error: Package: nodejs-npmlog-0.0.2-4.el6.noarch (build)
             Requires: npm(ansi) >= 0.1.2

Expected results:
nodejs-npmlog should install, along with nodejs-ansi

Additional info:
It is easiest to see the problem if we look at the koji information page, in the Provides section, for both this version, and the version right before it.

nodejs-ansi-0.1.2-6.el6 (works correctly)
http://koji.fedoraproject.org/koji/rpminfo?rpmID=3918036

nodejs-ansi-0.1.2-7.el6 (fails)
http://koji.fedoraproject.org/koji/rpminfo?rpmID=3978345
Comment 1 T.C. Hollingsworth 2013-05-29 21:16:22 EDT
Sorry, I should have tested this more in the other branches, but since this update just removed a single PNG for legal reasons, I figured "hey, what could go wrong?".  Famous last words...

A straight rebuild seems to fix this particular issue, but I'm still going to investigate the root cause to make sure something like this doesn't creep up in the future.  I opened bug 968776 so this doesn't drop off my radar.

Please provide karma to the update once it's pushed to we can get this pushed stable ASAP and unbreak the dependencies.  Thanks!
Comment 2 Fedora Update System 2013-05-29 21:46:28 EDT
nodejs-ansi-0.1.2-7.el6.1 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/nodejs-ansi-0.1.2-7.el6.1
Comment 3 T.C. Hollingsworth 2013-05-29 22:06:16 EDT
Just for some more background on this issue:  part of the reason this never got noticed is because RPM can't handle ExclusiveArch in noarch packages, so there's no way to block noarch node.js packages from trying to be used on ppc64.  As a result, every week every EPEL Node.js package maintainer gets a bunch of broken dependencies on ppc64 e-mails (for me that means I get ~200 e-mails).

That means that I probably got notified about this, but I never noticed it because the other 199 e-mails were crap and I just sent them all to the circular file.  :-(

For more information on this issue, see our mailing list discussion:
https://lists.fedoraproject.org/pipermail/nodejs/2013-May/000017.html

In the interim I'll try and be more proactive about checking for dependency issues manually, since I cannot rely on the buildsystem's automated checks for it at this time.

Sorry for the trouble this caused.  I put out a call for karma to the rest of the Node.js team so hopefully we can get the fixed build pushed ASAP.
Comment 4 Fedora Update System 2013-05-31 13:55:22 EDT
nodejs-ansi-0.1.2-7.el6.1 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.