Bug 968576 - [abrt] dnf-0.3.6-1.git24ce938.fc19: __init__.py:364:hashopen:DBNoSuchFileError: (2, 'Adres\xc3\xa1\xc5\x99 nebo soubor neexistuje')
[abrt] dnf-0.3.6-1.git24ce938.fc19: __init__.py:364:hashopen:DBNoSuchFileErro...
Status: CLOSED DUPLICATE of bug 967732
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
19
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
abrt_hash:d388a8d4fcf140c2818583e8ccf...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-29 17:11 EDT by Jiří Martínek
Modified: 2013-05-30 01:29 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-30 01:29:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (1.86 KB, text/plain)
2013-05-29 17:11 EDT, Jiří Martínek
no flags Details
File: core_backtrace (1.24 KB, text/plain)
2013-05-29 17:11 EDT, Jiří Martínek
no flags Details
File: environ (112 bytes, text/plain)
2013-05-29 17:11 EDT, Jiří Martínek
no flags Details

  None (edit)
Description Jiří Martínek 2013-05-29 17:11:13 EDT
Version-Release number of selected component:
dnf-0.3.6-1.git24ce938.fc19

Additional info:
reporter:       libreport-2.1.4
cmdline:        /usr/bin/python /usr/bin/dnf -v makecache timer
dso_list:       python-libs-2.7.5-1.fc19.i686
executable:     /usr/bin/dnf
kernel:         3.9.4-300.fc19.i686
runlevel:       N 5
uid:            0

Truncated backtrace:
__init__.py:364:hashopen:DBNoSuchFileError: (2, 'Adres\xc3\xa1\xc5\x99 nebo soubor neexistuje')

Traceback (most recent call last):
  File "/usr/bin/dnf", line 35, in <module>
    main.user_main(sys.argv[1:], exit_code=True)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 304, in user_main
    errcode = main(args)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 39, in main
    _main(base, args)
  File "/usr/lib/python2.7/site-packages/dnf/yum/base.py", line 125, in __exit__
    self.close()
  File "/usr/lib/python2.7/site-packages/dnf/yum/base.py", line 232, in close
    self._store_persistent_data()
  File "/usr/lib/python2.7/site-packages/dnf/yum/base.py", line 168, in _store_persistent_data
    self._persistor.set_expired_repos(expired)
  File "/usr/lib/python2.7/site-packages/dnf/persistor.py", line 60, in set_expired_repos
    shelf = self._expired_repos()
  File "/usr/lib/python2.7/site-packages/dnf/persistor.py", line 39, in _expired_repos
    return shelve.open(path)
  File "/usr/lib/python2.7/shelve.py", line 239, in open
    return DbfilenameShelf(filename, flag, protocol, writeback)
  File "/usr/lib/python2.7/shelve.py", line 223, in __init__
    Shelf.__init__(self, anydbm.open(filename, flag), protocol, writeback)
  File "/usr/lib/python2.7/anydbm.py", line 85, in open
    return mod.open(file, flag, mode)
  File "/usr/lib/python2.7/dbhash.py", line 18, in open
    return bsddb.hashopen(file, flag, mode)
  File "/usr/lib/python2.7/bsddb/__init__.py", line 364, in hashopen
    d.open(file, db.DB_HASH, flags, mode)
DBNoSuchFileError: (2, 'Adres\xc3\xa1\xc5\x99 nebo soubor neexistuje')

Local variables in innermost frame:
lorder: None
e: <DBEnv object at 0x9c2b678>
d: <DB object at 0x9c1a340>
flag: 'c'
ffactor: None
pgsize: None
flags: 33
mode: 438
file: '/var/cache/dnf/i386/19/expired_repos'
cachesize: None
nelem: None
hflags: 0
Comment 1 Jiří Martínek 2013-05-29 17:11:17 EDT
Created attachment 754540 [details]
File: backtrace
Comment 2 Jiří Martínek 2013-05-29 17:11:24 EDT
Created attachment 754541 [details]
File: core_backtrace
Comment 3 Jiří Martínek 2013-05-29 17:11:28 EDT
Created attachment 754542 [details]
File: environ
Comment 4 Ales Kozumplik 2013-05-30 01:29:40 EDT

*** This bug has been marked as a duplicate of bug 967732 ***

Note You need to log in before you can comment on or make changes to this bug.